aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql322-server/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/mysql322-server/Makefile')
-rw-r--r--databases/mysql322-server/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/databases/mysql322-server/Makefile b/databases/mysql322-server/Makefile
index a5fb7be60bc4..89f2b9222b13 100644
--- a/databases/mysql322-server/Makefile
+++ b/databases/mysql322-server/Makefile
@@ -7,6 +7,7 @@
PORTNAME?= ${MASTERPORTNAME}
PORTVERSION= 3.22.32
+PORTREVISION?= 1
CATEGORIES= databases
MASTER_SITES= http://www.wipol.uni-bonn.de/MySQL/Downloads/MySQL-3.22/ \
http://www.mysql.net/Downloads/MySQL-3.22/ \
@@ -34,6 +35,9 @@ CONFIGURE_ENV+= PERL=${PERL} \
PERL5=${PERL} \
INSTALL_SCRIPT="${INSTALL_SCRIPT}" \
CONFIGURE_ARGS="${CONFIGURE_ARGS}"
+# without including these flags mysqld may crash under heavy load
+# and multiple connections at the same time
+CXXFLAGS= ${CFLAGS} -felide-constructors -fno-exceptions -fno-rtti
# MySQL-Server part
.if !defined(CLIENT_ONLY)