aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql40-server/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/mysql40-server/Makefile')
-rw-r--r--databases/mysql40-server/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/databases/mysql40-server/Makefile b/databases/mysql40-server/Makefile
index 4152d4cb202f..c50762a7dfbd 100644
--- a/databases/mysql40-server/Makefile
+++ b/databases/mysql40-server/Makefile
@@ -69,10 +69,10 @@ CONFIGURE_ARGS+=-D_THREAD_SAFE -I${LOCALBASE}/include/pthread/linuxthreads
CFLAGS+= -D__USE_UNIX98 -D_REENTRANT -D_THREAD_SAFE
CFLAGS+= -I${LOCALBASE}/include/pthread/linuxthreads
.if ${OSVERSION} > 500000
-LIB_DEPENDS+= lthread.3:${PORTSDIR}/devel/linuxthreads
+LIB_DEPENDS+= lthread.[35]:${PORTSDIR}/devel/linuxthreads
CONFIGURE_ARGS+=-L${LOCALBASE}/lib -llthread -llgcc_r -llstdc++ -llsupc++'
.else
-LIB_DEPENDS+= lthread.2:${PORTSDIR}/devel/linuxthreads
+LIB_DEPENDS+= lthread.[24]:${PORTSDIR}/devel/linuxthreads
CONFIGURE_ARGS+=-L${LOCALBASE}/lib -llthread -llgcc_r'
.endif
.else