aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql56-client
diff options
context:
space:
mode:
Diffstat (limited to 'databases/mysql56-client')
-rw-r--r--databases/mysql56-client/Makefile2
-rw-r--r--databases/mysql56-client/files/patch-client_mysql.cc25
-rw-r--r--databases/mysql56-client/files/patch-cmake_readline.cmake17
3 files changed, 43 insertions, 1 deletions
diff --git a/databases/mysql56-client/Makefile b/databases/mysql56-client/Makefile
index 7da918eb3d9c..8071882371ee 100644
--- a/databases/mysql56-client/Makefile
+++ b/databases/mysql56-client/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mysql
-PORTREVISION?= 3
+PORTREVISION?= 4
PKGNAMESUFFIX= 56-client
COMMENT= Multithreaded SQL database (client)
diff --git a/databases/mysql56-client/files/patch-client_mysql.cc b/databases/mysql56-client/files/patch-client_mysql.cc
new file mode 100644
index 000000000000..5a03f22b249f
--- /dev/null
+++ b/databases/mysql56-client/files/patch-client_mysql.cc
@@ -0,0 +1,25 @@
+--- client/mysql.cc.orig 2016-09-30 11:41:40 UTC
++++ client/mysql.cc
+@@ -2738,9 +2738,11 @@ static void initialize_readline (char *n
+ #ifdef HAVE_LOCALE_H
+ setlocale(LC_ALL,""); /* so as libedit use isprint */
+ #endif
+- rl_attempted_completion_function= (CPPFunction*)&new_mysql_completion;
+- rl_completion_entry_function= &no_completion;
++ rl_attempted_completion_function= (rl_completion_func_t*)&new_mysql_completion;
++ rl_completion_entry_function= (rl_compentry_func_t*)&no_completion;
++ /*
+ rl_add_defun("magic-space", (Function*)&fake_magic_space, -1);
++ */
+ #else
+ rl_attempted_completion_function= (CPPFunction*)&new_mysql_completion;
+ rl_completion_entry_function= &no_completion;
+@@ -2759,7 +2761,7 @@ static char **new_mysql_completion(const
+ int end MY_ATTRIBUTE((unused)))
+ {
+ if (!status.batch && !quick)
+-#if defined(USE_NEW_READLINE_INTERFACE)
++#if defined(USE_NEW_READLINE_INTERFACE) || defined(USE_LIBEDIT_INTERFACE)
+ return rl_completion_matches(text, new_command_generator);
+ #else
+ return completion_matches((char *)text, (CPFunction *)new_command_generator);
diff --git a/databases/mysql56-client/files/patch-cmake_readline.cmake b/databases/mysql56-client/files/patch-cmake_readline.cmake
new file mode 100644
index 000000000000..4c251b15fc56
--- /dev/null
+++ b/databases/mysql56-client/files/patch-cmake_readline.cmake
@@ -0,0 +1,17 @@
+--- cmake/readline.cmake.orig 2016-09-30 11:41:40 UTC
++++ cmake/readline.cmake
+@@ -173,11 +173,11 @@ MACRO (FIND_SYSTEM_EDITLINE)
+ #include <readline.h>
+ int main(int argc, char **argv)
+ {
+- typedef int MYFunction(const char*, int);
++ typedef char *MYFunction(const char*, int);
+ MYFunction* myf= rl_completion_entry_function;
+- int res= (myf)(NULL, 0);
++ char *res= (myf)(NULL, 0);
+ completion_matches(0,0);
+- return res;
++ return (res != NULL);
+ }"
+ EDITLINE_HAVE_COMPLETION)
+