aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql60-server/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/mysql60-server/Makefile')
-rw-r--r--databases/mysql60-server/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/databases/mysql60-server/Makefile b/databases/mysql60-server/Makefile
index 7366666f55dd..0a519bcc2c15 100644
--- a/databases/mysql60-server/Makefile
+++ b/databases/mysql60-server/Makefile
@@ -44,7 +44,8 @@ CONFIGURE_ARGS= --localstatedir=${DB_DIR} \
--with-mysqlfs \
--with-vio \
--with-low-memory \
- --with-comment='FreeBSD port: ${PKGNAME}'
+ --with-comment='FreeBSD port: ${PKGNAME}' \
+ --enable-thread-safe-client
.include <bsd.port.pre.mk>
@@ -79,9 +80,6 @@ LIB_DEPENDS+= lthread.3:${PORTSDIR}/devel/linuxthreads
LIB_DEPENDS+= lthread.2:${PORTSDIR}/devel/linuxthreads
.endif
.endif
-.if defined(THREAD_SAFE_CLIENT)
-CONFIGURE_ARGS+=--enable-thread-safe-client
-.endif
CFLAGS+= -O3 -fno-omit-frame-pointer
CXXFLAGS= ${CFLAGS} -felide-constructors -fno-rtti