aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql60-server
diff options
context:
space:
mode:
Diffstat (limited to 'databases/mysql60-server')
-rw-r--r--databases/mysql60-server/Makefile5
-rw-r--r--databases/mysql60-server/distinfo6
-rw-r--r--databases/mysql60-server/files/patch-configure24
-rw-r--r--databases/mysql60-server/files/patch-storage_ndb_src_kernel_Makefile.in21
-rw-r--r--databases/mysql60-server/files/patch-storage_ndb_src_ndbapi_Makefile.in12
-rw-r--r--databases/mysql60-server/pkg-plist34
6 files changed, 92 insertions, 10 deletions
diff --git a/databases/mysql60-server/Makefile b/databases/mysql60-server/Makefile
index 216dcba70a3c..96829f87ba7d 100644
--- a/databases/mysql60-server/Makefile
+++ b/databases/mysql60-server/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME?= mysql
-PORTVERSION= 6.0.8
+PORTVERSION= 6.0.9
PORTREVISION?= 0
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_MYSQL}
@@ -24,6 +24,7 @@ USE_GMAKE= yes
CONFIGURE_ARGS= --localstatedir=/var/db/mysql \
--infodir=${PREFIX}/info \
--mandir=${PREFIX}/man \
+ --with-zlib-dir=/usr \
--without-debug \
--without-readline \
--without-libedit \
@@ -167,7 +168,7 @@ CONFIGURE_ARGS+=--without-server
post-patch:
@${REINPLACE_CMD} -e "s|SUBDIRS =|SUBDIRS = include sql-common scripts strings regex mysys dbug extra libmysql libmysql_r client @man_dirs@|g" ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e "s|install-exec-am: install-pkglibLIBRARIES|install-exec-am:|g" ${WRKSRC}/strings/Makefile.in ${WRKSRC}/mysys/Makefile.in ${WRKSRC}/dbug/Makefile.in
+ @${REINPLACE_CMD} -e "s|install-exec-am: install-pkglibLTLIBRARIES|install-exec-am:|g" ${WRKSRC}/strings/Makefile.in ${WRKSRC}/mysys/Makefile.in ${WRKSRC}/dbug/Makefile.in
@${REINPLACE_CMD} -e "s|bin_SCRIPTS =|bin_SCRIPTS = mysql_config mysql_fix_privilege_tables mysqlbug|g" ${WRKSRC}/scripts/Makefile.in
@${REINPLACE_CMD} -e "s|dist_pkgdata_DATA =|dist_pkgdata_DATA = mysql_fix_privilege_tables.sql|g" ${WRKSRC}/scripts/Makefile.in
@${REINPLACE_CMD} -e "s|man1_MANS =|man1_MANS = ${MAN1}|g" ${WRKSRC}/man/Makefile.in
diff --git a/databases/mysql60-server/distinfo b/databases/mysql60-server/distinfo
index 87e4579f12c3..cec3afe5db86 100644
--- a/databases/mysql60-server/distinfo
+++ b/databases/mysql60-server/distinfo
@@ -1,3 +1,3 @@
-MD5 (mysql-6.0.8-alpha.tar.gz) = 04e510c4fe038ceb7ddc28873ef3ab60
-SHA256 (mysql-6.0.8-alpha.tar.gz) = adcc797ae80bbea7e74e7eb3aa13e8ab53ec6b56c3ba882a13fc54cb246c6e42
-SIZE (mysql-6.0.8-alpha.tar.gz) = 31006870
+MD5 (mysql-6.0.9-alpha.tar.gz) = e2c4c820356f4bdfbf50ec5b7c788140
+SHA256 (mysql-6.0.9-alpha.tar.gz) = 0888b9c822aa3f84c63e819f37df8081553c9f429dfc5a1cf19be16a9f69807f
+SIZE (mysql-6.0.9-alpha.tar.gz) = 35513752
diff --git a/databases/mysql60-server/files/patch-configure b/databases/mysql60-server/files/patch-configure
index abfacbb91222..c20f77831590 100644
--- a/databases/mysql60-server/files/patch-configure
+++ b/databases/mysql60-server/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Sat May 26 12:22:14 2007
-+++ configure Fri Jun 1 07:53:46 2007
-@@ -20394,8 +20394,6 @@
+--- configure.orig 2009-01-02 16:59:54.000000000 +0100
++++ configure 2009-01-18 10:14:57.000000000 +0100
+@@ -21832,8 +21832,6 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
@@ -9,7 +9,23 @@
# Prevent multiple expansion
-@@ -26935,8 +26933,8 @@
+@@ -27046,13 +27044,14 @@
+ { $as_echo "$as_me:$LINENO: result: using bundled zlib" >&5
+ $as_echo "using bundled zlib" >&6; }
+ ;;
+- "")
++ *)
+ ZLIB_INCLUDES=""
+ ZLIB_LIBS="-lz"
+
+ save_CPPFLAGS="$CPPFLAGS"
+ save_LIBS="$LIBS"
+ CPPFLAGS="$ZLIB_INCLUDES $CPPFLAGS"
++LIBS="$ZLIB_LIBS $LIBS"
+ if test X"$with_server" = Xno
+ then
+ zlibsym=zlibVersion
+@@ -29214,8 +29213,8 @@
# Some system specific hacks
#
diff --git a/databases/mysql60-server/files/patch-storage_ndb_src_kernel_Makefile.in b/databases/mysql60-server/files/patch-storage_ndb_src_kernel_Makefile.in
new file mode 100644
index 000000000000..ffbdc44702e3
--- /dev/null
+++ b/databases/mysql60-server/files/patch-storage_ndb_src_kernel_Makefile.in
@@ -0,0 +1,21 @@
+--- storage/ndb/src/kernel/Makefile.in.orig 2009-01-18 12:52:07.000000000 +0100
++++ storage/ndb/src/kernel/Makefile.in 2009-01-18 12:52:20.000000000 +0100
+@@ -120,8 +120,7 @@
+ $(top_builddir)/storage/ndb/src/common/util/libgeneral.la \
+ $(top_builddir)/dbug/libdbuglt.la \
+ $(top_builddir)/mysys/libmysyslt.la \
+- $(top_builddir)/strings/libmystringslt.la \
+- $(top_builddir)/zlib/libzlt.la
++ $(top_builddir)/strings/libmystringslt.la
+ DEFAULT_INCLUDES = -I.@am__isrc@ -I$(top_builddir)/include
+ depcomp = $(SHELL) $(top_srcdir)/depcomp
+ am__depfiles_maybe = depfiles
+@@ -498,7 +497,7 @@
+ $(top_builddir)/dbug/libdbuglt.la \
+ $(top_builddir)/mysys/libmysyslt.la \
+ $(top_builddir)/strings/libmystringslt.la \
+- $(top_builddir)/zlib/libzlt.la @NDB_SCI_LIBS@
++ @NDB_SCI_LIBS@
+ NDB_CXXFLAGS = @ndb_cxxflags_fix@ $(NDB_CXXFLAGS_LOC)
+ NDB_AM_CXXFLAGS := $(AM_CXXFLAGS)
+ AM_CXXFLAGS = $(NDB_AM_CXXFLAGS) $(NDB_CXXFLAGS)
diff --git a/databases/mysql60-server/files/patch-storage_ndb_src_ndbapi_Makefile.in b/databases/mysql60-server/files/patch-storage_ndb_src_ndbapi_Makefile.in
new file mode 100644
index 000000000000..44dbc194c9ac
--- /dev/null
+++ b/databases/mysql60-server/files/patch-storage_ndb_src_ndbapi_Makefile.in
@@ -0,0 +1,12 @@
+--- storage/ndb/src/ndbapi/Makefile.in.orig 2009-01-18 12:30:08.000000000 +0100
++++ storage/ndb/src/ndbapi/Makefile.in 2009-01-18 12:30:38.000000000 +0100
+@@ -530,8 +530,7 @@
+ ndberror_check_LDFLAGS = \
+ $(top_builddir)/dbug/libdbuglt.la \
+ $(top_builddir)/mysys/libmysyslt.la \
+- $(top_builddir)/strings/libmystringslt.la \
+- $(top_builddir)/zlib/libzlt.la
++ $(top_builddir)/strings/libmystringslt.la
+
+ all: all-am
+
diff --git a/databases/mysql60-server/pkg-plist b/databases/mysql60-server/pkg-plist
index b4f9615e156e..05df34447de5 100644
--- a/databases/mysql60-server/pkg-plist
+++ b/databases/mysql60-server/pkg-plist
@@ -69,16 +69,19 @@ bin/resolveip
%%NDB%%include/mysql/storage/ndb/ndbapi/ndb_opt_defaults.h
%%NDB%%include/mysql/storage/ndb/ndbapi/ndberror.h
lib/mysql/libdbug.a
+lib/mysql/libdbug.la
lib/mysql/libheap.a
lib/mysql/libmaria.a
lib/mysql/libmyisam.a
lib/mysql/libmyisammrg.a
lib/mysql/libmystrings.a
+lib/mysql/libmystrings.la
lib/mysql/libmysys.a
+lib/mysql/libmysys.la
%%NDB%%lib/mysql/libndbclient.a
%%NDB%%lib/mysql/libndbclient.la
%%NDB%%lib/mysql/libndbclient.so
-%%NDB%%lib/mysql/libndbclient.so.3
+%%NDB%%lib/mysql/libndbclient.so.4
lib/mysql/libvio.a
lib/mysql/plugin/ha_example.a
lib/mysql/plugin/ha_example.la
@@ -159,6 +162,32 @@ libexec/mysqld
%%DATADIR%%/slovak/errmsg.sys
%%DATADIR%%/spanish/errmsg.sys
%%DATADIR%%/swedish/errmsg.sys
+%%NDB%%%%DATADIR%%/swig/globals.i
+%%NDB%%%%DATADIR%%/swig/mgmapi/ClusterState.i
+%%NDB%%%%DATADIR%%/swig/mgmapi/NdbLogEvent.i
+%%NDB%%%%DATADIR%%/swig/mgmapi/NdbLogEventManager.i
+%%NDB%%%%DATADIR%%/swig/mgmapi/NdbMgm.i
+%%NDB%%%%DATADIR%%/swig/mgmapi/NdbMgmFactory.i
+%%NDB%%%%DATADIR%%/swig/mgmapi/NdbMgmReply.i
+%%NDB%%%%DATADIR%%/swig/mgmapi/NodeState.i
+%%NDB%%%%DATADIR%%/swig/mgmapi/events.i
+%%NDB%%%%DATADIR%%/swig/mgmapi/listeners.i
+%%NDB%%%%DATADIR%%/swig/mgmapi/mgmglobals.i
+%%NDB%%%%DATADIR%%/swig/ndbapi/Ndb.i
+%%NDB%%%%DATADIR%%/swig/ndbapi/NdbBlob.i
+%%NDB%%%%DATADIR%%/swig/ndbapi/NdbClusterConnection.i
+%%NDB%%%%DATADIR%%/swig/ndbapi/NdbDictionary.i
+%%NDB%%%%DATADIR%%/swig/ndbapi/NdbError.i
+%%NDB%%%%DATADIR%%/swig/ndbapi/NdbEventOperation.i
+%%NDB%%%%DATADIR%%/swig/ndbapi/NdbFactory.i
+%%NDB%%%%DATADIR%%/swig/ndbapi/NdbIndexOperation.i
+%%NDB%%%%DATADIR%%/swig/ndbapi/NdbIndexScanOperation.i
+%%NDB%%%%DATADIR%%/swig/ndbapi/NdbOperation.i
+%%NDB%%%%DATADIR%%/swig/ndbapi/NdbRecAttr.i
+%%NDB%%%%DATADIR%%/swig/ndbapi/NdbScanFilter.i
+%%NDB%%%%DATADIR%%/swig/ndbapi/NdbScanOperation.i
+%%NDB%%%%DATADIR%%/swig/ndbapi/NdbTransaction.i
+%%NDB%%%%DATADIR%%/swig/ndbapi/ndbglobals.i
%%DATADIR%%/ukrainian/errmsg.sys
%%NDB%%@dirrm include/mysql/storage/ndb/mgmapi
%%NDB%%@dirrm include/mysql/storage/ndb/ndbapi
@@ -190,5 +219,8 @@ libexec/mysqld
@dirrm %%DATADIR%%/slovak
@dirrm %%DATADIR%%/spanish
@dirrm %%DATADIR%%/swedish
+%%NDB%%@dirrm %%DATADIR%%/swig/mgmapi
+%%NDB%%@dirrm %%DATADIR%%/swig/ndbapi
+%%NDB%%@dirrm %%DATADIR%%/swig
@dirrm %%DATADIR%%/ukrainian
@dirrmtry %%DATADIR%%