aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql_last_value/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/mysql_last_value/Makefile')
-rw-r--r--databases/mysql_last_value/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/databases/mysql_last_value/Makefile b/databases/mysql_last_value/Makefile
new file mode 100644
index 000000000000..773ca6ab99c6
--- /dev/null
+++ b/databases/mysql_last_value/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: mysql_last_value
+# Date created: 14th Aug 2003
+# Whom: Aftab Jahan Subedar
+# $FreeBSD$
+
+PORTNAME= mysql_last_value
+PORTVERSION= 3.2
+CATEGORIES= databases
+MASTER_SITES= http://www.geocities.com/jahan.geo/
+
+MAINTAINER= jahan@bol-online.com
+COMMENT= Replaces NULL value of current column with value from top row
+
+LIB_DEPENDS= mysqlclient.14:${PORTSDIR}/databases/mysql41-client
+
+USE_REINPLACE= yes
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/mysql_last_value ${PREFIX}/bin
+
+.include <bsd.port.mk>