aboutsummaryrefslogtreecommitdiff
path: root/databases/oracle_odbc_driver/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/oracle_odbc_driver/Makefile')
-rw-r--r--databases/oracle_odbc_driver/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/databases/oracle_odbc_driver/Makefile b/databases/oracle_odbc_driver/Makefile
index b98faf4b114d..308bea51c205 100644
--- a/databases/oracle_odbc_driver/Makefile
+++ b/databases/oracle_odbc_driver/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= oracle_odbc_driver
-PORTVERSION= 0.5.5
-PORTREVISION= 1
+PORTVERSION= 0.5.6
CATEGORIES= databases
MASTER_SITES= http://home.fnal.gov/~dbox/oracle/odbc/
DISTNAME= ${PORTNAME}.${PORTVERSION}
@@ -26,9 +25,11 @@ ORACLE_HOME= ${LOCALBASE}/oracle8-client
GNU_CONFIGURE= yes
CONFIGURE_ENV= ORACLE_HOME="${ORACLE_HOME}" \
- LIBS="`${CAT} ${ORACLE_HOME}/lib/sysliblist`"
+ LIBS="`${CAT} ${ORACLE_HOME}/lib/sysliblist`"\
+ AUTOHEADER=true
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
+USE_AUTOTOOLS= libtool:15
post-patch:
@${REINPLACE_CMD} -e 's/-lclntst8 -lcompat -lpthread -lm/-lclntst8 -lcompat ${PTHREAD_LIBS} -lm/' ${WRKSRC}/configure