aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBD-Excel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/p5-DBD-Excel/Makefile')
-rw-r--r--databases/p5-DBD-Excel/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/databases/p5-DBD-Excel/Makefile b/databases/p5-DBD-Excel/Makefile
new file mode 100644
index 000000000000..e0e6b3c059a1
--- /dev/null
+++ b/databases/p5-DBD-Excel/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: DBD::Excel
+# Date created: 24 Jan 2002
+# Whom: Seamus Venasse <svenasse@polaris.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBD-Excel
+PORTVERSION= 0.05
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DBD
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= svenasse@polaris.ca
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
+ ${SITE_PERL}/${PERL_ARCH}/SQL/Statement.pm:${PORTSDIR}/databases/p5-SQL-Statement \
+ ${SITE_PERL}/Spreadsheet/ParseExcel.pm:${PORTSDIR}/textproc/p5-Spreadsheet-ParseExcel \
+ ${SITE_PERL}/Spreadsheet/WriteExcel.pm:${PORTSDIR}/textproc/p5-Spreadsheet-WriteExcel
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+EXAMPLESDIR?= ${PREFIX}/share/examples/${PORTNAME}
+PERL_CONFIGURE= yes
+
+MAN3= DBD::Excel.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/sample/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>