aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBD-mysql/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/p5-DBD-mysql/Makefile')
-rw-r--r--databases/p5-DBD-mysql/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/databases/p5-DBD-mysql/Makefile b/databases/p5-DBD-mysql/Makefile
index a1562110d28b..65022d6675b4 100644
--- a/databases/p5-DBD-mysql/Makefile
+++ b/databases/p5-DBD-mysql/Makefile
@@ -16,9 +16,6 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
COMMENT= MySQL driver for the Perl5 Database Interface (DBI)
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
.include <bsd.port.pre.mk>
.if exists(${LOCALBASE}/lib/mysql/libmysqlclient.so.10)
@@ -35,4 +32,12 @@ PERL_CONFIGURE= yes
MAN3= Bundle::DBD::mysql.3 DBD::mysql.3 DBD::mysql::INSTALL.3 Mysql.3
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+.else
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+.endif
+
.include <bsd.port.post.mk>