aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBI-Shell/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/p5-DBI-Shell/Makefile')
-rw-r--r--databases/p5-DBI-Shell/Makefile19
1 files changed, 6 insertions, 13 deletions
diff --git a/databases/p5-DBI-Shell/Makefile b/databases/p5-DBI-Shell/Makefile
index 94984930210f..b13274855ba6 100644
--- a/databases/p5-DBI-Shell/Makefile
+++ b/databases/p5-DBI-Shell/Makefile
@@ -16,21 +16,14 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Interactive command shell for the DBI
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS+= ${SITE_PERL}/Text/Reform.pm:${PORTSDIR}/textproc/p5-Text-Reform \
+ ${SITE_PERL}/IO/Tee.pm:${PORTSDIR}/devel/p5-IO-Tee
+
PERL_CONFIGURE= yes
MAN1= dbish.1
MAN3= DBI::Format.3 DBI::Format::SQLMinus.3 DBI::Shell.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-.else
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-.endif
-RUN_DEPENDS+= ${SITE_PERL}/Text/Reform.pm:${PORTSDIR}/textproc/p5-Text-Reform
-RUN_DEPENDS+= ${SITE_PERL}/IO/Tee.pm:${PORTSDIR}/devel/p5-IO-Tee
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>