aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBI/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/p5-DBI/Makefile')
-rw-r--r--databases/p5-DBI/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/databases/p5-DBI/Makefile b/databases/p5-DBI/Makefile
index 6f6bc7d31af9..defdd847d95a 100644
--- a/databases/p5-DBI/Makefile
+++ b/databases/p5-DBI/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= DBI
-PORTVERSION= 1.49
+PORTVERSION= 1.50
CATEGORIES= databases perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= DBI
@@ -15,9 +15,13 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= The perl5 Database Interface. Required for DBD::* modules
-.if defined(WITH_PROXY)
-BUILD_DEPENDS= ${SITE_PERL}/RPC/PlServer.pm:${PORTSDIR}/net/p5-PlRPC
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
RUN_DEPENDS= ${BUILD_DEPENDS}
+
+.if defined(WITH_PROXY)
+PROXY_DEPENDS= ${SITE_PERL}/RPC/PlServer.pm:${PORTSDIR}/net/p5-PlRPC
+BUILD_DEPENDS+= ${PROXY_DEPENDS}
+RUN_DEPENDS+= ${PROXY_DEPENDS}
.endif
CONFLICTS= p5-DBI-1.3*
@@ -68,7 +72,7 @@ post-install:
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
-IGNORE= Please install databases/p5-DBI-137 instead
+IGNORE= requires newer Perl, but you can use databases/p5-DBI-137 instead
.endif
.include <bsd.port.post.mk>