aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-Dancer-Plugin-Redis
diff options
context:
space:
mode:
Diffstat (limited to 'databases/p5-Dancer-Plugin-Redis')
-rw-r--r--databases/p5-Dancer-Plugin-Redis/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/databases/p5-Dancer-Plugin-Redis/Makefile b/databases/p5-Dancer-Plugin-Redis/Makefile
index 9de7514aefec..abab2c558c96 100644
--- a/databases/p5-Dancer-Plugin-Redis/Makefile
+++ b/databases/p5-Dancer-Plugin-Redis/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Dancer-Plugin-Redis
PORTVERSION= 0.02
+PORTREVISION= 1
CATEGORIES= databases perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:CSCM
@@ -19,12 +20,17 @@ LICENSE= ART10 GPLv1
LICENSE_COMB= dual
BUILD_DEPENDS= p5-Dancer>=1.1750:${PORTSDIR}/www/p5-Dancer \
- p5-Redis>=0:${PORTSDIR}/databases/p5-Redis
+ p5-Redis>=1.902:${PORTSDIR}/databases/p5-Redis
RUN_DEPENDS= p5-Dancer>=1.1750:${PORTSDIR}/www/p5-Dancer \
- p5-Redis>=0:${PORTSDIR}/databases/p5-Redis
+ p5-Redis>=1.902:${PORTSDIR}/databases/p5-Redis
PERL_CONFIGURE= yes
MAN3= Dancer::Plugin::Redis.3
+post-patch:
+ @${REINPLACE_CMD} -i'' -e \
+ 's/_check_connection($$handle->{dbh})/$$handle->{dbh}->ping/' \
+ ${WRKSRC}/lib/Dancer/Plugin/Redis.pm
+
.include <bsd.port.mk>