aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-Ima-DBI
diff options
context:
space:
mode:
Diffstat (limited to 'databases/p5-Ima-DBI')
-rw-r--r--databases/p5-Ima-DBI/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/databases/p5-Ima-DBI/Makefile b/databases/p5-Ima-DBI/Makefile
index e4044bd05fc7..2245b65646aa 100644
--- a/databases/p5-Ima-DBI/Makefile
+++ b/databases/p5-Ima-DBI/Makefile
@@ -15,8 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
COMMENT= Database connection caching and organization
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
- ${SITE_PERL}/Class/WhiteHole.pm:${PORTSDIR}/devel/p5-Class-WhiteHole \
+BUILD_DEPENDS= ${SITE_PERL}/Class/WhiteHole.pm:${PORTSDIR}/devel/p5-Class-WhiteHole \
${SITE_PERL}/Class/Data/Inheritable.pm:${PORTSDIR}/devel/p5-Class-Data-Inheritable
RUN_DEPENDS= ${BUILD_DEPENDS}
@@ -24,4 +23,14 @@ PERL_CONFIGURE= yes
MAN3= Ima::DBI.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+.else
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+.endif
+
+.include <bsd.port.post.mk>