aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-LMDB_File/files/patch-liblmdb_Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/p5-LMDB_File/files/patch-liblmdb_Makefile')
-rw-r--r--databases/p5-LMDB_File/files/patch-liblmdb_Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/databases/p5-LMDB_File/files/patch-liblmdb_Makefile b/databases/p5-LMDB_File/files/patch-liblmdb_Makefile
new file mode 100644
index 000000000000..4511ae16f48e
--- /dev/null
+++ b/databases/p5-LMDB_File/files/patch-liblmdb_Makefile
@@ -0,0 +1,16 @@
+--- liblmdb/Makefile.orig 2013-09-11 05:23:43 UTC
++++ liblmdb/Makefile
+@@ -16,11 +16,11 @@
+ # There may be other macros in mdb.c of interest. You should
+ # read mdb.c before changing any of them.
+ #
+-CC = gcc
++CC ?= gcc
+ W = -W -Wall -Wno-unused-parameter -Wbad-function-cast
+ THREADS = -pthread
+ OPT = -O2 -g
+-CFLAGS = $(THREADS) $(OPT) $(W) $(XCFLAGS)
++CFLAGS += $(THREADS) $(OPT) $(W) $(XCFLAGS)
+ LDLIBS =
+ SOLIBS =
+ prefix = /usr/local