aboutsummaryrefslogtreecommitdiff
path: root/databases/php4-dba
diff options
context:
space:
mode:
Diffstat (limited to 'databases/php4-dba')
-rw-r--r--databases/php4-dba/Makefile1
-rw-r--r--databases/php4-dba/files/patch-fix-dba_replace-truncation17
2 files changed, 18 insertions, 0 deletions
diff --git a/databases/php4-dba/Makefile b/databases/php4-dba/Makefile
index abf53b08e91c..e093509420c8 100644
--- a/databases/php4-dba/Makefile
+++ b/databases/php4-dba/Makefile
@@ -6,6 +6,7 @@
#
CATEGORIES= databases
+PORTREVISION= 1
MASTERDIR= ${.CURDIR}/../../lang/php4
diff --git a/databases/php4-dba/files/patch-fix-dba_replace-truncation b/databases/php4-dba/files/patch-fix-dba_replace-truncation
new file mode 100644
index 000000000000..0f6dab4e5da7
--- /dev/null
+++ b/databases/php4-dba/files/patch-fix-dba_replace-truncation
@@ -0,0 +1,17 @@
+Patch that fixes dba_replace() file truncation issue
+
+Adopted from: http://cvs.php.net/viewvc.cgi/php-src/ext/dba/libinifile/inifile.c?r1=1.14.2.1.2.5&r2=1.14.2.1.2.4&view=patch
+
+--- libinifile/inifile.c 2007/12/31 07:20:05 1.14.2.1.2.4
++++ libinifile/inifile.c 2008/11/13 18:22:23 1.14.2.1.2.5
+@@ -508,7 +508,9 @@
+
+ /* 5 */
+ if (ret == SUCCESS) {
+- ret = inifile_truncate(dba, append ? pos_grp_next : pos_grp_start TSRMLS_CC); /* writes error on fail */
++ if (!value || (key->name && strlen(key->name))) {
++ ret = inifile_truncate(dba, append ? pos_grp_next : pos_grp_start TSRMLS_CC); /* writes error on fail */
++ }
+ }
+
+ if (ret == SUCCESS) {