aboutsummaryrefslogtreecommitdiff
path: root/databases/phpmyadmin211
diff options
context:
space:
mode:
Diffstat (limited to 'databases/phpmyadmin211')
-rw-r--r--databases/phpmyadmin211/Makefile151
-rw-r--r--databases/phpmyadmin211/distinfo3
-rw-r--r--databases/phpmyadmin211/files/config.inc.php.sample14
-rw-r--r--databases/phpmyadmin211/files/pkg-deinstall.in26
-rw-r--r--databases/phpmyadmin211/files/pkg-install.in98
-rw-r--r--databases/phpmyadmin211/files/pkg-message.in21
-rw-r--r--databases/phpmyadmin211/pkg-descr36
-rw-r--r--databases/phpmyadmin211/pkg-plist-chunk7
8 files changed, 0 insertions, 356 deletions
diff --git a/databases/phpmyadmin211/Makefile b/databases/phpmyadmin211/Makefile
deleted file mode 100644
index 3739797b54d8..000000000000
--- a/databases/phpmyadmin211/Makefile
+++ /dev/null
@@ -1,151 +0,0 @@
-# New ports collection makefile for: phpMyAdmin
-# Date created: 19 Jan 2001
-# Whom: nbm
-#
-# $FreeBSD$
-#
-
-PORTNAME= phpMyAdmin
-DISTVERSION= 2.9.0.2
-CATEGORIES= databases www
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= phpmyadmin
-DISTNAME= ${PORTNAME}-${PORTVERSION}
-
-MAINTAINER= m.seaman@infracaninophile.co.uk
-COMMENT= A set of PHP-scripts to manage MySQL over the web
-
-USE_BZIP2= yes
-NO_BUILD= yes
-USE_PHP= mysql pcre session
-
-SUB_LIST+= "MYADMDIR=${MYADMDIR}" \
- "PKGNAME=${PKGNAME}"
-SUB_FILES= pkg-message
-
-# Unfortunately can't make WITH_SUPHP part of the OPTIONS selection,
-# since it has to be processed before just about anything else.
-
-.if defined(WITH_SUPHP) && !defined(WITHOUT_SUPHP)
-
-PKGNAMESUFFIX= -suphp
-RUN_DEPENDS+= ${LOCALBASE}/sbin/suphp:${PORTSDIR}/www/suphp
-WANT_PHP_CGI= yes
-
-MYADMUSR?= phpmyadm
-
-SUB_LIST+= "MYADMUSR=${MYADMUSR}" \
- "MYADMGRP=${MYADMGRP}"
-SUB_FILES+= pkg-install pkg-deinstall
-
-.else
-
-WANT_PHP_WEB= yes
-
-.endif
-
-# Copy the way lang/php{4,5}-extensions deals with its OPTIONS -- avoids
-# problems with include of bsd.port.pre.mk
-
-OPTIONS= BZ2 "bzip2 library support" on \
- GD "GD library support" on \
- MYSQLI "Improved MySQL support" off \
- OPENSSL "OpenSSL support" on \
- PDF "PDFlib support (implies GD)" on \
- ZLIB "ZLIB support" on \
- MCRYPT "MCrypt library support" on \
- MBSTRING "Multi-byte character-set string support" on
-
-PORT_DBDIR?= ${DESTDIR}/var/db/ports
-LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
-OPTIONSFILE?= ${PORT_DBDIR}/${LATEST_LINK}/options
-
-.if exists(${OPTIONSFILE})
-.include "${OPTIONSFILE}"
-.endif
-
-# Options that default to on:
-.for opt in BZ2 GD OPENSSL PDF ZLIB MCRYPT MBSTRING
-. if !defined(WITHOUT_${opt}) || defined(WITH_${opt})
-USE_PHP+= ${opt:L}
-. endif
-.endfor
-
-# Options that default to off:
-.for opt in MYSQLI
-. if defined(WITH_${opt}) && !defined(WITHOUT_${opt})
-USE_PHP+= ${opt:L}
-. endif
-.endfor
-
-# MYADMUSR is only used WITH_SUPHP
-MYADMDIR?= www/phpMyAdmin
-MYADMGRP?= ${WWWGRP}
-CFGFILE= config.inc.php
-
-PLIST= ${WRKDIR}/plist
-PLIST_SUB+= MYADMDIR=${MYADMDIR} MYADMGRP=${MYADMGRP}
-
-.SILENT:
-
-do-build:
- @${DO_NADA}
-
-pre-everything::
- ${ECHO_MSG} ""
- ${ECHO_MSG} "You may use the following additional build option:"
- ${ECHO_MSG} ""
- ${ECHO_MSG} " WITH_SUPHP=yes Install appropriately for use with"
- ${ECHO_MSG} " the www/suphp port [default: no]"
- ${ECHO_MSG} ""
- ${ECHO_MSG} "Note that selecting the MYSQLI option will only work"
- ${ECHO_MSG} "with PHP5 and MySQL 4.1.x"
- ${ECHO_MSG} ""
- ${ECHO_MSG} "If you want to use PHP4, for best results, please"
- ${ECHO_MSG} "install lang/php4 before attempting to install"
- ${ECHO_MSG} "databases/phpmyadmin"
- ${ECHO_MSG} ""
-
-post-patch:
- ${CP} ${FILESDIR}/${CFGFILE}.sample ${WRKSRC}/${CFGFILE}.sample
- cd ${WRKSRC} ; \
- ${FIND} . ! -type d ! -name ${CFGFILE}.sample | ${SORT} | \
- ${SED} -e "s,^\.,%%MYADMDIR%%," >${PLIST} ; \
- ${CAT} ${PKGDIR}/pkg-plist-chunk >>${PLIST} ; \
- ${FIND} . -type d | ${SORT} -r | ${SED} \
- -e "s,^\.$$,@dirrmtry %%MYADMDIR%%," \
- -e "s,^\.,@dirrm %%MYADMDIR%%," >>${PLIST}
-
-pre-install:
-.if defined(WITH_SUPHP)
- ${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
-.endif
-
-do-install: install-app install-conf
-
-install-app:
- cd ${WRKSRC} ; \
- for src in $$( ${FIND} . ! -name .cvsignore ) ; do \
- dst=${TARGETDIR}/${MYADMDIR}$${src#.} ; \
- if ${TEST} -d $$src ; then \
- ${MKDIR} $$dst ; \
- else \
- ${INSTALL_DATA} $$src $$dst ; \
- fi \
- done
-
-install-conf: install-app
- cd ${TARGETDIR}/${MYADMDIR} ; \
- ${CHMOD} 0640 ${CFGFILE}.sample ; \
- ${CHGRP} ${MYADMGRP} ${CFGFILE}.sample ; \
- if ${TEST} ! -f ${CFGFILE} ; then \
- ${CP} -p ${CFGFILE}.sample ${CFGFILE} ; \
- fi
-
-post-install:
-.if defined(WITH_SUPHP)
- ${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.endif
- ${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.mk>
diff --git a/databases/phpmyadmin211/distinfo b/databases/phpmyadmin211/distinfo
deleted file mode 100644
index b689a301487e..000000000000
--- a/databases/phpmyadmin211/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (phpMyAdmin-2.9.0.2.tar.bz2) = c85e8b2b08dc7bd9be1e85ee38f5e4d9
-SHA256 (phpMyAdmin-2.9.0.2.tar.bz2) = e8f9089a8e87191be751e989e4a3e11c2698865a5bcb8507e3361a58bbb4376a
-SIZE (phpMyAdmin-2.9.0.2.tar.bz2) = 2041197
diff --git a/databases/phpmyadmin211/files/config.inc.php.sample b/databases/phpmyadmin211/files/config.inc.php.sample
deleted file mode 100644
index 0087f6fac79d..000000000000
--- a/databases/phpmyadmin211/files/config.inc.php.sample
+++ /dev/null
@@ -1,14 +0,0 @@
-<?php
-/* $FreeBSD$
- *
- * Skeleton configuration file -- this file is empty on a fresh
- * installaton of phpmyadmin.
- *
- * Copy any settings you want to override from
- * libraries/config.default.php or use scripts/setup.php to generate a
- * basic configuration file
- *
- */
-
-
-?>
diff --git a/databases/phpmyadmin211/files/pkg-deinstall.in b/databases/phpmyadmin211/files/pkg-deinstall.in
deleted file mode 100644
index 4962506b4e26..000000000000
--- a/databases/phpmyadmin211/files/pkg-deinstall.in
+++ /dev/null
@@ -1,26 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-
-case $2 in
- POST-DEINSTALL)
- cat <<EOMSG
-The phpMyAdmin-suphp port has been deleted.
-If you are not upgrading and don't intend to use
-phpMyAdmin any more then you may wish to delete
-the %%MYADMUSR%% account, which can be done with
-the following command:
-
- # pw userdel %%MYADMUSR%%
-EOMSG
- if [ -d %%PREFIX%%/%%MYADMDIR%% ] ; then
- echo " # rm -rf %%PREFIX%%/%%MYADMDIR%%/"
- fi
- echo
- ;;
-esac
-
-#
-# That's All Folks!
-#
diff --git a/databases/phpmyadmin211/files/pkg-install.in b/databases/phpmyadmin211/files/pkg-install.in
deleted file mode 100644
index bb4180b2660f..000000000000
--- a/databases/phpmyadmin211/files/pkg-install.in
+++ /dev/null
@@ -1,98 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-
-PATH=/usr/sbin:/usr/bin:/bin ; export PATH
-
-myadmdir=%%PREFIX%%/%%MYADMDIR%%
-myadmusr=%%MYADMUSR%%
-myadmgrp=%%MYADMGRP%%
-
-myadmgcos="phpMyAdmin Owner"
-myadmhome=/nonexistent
-myadmshell=/sbin/nologin
-
-create_group() {
- local user group gcos home shell
-
- user=$1
- group=$2
- gcos=$3
- home=$4
- shell=$5
-
- if pw groupadd -n $group ; then
- echo "===> Group $group created"
- else
- cat <<-EOERRORMSG
- *** Failed to create the $group group.
-
- Please add the $user user and $group group
- manually with the commands:
-
- pw groupadd -n $group
- pw useradd -n $user -g $group -c "$gcos" \\
- -d $home -s $shell -h -
-
- and retry installing this package.
- EOERRORMSG
- exit 1
- fi
-}
-
-
-create_user() {
- local user group gcos home shell
-
- user=$1
- group=$2
- gcos=$3
- home=$4
- shell=$5
-
- if pw useradd -n $user -g $group -c "$gcos" -d $home -s $shell -h - ; then
- echo "===> Created $user user"
- else
- cat <<-EOERRORMSG
- *** Failed to create the $user user.
-
- Please add the $user user manually with the command:
-
- pw useradd -n $user -g $group -c "$gcos" \\
- -d $home -s $shell -h -
-
- and retry installing this package.
- EOERRORMSG
- exit 1
- fi
-}
-
-
-case $2 in
- PRE-INSTALL)
-
- # Create the myadm user and group if they do not already exist
-
- if pw user show -n $myadmusr >/dev/null 2>&1 ; then
- echo "===> Using pre-existing user $myadmusr"
- else
- if ! pw group show -n $myadmgrp >/dev/null 2>&1 ; then
- create_group $myadmusr $myadmgrp "$myadmgcos" $myadmhome \
- $myadmshell
- fi
- create_user $myadmusr $myadmgrp "$myadmgcos" $myadmhome $myadmshell
- fi
- ;;
- POST-INSTALL)
-
- # Change ownership of the phpMyAdm directory
-
- echo "===> Adjusting file ownership in $myadmdir"
- chown -R $myadmusr:$myadmgrp $myadmdir || exit 1
- ;;
-esac
-
-#
-# That's All Folks!
-#
diff --git a/databases/phpmyadmin211/files/pkg-message.in b/databases/phpmyadmin211/files/pkg-message.in
deleted file mode 100644
index 34fbb55d1919..000000000000
--- a/databases/phpmyadmin211/files/pkg-message.in
+++ /dev/null
@@ -1,21 +0,0 @@
-
-%%PKGNAME%% has been installed into:
-
- %%PREFIX%%/%%MYADMDIR%%
-
-Please edit config.inc.php to suit your needs.
-
-To make phpMyAdmin available through your web site, I suggest
-that you add something like the following to httpd.conf:
-
- Alias /phpmyadmin/ "%%PREFIX%%/%%MYADMDIR%%/"
-
- <Directory "%%PREFIX%%/%%MYADMDIR%%/">
- Options none
- AllowOverride Limit
-
- Order Deny,Allow
- Deny from all
- Allow from 127.0.0.1 .example.com
- </Directory>
-
diff --git a/databases/phpmyadmin211/pkg-descr b/databases/phpmyadmin211/pkg-descr
deleted file mode 100644
index 6d392982ab23..000000000000
--- a/databases/phpmyadmin211/pkg-descr
+++ /dev/null
@@ -1,36 +0,0 @@
-
- phpMyAdmin handles the administration of MySQL over the Web. It can
- manage a whole MySQL server as well as a single database.
-
- Currently phpMyAdmin can:
- - easily browse through databases and tables
- - create, copy, rename, alter and drop databases
- - create, copy, rename, alter and drop tables
- - do table maintenance
- - add, edit and drop fields
- - execute any SQL-statement, even multiple queries
- - create, alter and drop indexes
- - load text files into tables
- - create (*) and read dumps of tables or databases
- - export (*) data to SQL, CSV, XML, Word, Excel, PDF and Latex
- formats
- - administer multiple servers
- - manage MySQL users and privileges
- - check server settings and runtime information with
- configuration hints
- - check referential integrity in MyISAM tables
- - using Query-by-example (QBE), create complex queries
- automatically connecting required tables
- - create PDF graphics of your Database layout
- - search globally in a database or a subset of it
- - transform stored data into any format using a set of predefined
- functions, like displaying BLOB-data as image or download-link
- - support InnoDB tables and foreign keys (see FAQ 3.6)
- - support mysqli, the improved MySQL extension (see FAQ 1.17)
- - communicate in 50 different languages
-
- (*) phpMyAdmin can compress (Zip, GZip -RFC 1952- or Bzip2 formats)
- dumps and CSV exports if you use PHP4 >= 4.0.4 with Zlib support
- (--with-zli b) and/or Bzip2 support (--with-bz2).
-
-WWW: http://www.phpmyadmin.net/
diff --git a/databases/phpmyadmin211/pkg-plist-chunk b/databases/phpmyadmin211/pkg-plist-chunk
deleted file mode 100644
index 271eb110d237..000000000000
--- a/databases/phpmyadmin211/pkg-plist-chunk
+++ /dev/null
@@ -1,7 +0,0 @@
-@mode 640
-@group %%MYADMGRP%%
-@unexec if cmp -s %D/%%MYADMDIR%%/config.inc.php.sample %D/%%MYADMDIR%%/config.inc.php ; then rm -f %D/%%MYADMDIR%%/config.inc.php ; fi
-%%MYADMDIR%%/config.inc.php.sample
-@exec [ ! -f %B/config.inc.php ] && cp -p %B/%f %B/config.inc.php || true
-@mode
-@group