aboutsummaryrefslogtreecommitdiff
path: root/databases/phpmyadmin211
diff options
context:
space:
mode:
Diffstat (limited to 'databases/phpmyadmin211')
-rw-r--r--databases/phpmyadmin211/Makefile152
-rw-r--r--databases/phpmyadmin211/distinfo2
-rw-r--r--databases/phpmyadmin211/pkg-deinstall-suphp26
-rw-r--r--databases/phpmyadmin211/pkg-descr24
-rw-r--r--databases/phpmyadmin211/pkg-install-suphp98
-rw-r--r--databases/phpmyadmin211/pkg-message12
-rw-r--r--databases/phpmyadmin211/pkg-plist-chunk7
7 files changed, 0 insertions, 321 deletions
diff --git a/databases/phpmyadmin211/Makefile b/databases/phpmyadmin211/Makefile
deleted file mode 100644
index cc1877b7b203..000000000000
--- a/databases/phpmyadmin211/Makefile
+++ /dev/null
@@ -1,152 +0,0 @@
-# New ports collection makefile for: phpMyAdmin
-# Date created: 19 Jan 2001
-# Whom: nbm
-#
-# $FreeBSD$
-#
-
-PORTNAME= phpMyAdmin
-CATEGORIES= databases www
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= phpmyadmin
-DISTVERSION= 2.6.1-rc1
-
-MAINTAINER= m.seaman@infracaninophile.co.uk
-COMMENT= A set of PHP-scripts to manage MySQL over the web
-
-USE_BZIP2= yes
-NO_BUILD= yes
-USE_PHP= mysql pcre
-
-# Unfortunately can't make WITH_SUPHP part of the OPTIONS selection,
-# since it has to be processed before just about anything else.
-
-.if defined(WITH_SUPHP) && !defined(WITHOUT_SUPHP)
-
-PKGNAMESUFFIX= -suphp
-RUN_DEPENDS+= ${LOCALBASE}/sbin/suphp:${PORTSDIR}/www/suphp
-WANT_PHP_CGI= yes
-PKGINST_SKEL= ${PKGDIR}/pkg-install${PKGNAMESUFFIX}
-PKGINSTALL= ${WRKDIR}/pkg-install${PKGNAMESUFFIX}
-PKGDEINST_SKEL= ${PKGDIR}/pkg-deinstall${PKGNAMESUFFIX}
-PKGDEINSTALL= ${WRKDIR}/pkg-deinstall${PKGNAMESUFFIX}
-
-MYADMUSR?= phpmyadm
-
-SED_SCRIPT= -e 's,%%PREFIX%%,${PREFIX},g' \
- -e 's,%%MYADMDIR%%,${MYADMDIR},g' \
- -e 's,%%MYADMUSR%%,${MYADMUSR},g' \
- -e 's,%%MYADMGRP%%,${MYADMGRP},g'
-
-.else
-
-WANT_PHP_WEB= yes
-
-.endif
-
-# Copy the way lang/php{4,5}-extensions deals with its OPTIONS -- avoids
-# problems with include of bsd.port.pre.mk
-
-OPTIONS= BZ2 "bzip2 library support" on \
- GD "GD library support" on \
- MYSQLI "Improved MySQL support (PHP5, MySQL 4.1 only)" off \
- OPENSSL "OpenSSL support" on \
- PDF "PDFlib support (implies GD)" on \
- ZLIB "ZLIB support" on
-
-PORT_DBDIR?= /var/db/ports
-LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
-OPTIONSFILE?= ${PORT_DBDIR}/${LATEST_LINK}/options
-
-.if exists(${OPTIONSFILE})
-.include "${OPTIONSFILE}"
-.endif
-
-# Options that default to on:
-.for opt in BZ2 GD OPENSSL PDF ZLIB
-. if !defined(WITHOUT_${opt}) || defined(WITH_${opt})
-USE_PHP+= ${opt:L}
-. endif
-.endfor
-
-# Options that default to off:
-.for opt in MYSQLI
-. if defined(WITH_${opt}) && !defined(WITHOUT_${opt})
-USE_PHP+= ${opt:L}
-. endif
-.endfor
-
-MSG_SKEL= ${PKGDIR}/pkg-message
-PKGMESSAGE= ${WRKDIR}/pkg-message
-
-# MYADMUSR is only used WITH_SUPHP
-MYADMDIR?= www/phpMyAdmin
-MYADMGRP?= ${WWWGRP}
-CFGFILE= config.inc.php
-
-PLIST= ${WRKDIR}/plist
-PLIST_SUB+= MYADMDIR=${MYADMDIR} MYADMGRP=${MYADMGRP}
-
-.SILENT:
-
-do-build:
- @${DO_NADA}
-
-pre-everything::
- ${ECHO_MSG} ""
- ${ECHO_MSG} "You may use the following additional build option:"
- ${ECHO_MSG} ""
- ${ECHO_MSG} " WITH_SUPHP=yes Install appropriately for use with"
- ${ECHO_MSG} " the www/suphp port [default: no]"
- ${ECHO_MSG} ""
-
-post-patch:
- ${MV} ${WRKSRC}/${CFGFILE} ${WRKSRC}/${CFGFILE}.sample
- cd ${WRKSRC} ; \
- ${FIND} . ! -type d ! -name ${CFGFILE}.sample | ${SORT} | \
- ${SED} -e "s,^\.,%%MYADMDIR%%," >${PLIST} ; \
- ${CAT} ${PKGDIR}/pkg-plist-chunk >>${PLIST} ; \
- ${FIND} . -type d | ${SORT} -r | ${SED} \
- -e "s,^\.$$,@unexec rmdir %D/%%MYADMDIR%% 2>/dev/null || true," \
- -e "s,^\.,@dirrm %%MYADMDIR%%," >>${PLIST}
- ${SED} -e 's,%%MYADMDIR%%,${MYADMDIR},g' \
- -e 's,%%PREFIX%%,${PREFIX},g' \
- -e 's,%%PKGNAME%%,${PKGNAME},g' ${MSG_SKEL} > ${PKGMESSAGE}
-.if defined(WITH_SUPHP)
- ${SED} ${SED_SCRIPT} ${PKGINST_SKEL} > ${PKGINSTALL}
- ${SED} ${SED_SCRIPT} ${PKGDEINST_SKEL} > ${PKGDEINSTALL}
-.endif
-
-pre-install:
-.if defined(WITH_SUPHP)
- ${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
-.endif
-
-do-install: install-app install-conf
-
-install-app:
- cd ${WRKSRC} ; \
- for src in $$( ${FIND} . ! -name .cvsignore ) ; do \
- dst=${PREFIX}/${MYADMDIR}$${src#.} ; \
- if ${TEST} -d $$src ; then \
- ${MKDIR} $$dst ; \
- else \
- ${INSTALL_DATA} $$src $$dst ; \
- fi \
- done
-
-install-conf: install-app
- cd ${PREFIX}/${MYADMDIR} ; \
- ${CHMOD} 0640 ${CFGFILE}.sample ; \
- ${CHGRP} ${MYADMGRP} ${CFGFILE}.sample ; \
- if ${TEST} ! -f ${CFGFILE} ; then \
- ${CP} -p ${CFGFILE}.sample ${CFGFILE} ; \
- fi
-
-post-install:
-.if defined(WITH_SUPHP)
- ${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.endif
- ${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.mk>
diff --git a/databases/phpmyadmin211/distinfo b/databases/phpmyadmin211/distinfo
deleted file mode 100644
index 308a4c7d890c..000000000000
--- a/databases/phpmyadmin211/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (phpMyAdmin-2.6.1-rc1.tar.bz2) = b413cc56b177547a94e387fa0f7d0334
-SIZE (phpMyAdmin-2.6.1-rc1.tar.bz2) = 1311277
diff --git a/databases/phpmyadmin211/pkg-deinstall-suphp b/databases/phpmyadmin211/pkg-deinstall-suphp
deleted file mode 100644
index f5991ecbab23..000000000000
--- a/databases/phpmyadmin211/pkg-deinstall-suphp
+++ /dev/null
@@ -1,26 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-
-case $2 in
- POST-DEINSTALL)
- cat <<EOMSG
-The phpMyAdmin-suphp port has been deleted.
-If you are not upgrading and don't intend to use
-phpMyAdmin any more then you may wish to delete
-the %%MYADMUSR%% account, which can be done with
-the following command:
-
- # pw userdel %%MYADMUSR%%
-EOMSG
- if [ -d %%PREFIX%%/%%MYADMDIR%% ] ; then
- echo " # rm -rf %%PREFIX%%/%%MYADMDIR%%/"
- fi
- echo
- ;;
-esac
-
-#
-# That's All Folks!
-# \ No newline at end of file
diff --git a/databases/phpmyadmin211/pkg-descr b/databases/phpmyadmin211/pkg-descr
deleted file mode 100644
index b1d2973e53c8..000000000000
--- a/databases/phpmyadmin211/pkg-descr
+++ /dev/null
@@ -1,24 +0,0 @@
-
-phpMyAdmin is intended to handle the administration of MySQL over the
-Web. It can manage a whole MySQL server as well as a single database.
-
-Currently it can:
- - create and drop databases
- - create, copy, drop, rename and alter tables
- - do table maintenance
- - delete, edit and add fields
- - execute any SQL-statement, even batch-queries
- - manage keys on fields
- - load text files into tables
- - create and read dumps of tables
- - export data to CSV, XML and Latex formats
- - administer multiple servers
- - manage MySQL users and privileges
- - check referential integrity
- - using Query-by-example (QBE), create complex queries automatically
- connecting required tables
- - create PDF graphics of your Database layout
- - search globally in a database or a subset of it
- - communicate in 47 different languages
-
-WWW: http://www.phpmyadmin.net/
diff --git a/databases/phpmyadmin211/pkg-install-suphp b/databases/phpmyadmin211/pkg-install-suphp
deleted file mode 100644
index 7bdf484e65ed..000000000000
--- a/databases/phpmyadmin211/pkg-install-suphp
+++ /dev/null
@@ -1,98 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-
-PATH=/usr/sbin:/usr/bin:/bin ; export PATH
-
-myadmdir=%%PREFIX%%/%%MYADMDIR%%
-myadmusr=%%MYADMUSR%%
-myadmgrp=%%MYADMGRP%%
-
-myadmgcos="phpMyAdmin Owner"
-myadmhome=/nonexistent
-myadmshell=/sbin/nologin
-
-create_group() {
- local user group gcos home shell
-
- user=$1
- group=$2
- gcos=$3
- home=$4
- shell=$5
-
- if pw groupadd -n $group ; then
- echo "===> Group $group created"
- else
- cat <<-EOERRORMSG
- *** Failed to create the $group group.
-
- Please add the $user user and $group group
- manually with the commands:
-
- pw groupadd -n $group
- pw useradd -n $user -g $group -c "$gcos" \\
- -d $home -s $shell -h -
-
- and retry installing this package.
- EOERRORMSG
- exit 1
- fi
-}
-
-
-create_user() {
- local user group gcos home shell
-
- user=$1
- group=$2
- gcos=$3
- home=$4
- shell=$5
-
- if pw useradd -n $user -g $group -c "$gcos" -d $home -s $shell -h - ; then
- echo "===> Created $user user"
- else
- cat <<-EOERRORMSG
- *** Failed to create the $user user.
-
- Please add the $user user manually with the command:
-
- pw useradd -n $user -g $group -c "$gcos" \\
- -d $home -s $shell -h -
-
- and retry installing this package.
- EOERRORMSG
- exit 1
- fi
-}
-
-
-case $2 in
- PRE-INSTALL)
-
- # Create the myadm user and group if they do not already exist
-
- if pw user show -n $myadmusr >/dev/null 2>&1 ; then
- echo "===> Using pre-existing user $myadmusr"
- else
- if ! pw group show -n $myadmgrp >/dev/null 2>&1 ; then
- create_group $myadmusr $myadmgrp "$myadmgcos" $myadmhome \
- $myadmshell
- fi
- create_user $myadmusr $myadmgrp "$myadmgcos" $myadmhome $myadmshell
- fi
- ;;
- POST-INSTALL)
-
- # Change ownership of the phpMyAdm directory
-
- echo "===> Adjusting file ownership in $myadmdir"
- chown -R $myadmusr:$myadmgrp $myadmdir || exit 1
- ;;
-esac
-
-#
-# That's All Folks!
-#
diff --git a/databases/phpmyadmin211/pkg-message b/databases/phpmyadmin211/pkg-message
deleted file mode 100644
index a9f3636dad94..000000000000
--- a/databases/phpmyadmin211/pkg-message
+++ /dev/null
@@ -1,12 +0,0 @@
-
-%%PKGNAME%% has been installed into:
-
- %%PREFIX%%/%%MYADMDIR%%
-
-Please edit config.inc.php to suit your needs.
-
-To make phpMyAdmin available through your web site, I suggest
-that you add the following to httpd.conf:
-
- Alias /phpmyadmin/ "%%PREFIX%%/%%MYADMDIR%%/"
-
diff --git a/databases/phpmyadmin211/pkg-plist-chunk b/databases/phpmyadmin211/pkg-plist-chunk
deleted file mode 100644
index 271eb110d237..000000000000
--- a/databases/phpmyadmin211/pkg-plist-chunk
+++ /dev/null
@@ -1,7 +0,0 @@
-@mode 640
-@group %%MYADMGRP%%
-@unexec if cmp -s %D/%%MYADMDIR%%/config.inc.php.sample %D/%%MYADMDIR%%/config.inc.php ; then rm -f %D/%%MYADMDIR%%/config.inc.php ; fi
-%%MYADMDIR%%/config.inc.php.sample
-@exec [ ! -f %B/config.inc.php ] && cp -p %B/%f %B/config.inc.php || true
-@mode
-@group