aboutsummaryrefslogtreecommitdiff
path: root/databases/postgis
diff options
context:
space:
mode:
Diffstat (limited to 'databases/postgis')
-rw-r--r--databases/postgis/Makefile13
1 files changed, 4 insertions, 9 deletions
diff --git a/databases/postgis/Makefile b/databases/postgis/Makefile
index 1293fcd0f10e..9fe5ffa657d5 100644
--- a/databases/postgis/Makefile
+++ b/databases/postgis/Makefile
@@ -27,8 +27,9 @@ PGSQL_SRC= ${WRKDIR}/pgsql/postgresql
INSTALL_TARGET= install
INSTALLS_SHLIB= no
-OPTIONS= PGSQL8 "Use PostgreSQL 8 instead of PostgreSQL 7.4" off \
- GEOS "Include GEOS - the OpenGIS 'Simple Features for SQL'" off \
+OPTIONS= GEOS "Include GEOS - the OpenGIS 'Simple Features for SQL'" off \
+
+USE_PGSQL= YES
.include <bsd.port.pre.mk>
@@ -37,13 +38,7 @@ MAKE_ARGS= PGSQL_SRC="${PGSQL_SRC}" \
BINDIR="${PREFIX}/bin" \
LIBDIR="${PREFIX}/lib"
-.if defined(WITH_PGSQL8)
-PGSQL_PORTDIR= ${PORTSDIR}/databases/postgresql-devel
-.else
-PGSQL_PORTDIR= ${PORTSDIR}/databases/postgresql7
-.endif
-
-LIB_DEPENDS+= pq.3:${PGSQL_PORTDIR}
+PGSQL_PORTDIR= ${PORTSDIR}/databases/postgresql${PGSQL_VER}-client
.if !defined(NOPORTDOCS)
BUILD_DEPENDS+= xsltproc:${PORTSDIR}/textproc/libxslt \