aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql-libpq++/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/postgresql-libpq++/Makefile')
-rw-r--r--databases/postgresql-libpq++/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/databases/postgresql-libpq++/Makefile b/databases/postgresql-libpq++/Makefile
new file mode 100644
index 000000000000..24aa1f23df3f
--- /dev/null
+++ b/databases/postgresql-libpq++/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: PostgreSQL Pgaccess
+# Date created: December 1st, 2002
+# Whom: Palle Girgensohn <girgen@pingpong.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libpq++
+PORTVERSION= 4.0
+CATEGORIES= databases
+MASTER_SITES= ftp://gborg.postgresql.org/pub/libpqpp/stable/
+DIST_SUBDIR= postgresql
+
+MAINTAINER= girgen@pingpong.net
+
+POSTGRESQL_PORT?= databases/postgresql7
+LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
+
+USE_GMAKE= YES
+USE_REINPLACE= YES
+INSTALLS_SHLIB= YES
+
+post-patch:
+ ${REINPLACE_CMD} "s,/usr/local/pgsql,${PREFIX},; \
+ s,^CFLAGS.*,CFLAGS=${CFLAGS},; \
+ s,\...SO_MINOR_VERSION.,,; \
+ s,\(\-[IL]\)[^/]*,\\1${LOCALBASE}," ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>