aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql-libpqxx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/postgresql-libpqxx/Makefile')
-rw-r--r--databases/postgresql-libpqxx/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/databases/postgresql-libpqxx/Makefile b/databases/postgresql-libpqxx/Makefile
index 356e3870f217..506ae6fb1a4b 100644
--- a/databases/postgresql-libpqxx/Makefile
+++ b/databases/postgresql-libpqxx/Makefile
@@ -21,6 +21,7 @@ USE_LIBTOOL_VER=15
USE_GMAKE= YES
GNU_CONFIGURE= YES
INSTALLS_SHLIB= YES
+PLIST_SUB= PORTVERSION=${PORTVERSION}
CONFIGURE_ARGS= --with-postgres=${LOCALBASE} \
--enable-shared \
@@ -30,8 +31,12 @@ POSTGRESQL_PORT?= databases/postgresql7
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= "<ios> header missing on this platform"
+.if ${OSVERSION} < 500035
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
+RUN_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
+CXXFLAGS+= -I${LOCALBASE}/include/stlport
+LDFLAGS+= -L${LOCALBASE}/lib -lstlport_gcc ${PTHREAD_LIBS}
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
.endif
.include <bsd.port.post.mk>