aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql-tcltk/files/patch-libpgtcl
diff options
context:
space:
mode:
Diffstat (limited to 'databases/postgresql-tcltk/files/patch-libpgtcl')
-rw-r--r--databases/postgresql-tcltk/files/patch-libpgtcl18
1 files changed, 10 insertions, 8 deletions
diff --git a/databases/postgresql-tcltk/files/patch-libpgtcl b/databases/postgresql-tcltk/files/patch-libpgtcl
index 831a4622f761..e0a811261fe7 100644
--- a/databases/postgresql-tcltk/files/patch-libpgtcl
+++ b/databases/postgresql-tcltk/files/patch-libpgtcl
@@ -1,9 +1,11 @@
---- src/interfaces/libpgtcl/Makefile Thu May 10 21:46:33 2001
-+++ src/interfaces/libpgtcl/Makefile Fri Mar 29 05:11:10 2002
-@@ -26,5 +26,5 @@
- # to be referenced separately to keep (broken) linkers happy. (This is
- # braindead; users of libpq should not need to know what it depends on.)
--SHLIB_LINK+= $(filter -L%, $(LDFLAGS)) $(filter -lcrypt, $(LIBS))
-+SHLIB_LINK+= $(filter -L%, $(LDFLAGS)) $(filter -lcrypt -L% -ltcl83 -ltcl84, $(LIBS))
+--- src/interfaces/libpgtcl/Makefile.orig Tue Oct 28 22:55:58 2003
++++ src/interfaces/libpgtcl/Makefile Tue Nov 18 04:21:46 2003
+@@ -21,7 +21,7 @@
+ OBJS= pgtcl.o pgtclCmds.o pgtclId.o
+
+ SHLIB_LINK = $(libpq) $(TCL_LIB_SPEC) $(TCL_LIBS) \
+- $(filter -lssl -lcrypto -lkrb5 -lcrypt, $(LIBS)) $(THREAD_LIBS)
++ $(filter -lssl -lcrypto -lkrb5 -lcrypt -L% -ltcl83 -ltcl84, $(LIBS)) $(THREAD_LIBS)
+
+ all: submake-libpq all-lib
- all: submake all-lib