aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql84-server/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/postgresql84-server/Makefile')
-rw-r--r--databases/postgresql84-server/Makefile24
1 files changed, 9 insertions, 15 deletions
diff --git a/databases/postgresql84-server/Makefile b/databases/postgresql84-server/Makefile
index 4ffa1b1bbb28..4505f524c045 100644
--- a/databases/postgresql84-server/Makefile
+++ b/databases/postgresql84-server/Makefile
@@ -8,7 +8,7 @@
PORTNAME?= postgresql
PKGNAMESUFFIX?= -server
PORTVERSION?= 8.0.1
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= databases
MASTER_SITES= ${MASTER_SITE_PGSQL}
MASTER_SITE_SUBDIR= source/v${PORTVERSION}
@@ -24,6 +24,9 @@ CONFLICTS?= ${PORTNAME}-client-7.[0-9]* \
WRKSRC= ${WRKDIR}/postgresql-${PORTVERSION}
DIST_SUBDIR= postgresql
+UNIQUENAME?= ${PORTNAME}80
+LATEST_LINK?= ${PKGNAMEPREFIX}${UNIQUENAME}${PKGNAMESUFFIX}
+
PKGINSTALL?= ${PKGDIR}/pkg-install${PKGNAMESUFFIX}
USE_BZIP2= YES
USE_GMAKE= YES
@@ -74,27 +77,18 @@ BROKEN= "Coredump during build on alpha 4.x"
.if !defined(SLAVE_ONLY)
# gnugetopt will always be used if already installed
-. if (${OSVERSION} < 500041) && !exists(${LOCALBASE}/include/getopt.h)
+. if ( ${OSVERSION} < 500041 ) && !exists(${LOCALBASE}/include/getopt.h)
OPTIONS+= GNUGETOPT "Use GNU getopt" on
. endif
-. if defined(SERVER_ONLY)
-OPTIONS+= PAM "Build with PAM support" off
-OPTIONS+= RENDEZVOUZ "Add support for Apple's Rendez-Vouz" off
-. endif
+OPTIONS+= PAM "Build with PAM support (server only)" off
OPTIONS+= MIT_KRB5 "Build with MIT's kerberos support" off
-OPTIONS+= HEIMDAL_KRB5 "Builds with Heimdal's kerberos support" off
+OPTIONS+= HEIMDAL_KRB5 "Builds with Heimdal kerberos support" off
OPTIONS+= OPTIMIZED_CFLAGS "Builds with compiler optimizations (-O3)" off
-. if defined(SERVER_ONLY)
-OPTIONS+= LIBC_R "Link with libc_r, needed by plpython" off
+OPTIONS+= LIBC_R "Link w/ libc_r, used by plpython (server)" off
# to run regression tests:
-OPTIONS+= TESTS "Allows the use of a \"check\" target" off
-. endif
+OPTIONS+= TESTS "Allows the use of a \"check\" target (server)" off
OPTIONS+= DEBUG "Builds with debugging symbols" off
-.if defined(SERVER_ONLY) && defined(WITH_RENDEZVOUS)
-CONFIGURE_ARGS+=--with-rendezvous
-.endif
-
. if defined(SERVER_ONLY) && defined(WITH_PAM)
CONFIGURE_ARGS+=--with-pam
. endif