aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql84-server/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/postgresql84-server/Makefile')
-rw-r--r--databases/postgresql84-server/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/databases/postgresql84-server/Makefile b/databases/postgresql84-server/Makefile
index 4ba024eccafc..886d3edb2686 100644
--- a/databases/postgresql84-server/Makefile
+++ b/databases/postgresql84-server/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= postgresql
-PORTVERSION= 7.1.1
+PORTVERSION= 7.1.2
CATEGORIES= databases
MASTER_SITES= ftp://ftp.iodynamics.com/pub/mirror/postgresql/%SUBDIR%/ \
ftp://ftp.postgresql.org/pub/%SUBDIR%/ \
@@ -87,9 +87,15 @@ SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
NO_OPENSSL="${NO_OPENSSL}" \
DISTNAME="${DISTNAME}"
-pre-fetch:
+pre-extract:
@ ${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/configure.postgresql
+# We must .include here because we need the Makefile.inc @ pre-install,
+# but it is created @ pre-extract
+.if exists(${WRKDIRPREFIX}${.CURDIR}/Makefile.inc)
+.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
+.endif
+
pre-install:
@ ${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGDIR}/pkg-install ${PORTNAME} PRE-INSTALL
.if !defined(BATCH)
@@ -186,8 +192,4 @@ post-clean:
post-extract: ${POSTEXTRACT}
-.if exists(${WRKDIRPREFIX}${.CURDIR}/Makefile.inc)
-.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
-.endif
-
.include <bsd.port.mk>