aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql91-contrib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/postgresql91-contrib/Makefile')
-rw-r--r--databases/postgresql91-contrib/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/databases/postgresql91-contrib/Makefile b/databases/postgresql91-contrib/Makefile
index 80248f9d16e5..4687e2d343f7 100644
--- a/databases/postgresql91-contrib/Makefile
+++ b/databases/postgresql91-contrib/Makefile
@@ -12,8 +12,8 @@ PKGNAMESUFFIX= -contrib
MAINTAINER= crees@FreeBSD.org
COMMENT= The contrib utilities from the PostgreSQL distribution
-LIB_DEPENDS= xslt.2:${PORTSDIR}/textproc/libxslt xml2.5:${PORTSDIR}/textproc/libxml2
-BUILD_DEPENDS= ${LOCALBASE}/lib/libuuid.a:${PORTSDIR}/misc/ossp-uuid
+LIB_DEPENDS= xslt.2:${PORTSDIR}/textproc/libxslt \
+ xml2.5:${PORTSDIR}/textproc/libxml2
USE_PGSQL= yes
DEFAULT_PGSQL_VER=91
@@ -25,9 +25,11 @@ BUILD_DIRS= src/port contrib
INSTALL_DIRS= contrib
SLAVE_ONLY= yes
-CONFIGURE_ARGS+=--with-libxslt --with-libxml --with-ossp-uuid
+CONFIGURE_ARGS+=--with-libxslt --with-libxml
LDFLAGS+= ${PTHREAD_LIBS} -L${PREFIX}/lib
+OPTIONS= OSSP_UUID "Enable / disable ossp-uuid support" on
+
post-install:
@- ${INSTALL_DATA} ${WRKSRC}/contrib/README ${DOCSDIR}/extension/README