aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql_autodoc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/postgresql_autodoc/Makefile')
-rw-r--r--databases/postgresql_autodoc/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/databases/postgresql_autodoc/Makefile b/databases/postgresql_autodoc/Makefile
index b07da1e736ce..1bac97e1aca4 100644
--- a/databases/postgresql_autodoc/Makefile
+++ b/databases/postgresql_autodoc/Makefile
@@ -13,19 +13,15 @@ BUILD_DEPENDS= p5-HTML-Template>=0:${PORTSDIR}/www/p5-HTML-Template \
p5-Term-ReadKey>=0:${PORTSDIR}/devel/p5-Term-ReadKey \
p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg
-USE_GMAKE= yes
-USES= perl5
+USES= gmake perl5
CONFIGURE_ARGS+=--datadir=${DATADIR}
-MAN1= postgresql_autodoc.1
-
WRKSRC= ${WRKDIR}/postgresql_autodoc
-NO_STAGE= yes
do-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/postgresql_autodoc ${PREFIX}/bin
- @${INSTALL_MAN} ${WRKSRC}/postgresql_autodoc.1 ${MANPREFIX}/man/man1
- @${MKDIR} ${DATADIR}
- @${INSTALL_DATA} ${WRKSRC}/*.tmpl ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/postgresql_autodoc ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/postgresql_autodoc.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.tmpl ${STAGEDIR}${DATADIR}
.include <bsd.port.mk>