aboutsummaryrefslogtreecommitdiff
path: root/databases/py-MySQLdb-devel
diff options
context:
space:
mode:
Diffstat (limited to 'databases/py-MySQLdb-devel')
-rw-r--r--databases/py-MySQLdb-devel/Makefile34
-rw-r--r--databases/py-MySQLdb-devel/distinfo1
-rw-r--r--databases/py-MySQLdb-devel/files/patch-ab23
-rw-r--r--databases/py-MySQLdb-devel/pkg-descr15
-rw-r--r--databases/py-MySQLdb-devel/pkg-plist60
5 files changed, 0 insertions, 133 deletions
diff --git a/databases/py-MySQLdb-devel/Makefile b/databases/py-MySQLdb-devel/Makefile
deleted file mode 100644
index c7e3ad8baf0d..000000000000
--- a/databases/py-MySQLdb-devel/Makefile
+++ /dev/null
@@ -1,34 +0,0 @@
-# New ports collection makefile for: py-MySQLdb
-# Date created: 04 April 2000
-# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= py-MySQLdb
-PORTVERSION= 0.9.2
-CATEGORIES= databases python
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= mysql-python
-DISTNAME= MySQL-python-${PORTVERSION}
-
-MAINTAINER= sheepkiller@cultdeadsheep.org
-COMMENT= Access a MySQL database through Python
-
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-USE_MYSQL= yes
-BROKEN_WITH_MYSQL= 41
-
-DOCS= MANIFEST README doc/*.html
-
-.if !defined(NOPORTDOCS)
-post-install:
- @${MKDIR} ${DOCSDIR}
-.for FILE in ${DOCS}
- @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
-.endfor
-.endif
-
-.include <bsd.port.mk>
-
diff --git a/databases/py-MySQLdb-devel/distinfo b/databases/py-MySQLdb-devel/distinfo
deleted file mode 100644
index 8728dca4b0c5..000000000000
--- a/databases/py-MySQLdb-devel/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (MySQL-python-0.9.2.tar.gz) = afef758f56289f98408dd9f379d8fc8d
diff --git a/databases/py-MySQLdb-devel/files/patch-ab b/databases/py-MySQLdb-devel/files/patch-ab
deleted file mode 100644
index 43239f23b4a2..000000000000
--- a/databases/py-MySQLdb-devel/files/patch-ab
+++ /dev/null
@@ -1,23 +0,0 @@
-
-$FreeBSD$
-
---- setup.py.orig Thu Jul 18 22:55:36 2002
-+++ setup.py Tue Sep 10 10:51:52 2002
-@@ -11,7 +11,7 @@
- NO = 0
-
- # set this to YES if you have the thread-safe mysqlclient library
--thread_safe_library = YES
-+thread_safe_library = NO
-
- # You probably don't have to do anything past this point. If you
- # do, please mail me the configuration for your platform. Don't
-@@ -51,7 +51,7 @@
- if sys.platform == "netbsd1":
- include_dirs = ['/usr/pkg/include/mysql']
- library_dirs = ['/usr/pkg/lib/mysql']
--elif sys.platform in ("freebsd4", "openbsd3"):
-+elif sys.platform[:7] in ("freebsd", "openbsd"):
- LOCALBASE = os.environ.get('LOCALBASE', '/usr/local')
- include_dirs = ['%s/include/mysql' % LOCALBASE]
- library_dirs = ['%s/lib/mysql' % LOCALBASE]
diff --git a/databases/py-MySQLdb-devel/pkg-descr b/databases/py-MySQLdb-devel/pkg-descr
deleted file mode 100644
index 5c4095d67f35..000000000000
--- a/databases/py-MySQLdb-devel/pkg-descr
+++ /dev/null
@@ -1,15 +0,0 @@
-You can easily access a MySQL database through the Python MySQL module.
-
-This module should be mostly compatible with an older interface written by
-Joe Skinner and others. However, the older version is
-
- a) not thread-friendly (database operations could cause all other threads to
- block),
- b) written for MySQL 3.21 (does not compile against newer versions without
- patches),
- c) apparently not actively maintained.
-
-MySQLdb is a completely new module, distributed free of charge under a license
-derived from the Python license.
-
-WWW: http://dustman.net/andy/python/
diff --git a/databases/py-MySQLdb-devel/pkg-plist b/databases/py-MySQLdb-devel/pkg-plist
deleted file mode 100644
index a2b5fc7ceee0..000000000000
--- a/databases/py-MySQLdb-devel/pkg-plist
+++ /dev/null
@@ -1,60 +0,0 @@
-lib/%%PYTHON_VERSION%%/site-packages/CompatMysqldb.py
-lib/%%PYTHON_VERSION%%/site-packages/CompatMysqldb.pyc
-lib/%%PYTHON_VERSION%%/site-packages/CompatMysqldb.pyo
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/__init__.py
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/__init__.pyc
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/__init__.pyo
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/connections.py
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/connections.pyc
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/connections.pyo
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/constants/CLIENT.py
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/constants/CLIENT.pyc
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/constants/CLIENT.pyo
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/constants/CR.py
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/constants/CR.pyc
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/constants/CR.pyo
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/constants/ER.py
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/constants/ER.pyc
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/constants/ER.pyo
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/constants/FIELD_TYPE.py
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/constants/FIELD_TYPE.pyc
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/constants/FIELD_TYPE.pyo
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/constants/FLAG.py
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/constants/FLAG.pyc
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/constants/FLAG.pyo
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/constants/REFRESH.py
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/constants/REFRESH.pyc
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/constants/REFRESH.pyo
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/constants/__init__.py
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/constants/__init__.pyc
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/constants/__init__.pyo
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/converters.py
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/converters.pyc
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/converters.pyo
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/cursors.py
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/cursors.pyc
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/cursors.pyo
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/sets.py
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/sets.pyc
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/sets.pyo
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/times.py
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/times.pyc
-lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/times.pyo
-lib/%%PYTHON_VERSION%%/site-packages/_mysql.so
-lib/%%PYTHON_VERSION%%/site-packages/_mysql_exceptions.py
-lib/%%PYTHON_VERSION%%/site-packages/_mysql_exceptions.pyc
-lib/%%PYTHON_VERSION%%/site-packages/_mysql_exceptions.pyo
-%%PORTDOCS%%%%DOCSDIR%%/MANIFEST
-%%PORTDOCS%%%%DOCSDIR%%/MySQLdb-1.html
-%%PORTDOCS%%%%DOCSDIR%%/MySQLdb-2.html
-%%PORTDOCS%%%%DOCSDIR%%/MySQLdb-3.html
-%%PORTDOCS%%%%DOCSDIR%%/MySQLdb-4.html
-%%PORTDOCS%%%%DOCSDIR%%/MySQLdb-FAQ-1.html
-%%PORTDOCS%%%%DOCSDIR%%/MySQLdb-FAQ-2.html
-%%PORTDOCS%%%%DOCSDIR%%/MySQLdb-FAQ-3.html
-%%PORTDOCS%%%%DOCSDIR%%/MySQLdb-FAQ.html
-%%PORTDOCS%%%%DOCSDIR%%/MySQLdb.html
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/constants
-@dirrm lib/%%PYTHON_VERSION%%/site-packages/MySQLdb