aboutsummaryrefslogtreecommitdiff
path: root/databases/py-MySQLdb
diff options
context:
space:
mode:
Diffstat (limited to 'databases/py-MySQLdb')
-rw-r--r--databases/py-MySQLdb/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/databases/py-MySQLdb/Makefile b/databases/py-MySQLdb/Makefile
index 348c5099d31b..1f4d069f6514 100644
--- a/databases/py-MySQLdb/Makefile
+++ b/databases/py-MySQLdb/Makefile
@@ -12,15 +12,14 @@ DISTNAME= MySQL-python-${DISTVERSION}
MAINTAINER= python@FreeBSD.org
COMMENT= Access a MySQL database through Python
-USE_PYTHON= 2
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
-USE_MYSQL= yes
+USES= python:2
+USE_PYTHON= distutils autoplist
+USE_MYSQL= yes
CONFLICTS= py*-MySQLdb-[0-9]* py*-MySQLdb5[0-9]-[0-9]*
PORTDOCS= *
-DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
+DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
OPTIONSFILE= ${PORT_DBDIR}/${PORTNAME}/options
OPTIONS_DEFINE= DOCS MYSQLCLIENT_R