aboutsummaryrefslogtreecommitdiff
path: root/databases/ruby-dbd_pg
diff options
context:
space:
mode:
Diffstat (limited to 'databases/ruby-dbd_pg')
-rw-r--r--databases/ruby-dbd_pg/Makefile39
-rw-r--r--databases/ruby-dbd_pg/pkg-comment1
-rw-r--r--databases/ruby-dbd_pg/pkg-descr5
-rw-r--r--databases/ruby-dbd_pg/pkg-plist4
4 files changed, 49 insertions, 0 deletions
diff --git a/databases/ruby-dbd_pg/Makefile b/databases/ruby-dbd_pg/Makefile
new file mode 100644
index 000000000000..03d8df99037c
--- /dev/null
+++ b/databases/ruby-dbd_pg/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: dbd_pg for DBD-for-Ruby
+# Date created: 9 June 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dbd_pg
+PORTVERSION= ${RUBY_DBI_PORTVERSION}
+CATEGORIES= databases ruby
+MASTER_SITES= ${RUBY_DBI_MASTER_SITES}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ${RUBY_DBI_DISTNAME}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+RUN_DEPENDS= ${RUBY_SITELIBDIR}/dbi.rb:${RUBY_DBI_PORTDIR} \
+ ${RUBY_SITEARCHLIBDIR}/postgres.so:${.CURDIR}/../ruby-postgres
+
+USE_RUBY= yes
+USE_RUBY_SETUP= yes
+
+WRKSRC= ${RUBY_DBI_WRKSRC}
+CONFIGURE_ARGS= --with=lib/${PORTNAME}
+
+DOCS_EN= lib/${PORTNAME}/doc/*
+
+.include "${.CURDIR}/../ruby-dbi/Makefile.common"
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_DOCDIR}/${RUBY_DBI_PORTNAME}/${PORTNAME}
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${RUBY_DBI_PORTNAME}/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/databases/ruby-dbd_pg/pkg-comment b/databases/ruby-dbd_pg/pkg-comment
new file mode 100644
index 000000000000..e5eabfa618d9
--- /dev/null
+++ b/databases/ruby-dbd_pg/pkg-comment
@@ -0,0 +1 @@
+PostgreSQL driver for DBI-for-Ruby
diff --git a/databases/ruby-dbd_pg/pkg-descr b/databases/ruby-dbd_pg/pkg-descr
new file mode 100644
index 000000000000..cfb254e2a545
--- /dev/null
+++ b/databases/ruby-dbd_pg/pkg-descr
@@ -0,0 +1,5 @@
+This is the PostgreSQL driver for DBI-for-Ruby.
+
+Author: Jim Weirich <jweirich@one.ent>
+WWW: http://www.ruby-projects.org/dbi/
+
diff --git a/databases/ruby-dbd_pg/pkg-plist b/databases/ruby-dbd_pg/pkg-plist
new file mode 100644
index 000000000000..24122cb73973
--- /dev/null
+++ b/databases/ruby-dbd_pg/pkg-plist
@@ -0,0 +1,4 @@
+%%RUBY_SITELIBDIR%%/DBD/Pg/Pg.rb
+@dirrm %%RUBY_SITELIBDIR%%/DBD/Pg
+%%PORTDOCS%%%%RUBY_DOCDIR%%/dbi/dbd_pg/README
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/dbi/dbd_pg