aboutsummaryrefslogtreecommitdiff
path: root/databases/rubygem-sqlite3-ruby/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/rubygem-sqlite3-ruby/Makefile')
-rw-r--r--databases/rubygem-sqlite3-ruby/Makefile22
1 files changed, 8 insertions, 14 deletions
diff --git a/databases/rubygem-sqlite3-ruby/Makefile b/databases/rubygem-sqlite3-ruby/Makefile
index 17fa00a5a6b1..76c9432c909d 100644
--- a/databases/rubygem-sqlite3-ruby/Makefile
+++ b/databases/rubygem-sqlite3-ruby/Makefile
@@ -1,37 +1,31 @@
-# New ports collection makefile for: sqlite-ruby
+# New ports collection makefile for: sqlite3-ruby
# Date created: 26 June 2003
# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
#
# $FreeBSD$
#
-PORTNAME= sqlite
-PORTVERSION= 2.2.2
+PORTNAME= sqlite3
+PORTVERSION= 0.5.0
CATEGORIES= databases ruby
-MASTER_SITES= http://rubyforge.org/frs/download.php/1901/
+MASTER_SITES= http://rubyforge.org/frs/download.php/2301/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= ${PORTNAME}-ruby-${PORTVERSION}
DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
-COMMENT= Ruby interface to the SQLite DB engine
+COMMENT= Ruby interface to the SQLite DB engine version 3
-LIB_DEPENDS= sqlite.2:${PORTSDIR}/databases/sqlite2
+LIB_DEPENDS= sqlite3.8:${PORTSDIR}/databases/sqlite3
USE_BZIP2= yes
USE_RUBY= yes
-USE_RUBY_EXTCONF= yes
+USE_RUBY_SETUP= yes
-CONFIGURE_WRKSRC= ${WRKSRC}/ext
-BUILD_WRKSRC= ${WRKSRC}/ext
-INSTALL_WRKSRC= ${WRKSRC}/ext
-INSTALL_TARGET= site-install
+NO_BUILD= yes
DOCS= ChangeLog LICENSE api/* doc/*
-post-extract:
- ${LN} -s ../lib ${WRKSRC}/ext/
-
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODDOCDIR}