aboutsummaryrefslogtreecommitdiff
path: root/databases/slony1v2
diff options
context:
space:
mode:
Diffstat (limited to 'databases/slony1v2')
-rw-r--r--databases/slony1v2/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/databases/slony1v2/Makefile b/databases/slony1v2/Makefile
index 6de4d7a80805..1f68cc41285c 100644
--- a/databases/slony1v2/Makefile
+++ b/databases/slony1v2/Makefile
@@ -15,11 +15,10 @@ DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
MAINTAINER= vivek@khera.org
COMMENT= PostgreSQL master to multiple replicas replication system
-PGSQL_PORT= ${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
-RUN_DEPENDS= ${LOCALBASE}/bin/postmaster:${PGSQL_PORT}
-BUILD_DEPENDS= ${LOCALBASE}/bin/postmaster:${PGSQL_PORT}
+BUILD_DEPENDS= ${LOCALBASE}/bin/postmaster:${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
GNU_CONFIGURE= yes
+USE_PGSQL= yes
USE_GMAKE= yes
USE_BZIP2= yes
USE_RC_SUBR= slon.sh
@@ -31,6 +30,8 @@ OPTIONS= PERLTOOLS "Install perl configuration tools" Off
.include <bsd.port.pre.mk>
+IGNORE_WITH_PGSQL= 84
+
.if defined(WITH_PERLTOOLS)
USE_PERL5= yes
CONFIGURE_ARGS+= --with-perltools=${LOCALBASE}/sbin