aboutsummaryrefslogtreecommitdiff
path: root/databases/sqlcipher/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/sqlcipher/Makefile')
-rw-r--r--databases/sqlcipher/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/databases/sqlcipher/Makefile b/databases/sqlcipher/Makefile
new file mode 100644
index 000000000000..2fe66efcb9cd
--- /dev/null
+++ b/databases/sqlcipher/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= sqlcipher
+PORTVERSION= 2.1.1
+CATEGORIES= databases
+
+MAINTAINER= jsa@FreeBSD.org
+COMMENT= Encrypted sqlite database
+
+LICENSE= BSD
+
+USE_LDCONFIG= yes
+USE_TCL_BUILD= 85
+USE_GITHUB= yes
+USE_GNOME= gnomehack
+GH_ACCOUNT= sqlcipher
+GH_TAGNAME= v${PORTVERSION}
+GH_COMMIT= ee2ce3e
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--enable-tempstore=yes --disable-tcl --disable-readline
+CPPFLAGS+= -DSQLITE_HAS_CODEC
+LDFLAGS+= -lcrypto
+
+CONFLICTS= sqlite3-3.*
+
+.include <bsd.port.mk>