aboutsummaryrefslogtreecommitdiff
path: root/databases/sqlite/files
diff options
context:
space:
mode:
Diffstat (limited to 'databases/sqlite/files')
-rw-r--r--databases/sqlite/files/Makefile.bsd38
-rw-r--r--databases/sqlite/files/Makefile.docs25
-rw-r--r--databases/sqlite/files/patch-docs30
-rw-r--r--databases/sqlite/files/patch-test12
-rw-r--r--databases/sqlite/files/pkgIndex.tcl2
5 files changed, 1 insertions, 106 deletions
diff --git a/databases/sqlite/files/Makefile.bsd b/databases/sqlite/files/Makefile.bsd
deleted file mode 100644
index 2b8d83f17612..000000000000
--- a/databases/sqlite/files/Makefile.bsd
+++ /dev/null
@@ -1,38 +0,0 @@
-TCL_VER ?= 8.3
-TCL_DVER = ${TCL_VER:S/.//}
-PREFIX ?= /usr/local
-
-CFLAGS += -DHAVE_READLINE=1 -DOS_UNIX=1 -DOS_WIN=0
-CFLAGS += -I${PREFIX}/include/tcl${TCL_VER} -I${PREFIX}/include
-CFLAGS += -I${.CURDIR}/src -I${.CURDIR}
-
-LDADD += -lreadline -L${PREFIX}/lib -ltcl${TCL_DVER} -lm -lgdbm
-
-.PATH: ${.CURDIR}/src
-
-SRCS = btree.c build.c dbbe.c dbbegdbm.c dbbemem.c delete.c expr.c \
- insert.c main.c pager.c parse.y printf.c random.c select.c \
- shell.c table.c tokenize.c update.c util.c vdbe.c where.c \
- tclsqlite.c
-
-INCS = sqlite.h
-
-LIB = sqlite
-SHLIB_MAJOR= 1
-SHLIB_MINOR= 0
-
-sqlite.h: sqlite.h.in VERSION
- sed -e s/--VERS--/`cat ${.CURDIR}/VERSION`/ \
- -e s/--ENCODING--/ISO8859/ \
- ${.CURDIR}/src/sqlite.h.in > sqlite.h
-
-parse.h parse.c: parse.y
- lemon o=parse ${.ALLSRC}
-
-INCSDIR = ${PREFIX}/include
-INCDIR = ${INCSDIR} # for pre-bsd.incs.mk API
-LIBDIR = ${PREFIX}/lib
-
-.include <bsd.lib.mk>
-
-${OBJS} ${SOBJS}: parse.h sqlite.h
diff --git a/databases/sqlite/files/Makefile.docs b/databases/sqlite/files/Makefile.docs
deleted file mode 100644
index 77d95a57d548..000000000000
--- a/databases/sqlite/files/Makefile.docs
+++ /dev/null
@@ -1,25 +0,0 @@
-TCL_VER ?= 8.3
-
-SRCS != echo ${.CURDIR}/*.tcl
-DOCS = ${SRCS:Nopcode.tcl:.tcl=.html}
-CODE != echo ${.CURDIR}/../src/*.[chy]
-
-all: ${DOCS} opcode.html
-
-opcode.html:: opcode.tcl vdbe.c
- tclsh${TCL_VER} ${.ALLSRC} > opcode.html
-
-.SUFFIXES: .tcl .html
-
-.tcl.html:
- tclsh${TCL_VER} $*.tcl > $*.html
-
-${DOCS}: last_change
-
-.PATH: ${.CURDIR}/../src
-
-last_change: ${CODE}
- awk '/\$$Id:/ && NF > 4 { \
- if ($$2 == "\$$Id:") print $$5 "," $$6; \
- else print $$6 "," $$7 \
- }' ${.ALLSRC} | sort -t, | tail -1 > lc && mv lc last_change
diff --git a/databases/sqlite/files/patch-docs b/databases/sqlite/files/patch-docs
deleted file mode 100644
index ce5498da4d16..000000000000
--- a/databases/sqlite/files/patch-docs
+++ /dev/null
@@ -1,30 +0,0 @@
---- www/index.tcl Thu Apr 5 12:49:44 2001
-+++ www/index.tcl Fri Jun 8 17:46:08 2001
-@@ -117,12 +117,6 @@
-
--puts {<h2>Download</h2>
-+puts "<!-- h2>Download</h2 --><h3>This installation of Sqlite $vers was made"
-+puts {by the <A href="http://www.freebsd.org/cgi/ports.cgi?query=sqlite">FreeBSD
-+Port</A>.</h3>}
-
--<p>You can download a tarball containing all source
--code for SQLite
--}
--puts "version $vers"
--puts {
--(including the TCL scripts that generate the
--HTML files for this website) at <a href="sqlite.tar.gz">sqlite.tar.gz</a>.}
--puts "This is a [file size sqlite.tar.gz] byte download."
- puts {</p>
---- www/dynload.tcl Sun Feb 11 11:58:22 2001
-+++ www/dynload.tcl Mon Jun 11 19:09:47 2001
-@@ -15,3 +15,3 @@
- <i>This note was contributed by
--<a href="bsaunder@tampabay.rr.com.nospam">Bill Saunders</a>. Thanks, Bill!</i>
-+<a href="mailto:bsaunder@tampabay.rr.com.nospam">Bill Saunders</a>. Thanks, Bill!</i>
-
-@@ -67,3 +67,3 @@
- Have fun....</p></li>
--</ul>
-+</ol>
-
diff --git a/databases/sqlite/files/patch-test b/databases/sqlite/files/patch-test
deleted file mode 100644
index 3adee03362f9..000000000000
--- a/databases/sqlite/files/patch-test
+++ /dev/null
@@ -1,12 +0,0 @@
---- test/all.test Tue Feb 6 08:29:31 2001
-+++ test/all.test Fri Jun 8 16:28:34 2001
-@@ -27,2 +27,3 @@
- set testdir [file dirname $argv0]
-+load [lindex $argv 0]
- source $testdir/tester.tcl
---- test/tableapi.test.orig Wed Apr 11 23:28:43 2001
-+++ test/tableapi.test Mon Sep 3 21:24:06 2001
-@@ -30,2 +30,3 @@
- source $testdir/tester.tcl
-+set ::big_str ""
-
diff --git a/databases/sqlite/files/pkgIndex.tcl b/databases/sqlite/files/pkgIndex.tcl
index df0b6bb0a82d..dba694a3bc8b 100644
--- a/databases/sqlite/files/pkgIndex.tcl
+++ b/databases/sqlite/files/pkgIndex.tcl
@@ -1 +1 @@
-package ifneeded sqlite 1.0 [list load $dir/../libsqlite.so]
+package ifneeded sqlite 0.0 [list load [file join $dir libtclsqlite.so.0] sqlite]