aboutsummaryrefslogtreecommitdiff
path: root/databases/sqlite34
diff options
context:
space:
mode:
Diffstat (limited to 'databases/sqlite34')
-rw-r--r--databases/sqlite34/Makefile41
-rw-r--r--databases/sqlite34/distinfo6
-rw-r--r--databases/sqlite34/files/fts2_patch-Makefile.in14
-rw-r--r--databases/sqlite34/files/patch-ext__fts1__fts1.c14
-rw-r--r--databases/sqlite34/files/patch-ext__fts1__fts1_porter.c14
-rw-r--r--databases/sqlite34/files/patch-ext__fts1__fts1_tokenizer1.c14
-rw-r--r--databases/sqlite34/files/patch-ext__fts2__fts2.c12
-rw-r--r--databases/sqlite34/files/patch-ext__fts2__fts2_porter.c14
-rw-r--r--databases/sqlite34/files/patch-ext__fts2__fts2_tokenizer1.c14
-rw-r--r--databases/sqlite34/pkg-plist2
10 files changed, 25 insertions, 120 deletions
diff --git a/databases/sqlite34/Makefile b/databases/sqlite34/Makefile
index 7d255af7d8b0..433a113b694c 100644
--- a/databases/sqlite34/Makefile
+++ b/databases/sqlite34/Makefile
@@ -5,19 +5,17 @@
# $FreeBSD$
#
-PORTNAME= sqlite3
-PORTVERSION= 3.4.1
+PORTNAME= sqlite34
+PORTVERSION= 3.4.2
CATEGORIES= databases
-MASTER_SITES= http://www.sqlite.org/
-.if defined(USE_THOL)
-PKGNAMESUFFIX= -threads
-.endif
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= mnag/${PORTNAME}
DISTNAME= sqlite-${PORTVERSION}
MAINTAINER= mnag@FreeBSD.org
-COMMENT?= An SQL database engine in a C library w/ Tcl wrapper
+COMMENT= An SQL database engine in a C library w/ Tcl wrapper
-SLAVEDIRS= databases/sqlite3-threads
+CONFLICTS= sqlite3-[0-9]*
USE_GMAKE= YES
USE_GNOME= pkgconfig
@@ -32,23 +30,14 @@ OPTIONS= DEBUG "Enable debugging & verbose explain" off \
DOCS "Building docs (depends on TCL)" on \
FTS1 "Enable FTS1 (Full Text Search) module" off \
FTS2 "Enable FTS2 (Full Text Search) module" off \
- TCLWRAPPER "TCL wrapper for SQLITE" off
+ TCLWRAPPER "TCL wrapper for SQLITE" off \
+ THREADS "Enable threads support" off
# Defaults, for building the docs:
TCL_V?= 8.4
MAKE_ARGS+= TCLSH=tclsh${TCL_V}
MAKE_ENV+= TCL_VER=${TCL_V}
-.if !defined(USE_THOL)
-OPTIONS+= THREADS "Enable threads support" off
-PLIST_SUB+= THOL="@comment "
-CONFLICTS= sqlite-threads-3*
-.else
-CONFIGURE_ARGS+= --enable-threadsafe --enable-threads-override-locks
-PLIST_SUB+= THOL=""
-CONFLICTS= sqlite-3*
-.endif
-
.include <bsd.port.pre.mk>
.if defined(WITH_DEBUG)
@@ -62,13 +51,13 @@ PORTDOCS= *
.endif
.if defined(WITH_FTS1) && defined(WITH_FTS2)
-CFLAGS+= -DSQLITE_ENABLE_FTS1 -DSQLITE_ENABLE_FTS2
+CFLAGS+= -DSQLITE_CORE -DSQLITE_ENABLE_FTS1 -DSQLITE_ENABLE_FTS2
EXTRA_PATCHES+= ${FILESDIR}/fts12_patch-Makefile.in
.elif defined(WITH_FTS1) && !defined(WITH_FTS2)
-CFLAGS+= -DSQLITE_ENABLE_FTS1
+CFLAGS+= -DSQLITE_CORE -DSQLITE_ENABLE_FTS1
EXTRA_PATCHES+= ${FILESDIR}/fts1_patch-Makefile.in
.elif defined(WITH_FTS2) && !defined(WITH_FTS1)
-CFLAGS+= -DSQLITE_ENABLE_FTS2
+CFLAGS+= -DSQLITE_CORE -DSQLITE_ENABLE_FTS2
EXTRA_PATCHES+= ${FILESDIR}/fts2_patch-Makefile.in
.endif
@@ -83,7 +72,7 @@ PLIST_SUB+= WITH_TCLWRAPPER="@comment "
.endif
.if defined(WITH_THREADS)
-CONFIGURE_ARGS+= --enable-threadsafe
+CONFIGURE_ARGS+= --enable-threadsafe --enable-threads-override-locks
.endif
post-patch:
@@ -100,7 +89,7 @@ post-patch:
>> ${WRKSRC}/freebsd.hints
pre-configure:
-.if defined(WITH_THREADS) || defined(USE_THOL)
+.if defined(WITH_THREADS)
@${REINPLACE_CMD} -e "s|-lpthread|${PTHREAD_LIBS}|g" \
${WRKSRC}/configure
@${REINPLACE_CMD} -E -e "s|(Libs:.*)|\1 ${PTHREAD_LIBS}|" \
@@ -122,9 +111,5 @@ post-install:
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
.endif
-.if defined(USE_THOL)
- @${MKDIR} ${DATADIR}
- @${TOUCH} ${DATADIR}/sqlite3_with_threads-override-locks
-.endif
.include <bsd.port.post.mk>
diff --git a/databases/sqlite34/distinfo b/databases/sqlite34/distinfo
index 0a33511ac3c0..2f313e082ba8 100644
--- a/databases/sqlite34/distinfo
+++ b/databases/sqlite34/distinfo
@@ -1,3 +1,3 @@
-MD5 (sqlite-3.4.1.tar.gz) = 0f06955b18da295fecb62d4bf9ded3c6
-SHA256 (sqlite-3.4.1.tar.gz) = d604a4db7781db3d8dda0bb30c4a35bbee184d48e72d9c0de855cf55170ee1be
-SIZE (sqlite-3.4.1.tar.gz) = 2237515
+MD5 (sqlite-3.4.2.tar.gz) = 2feec9b429f9298c9f288420c8b449f8
+SHA256 (sqlite-3.4.2.tar.gz) = 0ad86c4b26cd687122b158bf848f0a07d7cd644033d15c4f43b6d643bd74cd81
+SIZE (sqlite-3.4.2.tar.gz) = 2377646
diff --git a/databases/sqlite34/files/fts2_patch-Makefile.in b/databases/sqlite34/files/fts2_patch-Makefile.in
index b079a8501121..5809bcb9d6c2 100644
--- a/databases/sqlite34/files/fts2_patch-Makefile.in
+++ b/databases/sqlite34/files/fts2_patch-Makefile.in
@@ -1,16 +1,16 @@
--- Makefile.in.orig 2007-06-28 09:46:18.000000000 -0300
-+++ Makefile.in 2007-08-10 08:47:35.000000000 -0300
++++ Makefile.in 2008-03-05 22:07:49.000000000 -0300
@@ -128,7 +128,8 @@
select.lo table.lo tokenize.lo trigger.lo update.lo \
util.lo vacuum.lo \
vdbe.lo vdbeapi.lo vdbeaux.lo vdbeblob.lo vdbefifo.lo vdbemem.lo \
- where.lo utf.lo legacy.lo vtab.lo
+ where.lo utf.lo legacy.lo vtab.lo \
-+ fts2.lo fts2_hash.lo fts2_porter.lo fts2_tokenizer.lo fts2_tokenizer1.lo
++ fts2.lo fts2_hash.lo fts2_porter.lo fts2_icu.lo fts2_tokenizer.lo fts2_tokenizer1.lo
# All of the source code files.
#
-@@ -198,6 +199,15 @@
+@@ -198,6 +199,16 @@
$(TOP)/ext/fts1/fts1_tokenizer.h \
$(TOP)/ext/fts1/fts1_tokenizer1.c
@@ -20,13 +20,14 @@
+ $(TOP)/ext/fts2/fts2_hash.c \
+ $(TOP)/ext/fts2/fts2_hash.h \
+ $(TOP)/ext/fts2/fts2_porter.c \
++ $(TOP)/ext/fts2/fts2_icu.c \
+ $(TOP)/ext/fts2/fts2_tokenizer.c \
+ $(TOP)/ext/fts2/fts2_tokenizer.h \
+ $(TOP)/ext/fts2/fts2_tokenizer1.c
# Source code to the test files.
#
-@@ -261,6 +271,11 @@
+@@ -261,6 +272,11 @@
$(TOP)/ext/fts1/fts1_hash.h \
$(TOP)/ext/fts1/fts1_tokenizer.h
@@ -38,7 +39,7 @@
# Header files used by the VDBE submodule
#
VDBEHDR = \
-@@ -482,6 +497,21 @@
+@@ -482,6 +498,24 @@
where.lo: $(TOP)/src/where.c $(HDR)
$(LTCOMPILE) -c $(TOP)/src/where.c
@@ -51,6 +52,9 @@
+fts2_porter.lo: $(TOP)/ext/fts2/fts2_porter.c $(HDR)
+ $(LTCOMPILE) -c $(TOP)/ext/fts2/fts2_porter.c
+
++fts2_icu.lo: $(TOP)/ext/fts2/fts2_icu.c $(HDR)
++ $(LTCOMPILE) -c $(TOP)/ext/fts2/fts2_icu.c
++
+fts2_tokenizer.lo: $(TOP)/ext/fts2/fts2_tokenizer.c $(HDR)
+ $(LTCOMPILE) -c $(TOP)/ext/fts2/fts2_tokenizer.c
+
diff --git a/databases/sqlite34/files/patch-ext__fts1__fts1.c b/databases/sqlite34/files/patch-ext__fts1__fts1.c
deleted file mode 100644
index 8357e5832668..000000000000
--- a/databases/sqlite34/files/patch-ext__fts1__fts1.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- ext/fts1/fts1.c.orig Sun Oct 8 06:16:32 2006
-+++ ext/fts1/fts1.c Sun Dec 3 14:44:46 2006
-@@ -19,11 +19,7 @@
- #endif
-
- #include <assert.h>
--#if !defined(__APPLE__)
--#include <malloc.h>
--#else
- #include <stdlib.h>
--#endif
- #include <stdio.h>
- #include <string.h>
- #include <ctype.h>
diff --git a/databases/sqlite34/files/patch-ext__fts1__fts1_porter.c b/databases/sqlite34/files/patch-ext__fts1__fts1_porter.c
deleted file mode 100644
index 6185bf94dcd5..000000000000
--- a/databases/sqlite34/files/patch-ext__fts1__fts1_porter.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- ext/fts1/fts1_porter.c.orig Sun Oct 1 13:01:13 2006
-+++ ext/fts1/fts1_porter.c Sun Dec 3 14:45:17 2006
-@@ -26,11 +26,7 @@
-
-
- #include <assert.h>
--#if !defined(__APPLE__)
--#include <malloc.h>
--#else
- #include <stdlib.h>
--#endif
- #include <stdio.h>
- #include <string.h>
- #include <ctype.h>
diff --git a/databases/sqlite34/files/patch-ext__fts1__fts1_tokenizer1.c b/databases/sqlite34/files/patch-ext__fts1__fts1_tokenizer1.c
deleted file mode 100644
index 438019e54f9d..000000000000
--- a/databases/sqlite34/files/patch-ext__fts1__fts1_tokenizer1.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- ext/fts1/fts1_tokenizer1.c.orig Sat Sep 30 08:57:33 2006
-+++ ext/fts1/fts1_tokenizer1.c Sun Dec 3 14:45:56 2006
-@@ -18,11 +18,7 @@
-
-
- #include <assert.h>
--#if !defined(__APPLE__)
--#include <malloc.h>
--#else
- #include <stdlib.h>
--#endif
- #include <stdio.h>
- #include <string.h>
- #include <ctype.h>
diff --git a/databases/sqlite34/files/patch-ext__fts2__fts2.c b/databases/sqlite34/files/patch-ext__fts2__fts2.c
deleted file mode 100644
index b68f8f3a4a64..000000000000
--- a/databases/sqlite34/files/patch-ext__fts2__fts2.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- ext/fts2/fts2.c.orig Fri Jun 8 12:31:37 2007
-+++ ext/fts2/fts2.c Fri Jun 8 12:32:16 2007
-@@ -269,9 +269,6 @@
- #endif
-
- #include <assert.h>
--#if !defined(__APPLE__)
--#include <malloc.h>
--#endif
- #include <stdlib.h>
- #include <stdio.h>
- #include <string.h>
diff --git a/databases/sqlite34/files/patch-ext__fts2__fts2_porter.c b/databases/sqlite34/files/patch-ext__fts2__fts2_porter.c
deleted file mode 100644
index 0ed308c4f012..000000000000
--- a/databases/sqlite34/files/patch-ext__fts2__fts2_porter.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- ext/fts2/fts2_porter.c.orig Fri Jun 8 12:31:44 2007
-+++ ext/fts2/fts2_porter.c Fri Jun 8 12:32:21 2007
-@@ -26,11 +26,7 @@
-
-
- #include <assert.h>
--#if !defined(__APPLE__)
--#include <malloc.h>
--#else
- #include <stdlib.h>
--#endif
- #include <stdio.h>
- #include <string.h>
- #include <ctype.h>
diff --git a/databases/sqlite34/files/patch-ext__fts2__fts2_tokenizer1.c b/databases/sqlite34/files/patch-ext__fts2__fts2_tokenizer1.c
deleted file mode 100644
index 1f539b950b31..000000000000
--- a/databases/sqlite34/files/patch-ext__fts2__fts2_tokenizer1.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- ext/fts2/fts2_tokenizer1.c.orig Fri Jun 8 12:31:51 2007
-+++ ext/fts2/fts2_tokenizer1.c Fri Jun 8 12:32:26 2007
-@@ -18,11 +18,7 @@
-
-
- #include <assert.h>
--#if !defined(__APPLE__)
--#include <malloc.h>
--#else
- #include <stdlib.h>
--#endif
- #include <stdio.h>
- #include <string.h>
- #include <ctype.h>
diff --git a/databases/sqlite34/pkg-plist b/databases/sqlite34/pkg-plist
index f6b0ecd11099..72bc9ffc9609 100644
--- a/databases/sqlite34/pkg-plist
+++ b/databases/sqlite34/pkg-plist
@@ -15,5 +15,3 @@ libdata/pkgconfig/sqlite3.pc
%%WITH_TCLWRAPPER%%@dirrm lib/sqlite
%%WITH_TCLWRAPPER%%%%EXAMPLESDIR%%/example.tcl
%%WITH_TCLWRAPPER%%@dirrm %%EXAMPLESDIR%%
-%%THOL%%%%DATADIR%%/sqlite3_with_threads-override-locks
-%%THOL%%@dirrm %%DATADIR%%