aboutsummaryrefslogtreecommitdiff
path: root/databases/tarantool/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/tarantool/Makefile')
-rw-r--r--databases/tarantool/Makefile24
1 files changed, 5 insertions, 19 deletions
diff --git a/databases/tarantool/Makefile b/databases/tarantool/Makefile
index 5d4c5e153b66..356c85ff81f3 100644
--- a/databases/tarantool/Makefile
+++ b/databases/tarantool/Makefile
@@ -2,20 +2,17 @@
# $FreeBSD$
PORTNAME= tarantool
-PORTVERSION= 1.6.6
+PORTVERSION= 1.6.8.371
CATEGORIES= databases
-MASTER_SITES= http://tarantool.org/dist/master/
-DISTNAME= ${PORTNAME}-${PORTVERSION}-${TR_REV}-src
+MASTER_SITES= http://tarantool.org/dist/1.6/
MAINTAINER= vg@FreeBSD.org
COMMENT= NoSQL database running in a Lua application server
LICENSE= BSD2CLAUSE
-TR_REV= 130-ge3f2420
MAKE_JOBS_UNSAFE=yes
USES= cmake compiler:c++11-lang gettext gmake perl5 readline
-USE_GCC= yes # clang bug PR/201270
USE_LDCONFIG= yes
USE_RC_SUBR= ${PORTNAME}
SUB_FILES= pkg-message
@@ -25,9 +22,9 @@ TT_RUNDIR?= /var/run/tarantool
TT_LOGDIR?= /var/log/tarantool
CMAKE_ARGS= -DCMAKE_INSTALL_MANDIR=man \
- -DCMAKE_INSTALL_SYSCONFDIR=${ETCDIR} \
- -DCMAKE_LOCALSTATE_DIR=${DATADIR} \
- -DTARANTOOL_DATADIR="${TT_DATADIR}"
+ -DCMAKE_INSTALL_FULL_SYSCONFDIR=${ETCDIR} \
+ -DCMAKE_INSTALL_LOCALSTATEDIR=/var \
+ -DENABLE_DIST=ON
USERS= tarantool
GROUPS= tarantool
@@ -52,11 +49,6 @@ NOT_FOR_ARCHS_REASON= not yet ported to this architecture
.include <bsd.port.options.mk>
-.include "${.CURDIR}/../../Mk/bsd.default-versions.mk"
-.if defined(USE_GCC) && ${USE_GCC} == yes && ${GCC_DEFAULT} == 4.8
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-src_trivia_config.h.cmake
-.endif
-
.if ${PORT_OPTIONS:MDEBUG}
CMAKE_BUILD_TYPE= RelWithDebugInfo
CMAKE_ARGS+= -DENABLE_BACKTRACE=ON
@@ -65,10 +57,4 @@ CMAKE_BUILD_TYPE= Rel
CMAKE_ARGS+= -DENABLE_BACKTRACE=OFF
.endif
-post-install:
- ${MKDIR} ${STAGEDIR}${TT_LOGDIR} \
- ${STAGEDIR}${TT_DATADIR} \
- ${STAGEDIR}${TT_RUNDIR} \
- ${STAGEDIR}${ETCDIR}/instances.enabled
-
.include <bsd.port.mk>