aboutsummaryrefslogtreecommitdiff
path: root/databases/tarantool
diff options
context:
space:
mode:
Diffstat (limited to 'databases/tarantool')
-rw-r--r--databases/tarantool/Makefile7
-rw-r--r--databases/tarantool/distinfo4
-rw-r--r--databases/tarantool/files/patch-doc_man_CMakeLists.txt12
-rw-r--r--databases/tarantool/files/patch-src_CMakeLists.txt25
-rw-r--r--databases/tarantool/pkg-plist2
5 files changed, 24 insertions, 26 deletions
diff --git a/databases/tarantool/Makefile b/databases/tarantool/Makefile
index cec0f140cdbb..e03e0cd4147c 100644
--- a/databases/tarantool/Makefile
+++ b/databases/tarantool/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= tarantool
-PORTVERSION= 1.4.8
-PORTREVISION= 2
+PORTVERSION= 1.4.9
CATEGORIES= databases
MASTER_SITES= http://tarantool.org/dist/
DISTNAME= ${PORTNAME}-${PORTVERSION}-${TR_REV}-src
@@ -13,7 +12,7 @@ COMMENT= High performance key/value storage server
LICENSE= BSD
-TR_REV= 72-g277010b
+TR_REV= 45-g2f7b3f9
USES= cmake gettext:build
USE_GCC= 4.6+
USE_GMAKE= yes
@@ -22,6 +21,7 @@ USE_PERL5= yes
USE_RC_SUBR= ${PORTNAME}
SUB_FILES= pkg-message
MAN1= tarantool_box.1
+CMAKE_ARGS= -DCMAKE_MAN_DIR=man/man1
OPTIONS_DEFINE= CLIENT DEBUG STATIC
CLIENT_DESC= Enable client
@@ -46,6 +46,7 @@ CMAKE_ARGS+= -DCMAKE_BUILD_TYPE=RelWithDebugInfo
.endif
.if ${PORT_OPTIONS:MSTATIC}
+LIB_DEPENDS+= iconv:${PORTSDIR}/converters/iconv
CMAKE_ARGS+= -DENABLE_STATIC=true
.endif
diff --git a/databases/tarantool/distinfo b/databases/tarantool/distinfo
index 439fa3db35f0..4ff5f33476cc 100644
--- a/databases/tarantool/distinfo
+++ b/databases/tarantool/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tarantool-1.4.8-72-g277010b-src.tar.gz) = ff19a272d912947fb4d56d4bec3986681a3fad3091c1bb0504a7ea5dc38f4330
-SIZE (tarantool-1.4.8-72-g277010b-src.tar.gz) = 2268177
+SHA256 (tarantool-1.4.9-45-g2f7b3f9-src.tar.gz) = 45c37824c0f2cef8746523347ba727ced98e8c21eec17e11729d6ff38d1f7bbd
+SIZE (tarantool-1.4.9-45-g2f7b3f9-src.tar.gz) = 2772012
diff --git a/databases/tarantool/files/patch-doc_man_CMakeLists.txt b/databases/tarantool/files/patch-doc_man_CMakeLists.txt
deleted file mode 100644
index abda94ac6917..000000000000
--- a/databases/tarantool/files/patch-doc_man_CMakeLists.txt
+++ /dev/null
@@ -1,12 +0,0 @@
---- doc/man/CMakeLists.txt.orig 2012-12-11 01:42:20.346392205 +0400
-+++ doc/man/CMakeLists.txt 2012-12-11 01:42:53.437090883 +0400
-@@ -5,7 +5,7 @@
- ${CMAKE_SOURCE_DIR}/doc/man/tarantool.pod > ${PROJECT_BINARY_DIR}/doc/man/tarantool.1
- )
-
--install(FILES ${PROJECT_BINARY_DIR}/doc/man/tarantool_box.1 DESTINATION "${CMAKE_MAN_DIR}")
-+install(FILES ${PROJECT_BINARY_DIR}/doc/man/tarantool_box.1 DESTINATION "${CMAKE_MAN_DIR}/man1")
- if (ENABLE_CLIENT)
-- install(FILES ${PROJECT_BINARY_DIR}/doc/man/tarantool.1 DESTINATION "${CMAKE_MAN_DIR}")
-+ install(FILES ${PROJECT_BINARY_DIR}/doc/man/tarantool.1 DESTINATION "${CMAKE_MAN_DIR}/man1")
- endif()
diff --git a/databases/tarantool/files/patch-src_CMakeLists.txt b/databases/tarantool/files/patch-src_CMakeLists.txt
index 7196e487eaf0..0d801ac6c72b 100644
--- a/databases/tarantool/files/patch-src_CMakeLists.txt
+++ b/databases/tarantool/files/patch-src_CMakeLists.txt
@@ -1,13 +1,22 @@
---- src/CMakeLists.txt.orig 2012-12-11 02:19:57.157548371 +0400
-+++ src/CMakeLists.txt 2012-12-11 02:23:55.400718104 +0400
-@@ -155,6 +155,10 @@
+--- src/CMakeLists.txt.orig 2013-05-18 07:08:17.087914237 +0000
++++ src/CMakeLists.txt 2013-05-18 10:23:24.584910099 +0000
+@@ -138,6 +138,10 @@
set (common_libraries ${common_libraries} dl)
endif()
-+if (NOT LINUX)
-+ set (common_libraries ${common_libraries} intl) # if used not GNU libc, depended by gettext
++if (TARGET_OS_FREEBSD)
++ set (common_libraries ${common_libraries} intl)
+endif()
+
- if (ENABLE_GCOV)
- set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${GCOV_C_FLAGS}")
- set (LDFLAGS "${LDFLAGS} ${GCOV_LDFLAGS}")
+ if (ENABLE_BACKTRACE AND HAVE_BFD)
+ set (common_libraries ${common_libraries} bfd)
+ if (NOT TARGET_OS_DARWIN)
+@@ -145,7 +149,7 @@
+ endif()
+ if (ENABLE_STATIC OR TARGET_OS_FREEBSD)
+ include (FindZLIB)
+- set (common_libraries ${common_libraries} ${ZLIB_LIBRARIES})
++ set (common_libraries ${common_libraries} ${ZLIB_LIBRARIES} iconv intl)
+ endif()
+ endif()
+
diff --git a/databases/tarantool/pkg-plist b/databases/tarantool/pkg-plist
index de45cfc136a4..6ec1d5d2f1de 100644
--- a/databases/tarantool/pkg-plist
+++ b/databases/tarantool/pkg-plist
@@ -47,7 +47,7 @@ lib/libtarantoolsql.so
lib/libtarantool.so.1.1
lib/libtarantoolrpl.a
lib/libtarantool.so
-%%DOCSDIR%%/README
+%%DOCSDIR%%/README.md
%%DOCSDIR%%/box-protocol.txt
%%DOCSDIR%%/LICENSE
@dirrm %%DOCSDIR%%