aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
Diffstat (limited to 'databases')
-rw-r--r--databases/evolution-data-server/Makefile18
-rw-r--r--databases/gdbm/Makefile6
2 files changed, 21 insertions, 3 deletions
diff --git a/databases/evolution-data-server/Makefile b/databases/evolution-data-server/Makefile
index 355d60d4b793..4019e529f7f9 100644
--- a/databases/evolution-data-server/Makefile
+++ b/databases/evolution-data-server/Makefile
@@ -68,5 +68,23 @@ post-patch:
s|-Wl,--no-undefined||g ; \
s|-Wmissing-include-dirs||g' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} '/^e_addressbook_factory_LDADD =/ \
+ s/=/= -lgio-2.0 -lgobject-2.0 -lgthread-2.0 -lglib-2.0 $$(INTLLIBS)/' \
+ ${WRKSRC}/addressbook/libedata-book/Makefile.in
+ @${REINPLACE_CMD} '/^test_interval_searches_LDADD =/s/=/= -lgthread-2.0/' \
+ ${WRKSRC}/calendar/backends/file/Makefile.in
+ @${REINPLACE_CMD} -e '/^test_e_sexp_LDADD =/s/=/= -lical/' \
+ -e '/^test_intervaltree_LDADD =/s/=/= -lical/' \
+ -e '/^e_calendar_factory_LDADD =/s|=|= ../libecal/libecal-1.2.la -lical|' \
+ ${WRKSRC}/calendar/libedata-cal/Makefile.in
+ @${REINPLACE_CMD} '/^camel_index_control_1_2_LDADD =/s/=/= -lgthread-2.0/' \
+ ${WRKSRC}/camel/Makefile.in
+ @${REINPLACE_CMD} '/^test_imapx_LDADD =/s/=/= -lgobject-2.0 -lgthread-2.0/' \
+ ${WRKSRC}/camel/providers/imapx/Makefile.in
+ @${REINPLACE_CMD} -e '/^test_contact_store_LDADD =/s|$$| ../addressbook/libebook/libebook-1.2.la|' \
+ -e '/^test_name_selector_LDADD =/s|$$| ../camel/libcamel-1.2.la -lgthread-2.0|' \
+ ${WRKSRC}/libedataserverui/Makefile.in
+ @${REINPLACE_CMD} '/^soap_test_LDADD =/s/=/= -lgthread-2.0/' \
+ ${WRKSRC}/servers/groupwise/Makefile.in
.include <bsd.port.mk>
diff --git a/databases/gdbm/Makefile b/databases/gdbm/Makefile
index 386bb7354049..7380ad2445a6 100644
--- a/databases/gdbm/Makefile
+++ b/databases/gdbm/Makefile
@@ -13,6 +13,7 @@ COMMENT= GNU database manager
LICENSE= GPLv3
GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
USES= gmake libtool:keepla
@@ -32,8 +33,7 @@ post-patch:
-e "s|BINOWN = bin|BINOWN = root|" -e "s|BINGRP = bin|BINGRP = wheel|" \
-e "s|libgdbm.la libgdbm_compat.la|libgdbm.la libgdbm_compat.la gdbm.info|" \
${WRKSRC}/Makefile.in
-
-post-install:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgdbm*.so
+ @${REINPLACE_CMD} '/_LDADD =/s/$$/ @LTLIBINTL@/' \
+ ${WRKSRC}/src/Makefile.in
.include <bsd.port.mk>