aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
Diffstat (limited to 'databases')
-rw-r--r--databases/grass/Makefile3
-rw-r--r--databases/msql/Makefile8
-rw-r--r--databases/msql3/Makefile8
-rw-r--r--databases/namazu2/Makefile9
-rw-r--r--databases/rdb/Makefile8
-rw-r--r--databases/wfb2sql/Makefile8
-rw-r--r--databases/yasql/Makefile8
7 files changed, 13 insertions, 39 deletions
diff --git a/databases/grass/Makefile b/databases/grass/Makefile
index 7853a52b3410..969a1bbd5044 100644
--- a/databases/grass/Makefile
+++ b/databases/grass/Makefile
@@ -34,8 +34,7 @@ LIB_DEPENDS= gdal:${PORTSDIR}/graphics/gdal \
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
USE_GMAKE= yes
-USES= gettext iconv readline
-USE_PERL5= yes
+USES= gettext iconv readline perl5
USE_XORG= sm ice xi x11 xt xmu xext
USE_GL= glut
USE_TCL= yes
diff --git a/databases/msql/Makefile b/databases/msql/Makefile
index f6abf20d077e..f4f542da99df 100644
--- a/databases/msql/Makefile
+++ b/databases/msql/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: msql2
-# Date created: December 17th 1996
-# Whom: jfitz
-#
+# Created by: jfitz
# $FreeBSD$
-#
PORTNAME= msql
PORTVERSION= 2.0.12
@@ -15,8 +11,8 @@ COMMENT= The Mini SQL server, version 2
CONFLICTS= msql-3*
+USES= perl5
USE_LDCONFIG= YES
-USE_PERL5= YES
PKGMESSAGE= ${FILESDIR}/post-install-notes
USERS= ${PORTNAME}
diff --git a/databases/msql3/Makefile b/databases/msql3/Makefile
index a11d52d67089..3f686e6e9884 100644
--- a/databases/msql3/Makefile
+++ b/databases/msql3/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: msql3
-# Date created: 24 May 2004
-# Whom: Andrey Slusar <anray@FreeBSD.org>
-#
+# Created by: Andrey Slusar <anray@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= msql
PORTVERSION= 3.8
@@ -14,8 +10,8 @@ COMMENT= Version 3 of the Mini SQL relational database system
CONFLICTS= msql-2*
+USES= perl5
USE_LDCONFIG= YES
-USE_PERL5= YES
USERS= ${PORTNAME}
GROUPS= ${USERS}
diff --git a/databases/namazu2/Makefile b/databases/namazu2/Makefile
index 5eb0363a43fa..2175a470e2dd 100644
--- a/databases/namazu2/Makefile
+++ b/databases/namazu2/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: namazu2
-# Date created: 25 February 2000
-# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
-#
+# Created by: Akinori MUSHA aka knu <knu@idaemons.org>
# $FreeBSD$
-#
PORTNAME= namazu
PORTVERSION= ${NAMAZU_PORTVERSION}
@@ -17,8 +13,7 @@ COMMENT= Full-text search system intended for easy use
BUILD_DEPENDS= p5-File-MMagic>=0:${PORTSDIR}/devel/p5-File-MMagic
RUN_DEPENDS= p5-File-MMagic>=0:${PORTSDIR}/devel/p5-File-MMagic
-USE_PERL5= yes
-USES= gettext iconv
+USES= gettext iconv perl5
USE_AUTOTOOLS= libtool
CONFIGURE_ARGS= --with-perl5="${PERL}" \
--with-libintl-prefix=${LOCALBASE} \
diff --git a/databases/rdb/Makefile b/databases/rdb/Makefile
index 275907c56b5a..e9a35a1080dc 100644
--- a/databases/rdb/Makefile
+++ b/databases/rdb/Makefile
@@ -1,9 +1,5 @@
-# ports collection makefile for: rdb
-# Date created: 2000 Feb. 8
-# Whom: Abel Chow <abel_chow@yahoo.com>
-#
+# Created by: Abel Chow <abel_chow@yahoo.com>
# $FreeBSD$
-#
PORTNAME= rdb
PORTVERSION= 2.6d
@@ -15,7 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A fast, portable, relational database management system
WRKSRC= ${WRKDIR}/rdb
-USE_PERL5= yes
+USES= perl5
BINFILES= column compute dataent etbl headchg jointbl lst2tbl \
mergetbl mktbl ptbl rdb rdbt repair reporttbl row search \
diff --git a/databases/wfb2sql/Makefile b/databases/wfb2sql/Makefile
index 957e0fce72d9..73e128b816e3 100644
--- a/databases/wfb2sql/Makefile
+++ b/databases/wfb2sql/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: wfb2sql
-# Date created: August 21st, 2003
-# Whom: Sean Chittenden <seanc@FreeBSD.org>
-#
+# Created by: Sean Chittenden <seanc@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= wfb2sql
PORTVERSION= 0.6
@@ -17,8 +13,8 @@ COMMENT= CIA World Fact Book to SQL Conversion Utility
BUILD_DEPENDS= p5-Config-General>=0:${PORTSDIR}/devel/p5-Config-General
RUN_DEPENDS:= ${BUILD_DEPENDS}
+USES= perl5
NO_BUILD= YES
-USE_PERL5= YES
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/wfb2sql ${PREFIX}/bin/wfb2sql
diff --git a/databases/yasql/Makefile b/databases/yasql/Makefile
index a4759d92f124..9a06aa483ead 100644
--- a/databases/yasql/Makefile
+++ b/databases/yasql/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: yasql
-# Date created: 22 February 2005
-# Whom: Thierry Thomas <thierry@pompo.net>
-#
+# Created by: Thierry Thomas <thierry@pompo.net>
# $FreeBSD$
-#
PORTNAME= yasql
PORTVERSION= 1.83
@@ -37,7 +33,7 @@ BUILD_DEPENDS+= p5-Term-ReadKey>=0:${PORTSDIR}/devel/p5-Term-ReadKey
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
-USE_PERL5= yes
+USES+= perl5
ALL_TARGET= default
SUB_FILES= pkg-message