aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
Diffstat (limited to 'databases')
-rw-r--r--databases/clip/Makefile2
-rw-r--r--databases/db2/Makefile2
-rw-r--r--databases/dbh/Makefile2
-rw-r--r--databases/dbh10/Makefile2
-rw-r--r--databases/libiodbc/Makefile2
-rw-r--r--databases/libsdb/Makefile2
-rw-r--r--databases/mdbtools/Makefile2
-rw-r--r--databases/metakit/Makefile2
-rw-r--r--databases/namazu2/Makefile2
-rw-r--r--databases/pgcluster/Makefile2
-rw-r--r--databases/tdb/Makefile2
-rw-r--r--databases/typhoon/Makefile2
-rw-r--r--databases/unixODBC/Makefile2
-rw-r--r--databases/xbase/Makefile2
-rw-r--r--databases/xbsql/Makefile2
15 files changed, 15 insertions, 15 deletions
diff --git a/databases/clip/Makefile b/databases/clip/Makefile
index a06828c8ede7..e2b04e11995e 100644
--- a/databases/clip/Makefile
+++ b/databases/clip/Makefile
@@ -103,7 +103,7 @@ USE_XPM= yes
USE_GNOME= gtk12 gtk20
HAS_CONFIGURE= yes
CONFIGURE_WRKSRC= ${WRKSRC}/clip
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
LDCONFIG_DIRS= ${LOCALBASE}/clip/lib
ALL_TARGET= local
MAKE_ENV= HOME="${WRKDIR}" \
diff --git a/databases/db2/Makefile b/databases/db2/Makefile
index 842d92aa7837..9e5e6080b9df 100644
--- a/databases/db2/Makefile
+++ b/databases/db2/Makefile
@@ -19,7 +19,7 @@ COMMENT= The Berkeley DB package, revision 2
WRKSRC= ${WRKDIR}/${DISTNAME}/build_unix
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_SCRIPT= ../dist/configure
CONFIGURE_ARGS= --enable-compat185 \
diff --git a/databases/dbh/Makefile b/databases/dbh/Makefile
index 5732cc9ad3dd..169a31d5d770 100644
--- a/databases/dbh/Makefile
+++ b/databases/dbh/Makefile
@@ -18,6 +18,6 @@ COMMENT= Disk Based Hashtables
USE_GNOME= gnomehack gnometarget pkgconfig
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
.include <bsd.port.mk>
diff --git a/databases/dbh10/Makefile b/databases/dbh10/Makefile
index 5732cc9ad3dd..169a31d5d770 100644
--- a/databases/dbh10/Makefile
+++ b/databases/dbh10/Makefile
@@ -18,6 +18,6 @@ COMMENT= Disk Based Hashtables
USE_GNOME= gnomehack gnometarget pkgconfig
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
.include <bsd.port.mk>
diff --git a/databases/libiodbc/Makefile b/databases/libiodbc/Makefile
index ce540a3de9d4..9a7d418a2665 100644
--- a/databases/libiodbc/Makefile
+++ b/databases/libiodbc/Makefile
@@ -26,7 +26,7 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-iodbc-inidir=${INIDIR}
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
MAN1= iodbc-config.1 iodbctest.1 iodbctestw.1
diff --git a/databases/libsdb/Makefile b/databases/libsdb/Makefile
index c518e5d736a5..bd1859c9cacf 100644
--- a/databases/libsdb/Makefile
+++ b/databases/libsdb/Makefile
@@ -18,7 +18,7 @@ COMMENT= Simple database library
HAS_CONFIGURE= yes
MAKE_ARGS= PREFIX="${PREFIX}" CC="${CC}" CFLAGS="${CFLAGS}"
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
NO_FILTER_SHLIBS= yes
MAN3= sdb.3 sdb_init.3 sdb_open.3 sdb_close.3 sdb_query.3
diff --git a/databases/mdbtools/Makefile b/databases/mdbtools/Makefile
index 223a8521f9ab..0670afa7272d 100644
--- a/databases/mdbtools/Makefile
+++ b/databases/mdbtools/Makefile
@@ -20,7 +20,7 @@ BUILD_DEPENDS= gawk:${PORTSDIR}/lang/gawk # To build man-pages
USE_BISON= yes
USE_GNOME= glib20
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
DOCS= AUTHORS ChangeLog HACKING NEWS README TODO
MAN1= mdb-ver.1 mdb-tables.1 mdb-schema.1 mdb-sql.1 mdb-export.1
diff --git a/databases/metakit/Makefile b/databases/metakit/Makefile
index 8f3f43bfa613..9e08c1f1b07a 100644
--- a/databases/metakit/Makefile
+++ b/databases/metakit/Makefile
@@ -25,7 +25,7 @@ BUILD_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/builds
GNU_CONFIGURE= yes
CONFIGURE_SCRIPT= ../unix/configure
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
MAKE_ARGS= CXXFLAGS="-Dq4_INLINE ${CFLAGS} -fpermissive"
ONLY_FOR_ARCHS= i386 alpha
diff --git a/databases/namazu2/Makefile b/databases/namazu2/Makefile
index 7067e3619d1c..441fd22cb27b 100644
--- a/databases/namazu2/Makefile
+++ b/databases/namazu2/Makefile
@@ -29,7 +29,7 @@ CONFIGURE_ARGS= --with-perl5="${PERL}" \
--with-libiconv-prefix=${LOCALBASE}
MAN1= namazu.1 mknmz.1
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
post-install:
.if defined(NOPORTDOCS)
diff --git a/databases/pgcluster/Makefile b/databases/pgcluster/Makefile
index b47747309a54..4585c5d51e18 100644
--- a/databases/pgcluster/Makefile
+++ b/databases/pgcluster/Makefile
@@ -30,7 +30,7 @@ MAKE_FLAGS= # empty
MAKEFILE= # empty
CONFLICTS= postgresql-*
USE_RC_SUBR= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-debug
INSTALL_TARGET= install
diff --git a/databases/tdb/Makefile b/databases/tdb/Makefile
index 9bfdce20aded..6dffb805085d 100644
--- a/databases/tdb/Makefile
+++ b/databases/tdb/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Trivial Database
USE_AUTOTOOLS= automake:14 autoconf:213 libtool:15
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
MAN3= tdb.3 tdb_chainlock.3 tdb_close.3 tdb_delete.3 tdb_error.3 \
tdb_exists.3 tdb_fetch.3 tdb_firstkey.3 tdb_open.3 tdb_store.3 \
diff --git a/databases/typhoon/Makefile b/databases/typhoon/Makefile
index a23dfa50678a..2bd781fcaddd 100644
--- a/databases/typhoon/Makefile
+++ b/databases/typhoon/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A relational database library
HAS_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
MAN1= ddlp.1
MAN3= d_close.3 d_crget.3 d_crread.3 d_crset.3 d_dbdpath.3 d_dbfpath.3 \
diff --git a/databases/unixODBC/Makefile b/databases/unixODBC/Makefile
index d7db7e6c8db2..3efb5e6592fd 100644
--- a/databases/unixODBC/Makefile
+++ b/databases/unixODBC/Makefile
@@ -21,7 +21,7 @@ USE_ICONV= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-static --enable-shared \
--with-libiconv-prefix=${LOCALBASE}
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
.if defined(WITH_GUI)
USE_QT_VER= 3
diff --git a/databases/xbase/Makefile b/databases/xbase/Makefile
index d151ee463da5..048d4a524f0a 100644
--- a/databases/xbase/Makefile
+++ b/databases/xbase/Makefile
@@ -16,7 +16,7 @@ COMMENT= An xbase (i.e. dBase, FoxPro, etc.) compatible C++ class library
USE_AUTOTOOLS= libtool:15
USE_GNOME= lthack
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
.if defined(MAINTAINER_MODE)
test: install
diff --git a/databases/xbsql/Makefile b/databases/xbsql/Makefile
index e702659fe364..d8f6d2cecfae 100644
--- a/databases/xbsql/Makefile
+++ b/databases/xbsql/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= xbase-2.0.0:${PORTSDIR}/databases/xbase
USE_BISON= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
LB2FIX= Makefile.in test/Makefile.in xbsql/Makefile.in