aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
Diffstat (limited to 'databases')
-rw-r--r--databases/akonadi-kde4/Makefile2
-rw-r--r--databases/akonadi/Makefile2
-rw-r--r--databases/arangodb32/Makefile2
-rw-r--r--databases/arangodb33/Makefile2
-rw-r--r--databases/cassandra-cpp-driver/Makefile6
-rw-r--r--databases/clickhouse/Makefile2
-rw-r--r--databases/cppdb/Makefile2
-rw-r--r--databases/iowow/Makefile2
-rw-r--r--databases/kdb/Makefile2
-rw-r--r--databases/kexi/Makefile2
-rw-r--r--databases/mariadb-connector-c/Makefile2
-rw-r--r--databases/mariadb-connector-odbc/Makefile2
-rw-r--r--databases/mariadb100-server/Makefile2
-rw-r--r--databases/mariadb101-server/Makefile2
-rw-r--r--databases/mariadb102-server/Makefile2
-rw-r--r--databases/mariadb103-server/Makefile2
-rw-r--r--databases/mariadb55-server/Makefile2
-rw-r--r--databases/mydumper/Makefile2
-rw-r--r--databases/mysql-connector-c++/Makefile2
-rw-r--r--databases/mysql-connector-c/Makefile2
-rw-r--r--databases/mysql55-server/Makefile2
-rw-r--r--databases/mysql56-server/Makefile2
-rw-r--r--databases/mysql57-server/Makefile2
-rw-r--r--databases/mysql80-server/Makefile2
-rw-r--r--databases/mysqlwsrep56-server/Makefile2
-rw-r--r--databases/mysqlwsrep57-server/Makefile2
-rw-r--r--databases/opendbviewer/Makefile2
-rw-r--r--databases/percona55-server/Makefile2
-rw-r--r--databases/percona56-server/Makefile2
-rw-r--r--databases/percona57-server/Makefile2
-rw-r--r--databases/pgagent/Makefile2
-rw-r--r--databases/pgrouting/Makefile2
-rw-r--r--databases/timescaledb/Makefile2
-rw-r--r--databases/xrootd/Makefile2
34 files changed, 37 insertions, 35 deletions
diff --git a/databases/akonadi-kde4/Makefile b/databases/akonadi-kde4/Makefile
index f6eca2df671b..5c86a50038e7 100644
--- a/databases/akonadi-kde4/Makefile
+++ b/databases/akonadi-kde4/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= libboost_thread.so:devel/boost-libs
# Let process generate meaningful backtrace on core dump.
BUILD_DEPENDS= xsltproc:textproc/libxslt
-USES= cmake:outsource kde:4 qt:4 shared-mime-info \
+USES= cmake kde:4 qt:4 shared-mime-info \
compiler:c++11-lang pathfix tar:bzip2
USE_KDE= automoc4 soprano
USE_QT= corelib dbus gui network qtestlib_build sql xml \
diff --git a/databases/akonadi/Makefile b/databases/akonadi/Makefile
index eff73aebe307..6c46752317e6 100644
--- a/databases/akonadi/Makefile
+++ b/databases/akonadi/Makefile
@@ -15,7 +15,7 @@ BUILD_DEPENDS= xsltproc:textproc/libxslt
CONFLICTS= akonadi-[0-9]* akonadi-kf5-git-[0-9]*
-USES= cmake:outsource compiler:c++11-lib gettext kde:5 \
+USES= cmake compiler:c++11-lib gettext kde:5 \
qt:5 shared-mime-info tar:xz
USE_GNOME= libxml2
USE_KDE= auth codecs completion config configwidgets coreaddons crash \
diff --git a/databases/arangodb32/Makefile b/databases/arangodb32/Makefile
index 39fd410d3278..39da67092ca8 100644
--- a/databases/arangodb32/Makefile
+++ b/databases/arangodb32/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
ONLY_FOR_ARCHS= amd64
ONLY_FOR_ARCHS_REASON= "Only builds on amd64"
-USES= gmake ssl cmake:outsource,noninja python:2.7 compiler
+USES= gmake ssl cmake:noninja python:2.7 compiler
USE_GITHUB= yes
CMAKE_ARGS= -DUSE_JEMALLOC:BOOL=off \
diff --git a/databases/arangodb33/Makefile b/databases/arangodb33/Makefile
index 5dc0e6923efe..f15df379daa2 100644
--- a/databases/arangodb33/Makefile
+++ b/databases/arangodb33/Makefile
@@ -19,7 +19,7 @@ ONLY_FOR_ARCHS_REASON= "Only builds on amd64: https://github.com/arangodb/arango
CONFLICTS_INSTALL= arangodb32
CONFLICTS_BUILD= v8
-USES= cmake:outsource,noninja compiler gmake python:2.7 ssl # ninja: error: loading 'build.ninja': No such file or directory
+USES= cmake:noninja compiler gmake python:2.7 ssl # ninja: error: loading 'build.ninja': No such file or directory
USE_GITHUB= yes
CMAKE_OFF= USE_JEMALLOC
diff --git a/databases/cassandra-cpp-driver/Makefile b/databases/cassandra-cpp-driver/Makefile
index 6c94989fa436..c8efb184653a 100644
--- a/databases/cassandra-cpp-driver/Makefile
+++ b/databases/cassandra-cpp-driver/Makefile
@@ -13,13 +13,15 @@ LICENSE= APACHE20
LIB_DEPENDS= libuv.so:devel/libuv
-USES= cmake:outsource compiler:c++11-lang pkgconfig pathfix ssl
+USES= cmake compiler:c++11-lang pkgconfig pathfix ssl
USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= datastax
GH_PROJECT= cpp-driver
-CMAKE_ARGS= -DCMAKE_INSTALL_LIBDIR:STRING=lib -DCASS_BUILD_STATIC:BOOL=ON
+USES= cmake pkgconfig pathfix ssl
+CMAKE_ARGS= -DCMAKE_INSTALL_LIBDIR:STRING=lib \
+ -DCASS_BUILD_STATIC:BOOL=ON
PLIST_FILES= include/cassandra.h \
lib/libcassandra.so \
diff --git a/databases/clickhouse/Makefile b/databases/clickhouse/Makefile
index c174d098d4bd..9934ff75c245 100644
--- a/databases/clickhouse/Makefile
+++ b/databases/clickhouse/Makefile
@@ -35,7 +35,7 @@ LIB_DEPENDS= libtcmalloc.so:devel/google-perftools \
libcpuid.so:sysutils/libcpuid \
libgtest.so:devel/googletest
-USES= compiler:c++14-lang cmake iconv mysql ssl readline shebangfix
+USES= compiler:c++14-lang cmake:insource iconv mysql ssl readline shebangfix
USE_LDCONFIG= yes
CMAKE_ARGS= -DUNBUNDLED=1 \
diff --git a/databases/cppdb/Makefile b/databases/cppdb/Makefile
index 0a6abbf4a660..e1738511bc80 100644
--- a/databases/cppdb/Makefile
+++ b/databases/cppdb/Makefile
@@ -41,7 +41,7 @@ SQLITE3_INTERNAL_DESC= Link SQLite 3 backend into CppDB
SQLITE3_MODULE_DESC= Build SQLite 3 backend as a CppDB module
USE_LDCONFIG= yes
-USES= cmake:outsource tar:bzip2
+USES= cmake tar:bzip2
.include <bsd.port.options.mk>
diff --git a/databases/iowow/Makefile b/databases/iowow/Makefile
index a056b5682422..d9da8003227d 100644
--- a/databases/iowow/Makefile
+++ b/databases/iowow/Makefile
@@ -12,7 +12,7 @@ COMMENT= Persistent key-value database engine
LICENSE= MIT
-USES= cmake:outsource compiler:c11
+USES= cmake compiler:c11
USE_GITHUB= yes
GH_ACCOUNT= Softmotions
USE_LDCONFIG= yes
diff --git a/databases/kdb/Makefile b/databases/kdb/Makefile
index 8184e5803320..1ad6f545ba5f 100644
--- a/databases/kdb/Makefile
+++ b/databases/kdb/Makefile
@@ -12,7 +12,7 @@ COMMENT= Database connectivity and creation framework
LIB_DEPENDS= libicuuc.so:devel/icu
-USES= cmake:outsource compiler:c++11-lang gettext kde:5 \
+USES= cmake compiler:c++11-lang gettext kde:5 \
python:2.7 qt:5 tar:xz
USE_KDE= coreaddons ecm i18n
USE_QT= core gui network widgets xml \
diff --git a/databases/kexi/Makefile b/databases/kexi/Makefile
index 588ff27f2555..51412ce3e593 100644
--- a/databases/kexi/Makefile
+++ b/databases/kexi/Makefile
@@ -14,7 +14,7 @@ LIB_DEPENDS= libKDb3.so:databases/kdb \
libKPropertyCore3.so:x11-toolkits/kproperty \
libKReport3.so:textproc/kreport
-USES= cmake:outsource desktop-file-utils gettext iconv \
+USES= cmake desktop-file-utils gettext iconv \
kde:5 pkgconfig qt:5 tar:xz
USE_GNOME= glib20
USE_KDE= auth bookmarks codecs completion config \
diff --git a/databases/mariadb-connector-c/Makefile b/databases/mariadb-connector-c/Makefile
index 639c475d31e7..03bba229a543 100644
--- a/databases/mariadb-connector-c/Makefile
+++ b/databases/mariadb-connector-c/Makefile
@@ -27,7 +27,7 @@ CONFLICTS_INSTALL= mariadb[0-9]*-client-* \
mysql[0-9]*-client-* \
percona[0-9]*-client-*
-USES= cmake compiler:c++11-lib iconv:translit ssl
+USES= cmake:insource compiler:c++11-lib iconv:translit ssl
USE_LDCONFIG= ${PREFIX}/lib/mariadb
SITESDIR= mariadb/connector-c-${PORTVERSION}
DOCSDIR= ${PREFIX}/share/doc/mysql
diff --git a/databases/mariadb-connector-odbc/Makefile b/databases/mariadb-connector-odbc/Makefile
index 7a79129a9ade..d12519c117f9 100644
--- a/databases/mariadb-connector-odbc/Makefile
+++ b/databases/mariadb-connector-odbc/Makefile
@@ -23,7 +23,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libodbc.so:databases/unixODBC \
libmariadb.so:databases/mariadb-connector-c
-USES= cmake
+USES= cmake:insource
USE_LDCONFIG= ${PREFIX}/lib/mariadbconnector-odbc
SITESDIR= ${PORTNAME}/${PKGNAMESUFFIX:S/^-//}-${PORTVERSION:S/.b$//}
DOCSDIR= ${PREFIX}/share/doc/mysql
diff --git a/databases/mariadb100-server/Makefile b/databases/mariadb100-server/Makefile
index f814ee4deb6d..2c1e004b78a9 100644
--- a/databases/mariadb100-server/Makefile
+++ b/databases/mariadb100-server/Makefile
@@ -31,7 +31,7 @@ BROKEN_SSL_REASON_openssl111= Does not support OpenSSL 1.1, use MariaDB 10.2 or
SUB_FILES= pkg-message
SLAVEDIRS= databases/mariadb100-client
-USES= bison:build cmake:noninja compiler:c++11-lib cpe \
+USES= bison:build cmake:insource,noninja compiler:c++11-lib cpe \
ncurses shebangfix ssl
USE_LDCONFIG= ${PREFIX}/lib/mysql ${PREFIX}/lib/mysql/plugin
SHEBANG_FILES= scripts/*.sh
diff --git a/databases/mariadb101-server/Makefile b/databases/mariadb101-server/Makefile
index 874a72260269..600298b8d373 100644
--- a/databases/mariadb101-server/Makefile
+++ b/databases/mariadb101-server/Makefile
@@ -28,7 +28,7 @@ BROKEN_SSL_REASON_openssl111= Does not support OpenSSL 1.1, use MariaDB 10.2 or
SUB_FILES= pkg-message
SLAVEDIRS= databases/mariadb101-client
-USES= bison:build cmake:noninja compiler:c++11-lib cpe libedit ncurses \
+USES= bison:build cmake:insource,noninja compiler:c++11-lib cpe libedit ncurses \
shebangfix ssl
USE_LDCONFIG= ${PREFIX}/lib/mysql
SHEBANG_FILES= scripts/*.sh
diff --git a/databases/mariadb102-server/Makefile b/databases/mariadb102-server/Makefile
index 57a0540f9480..ccb2d701b1e7 100644
--- a/databases/mariadb102-server/Makefile
+++ b/databases/mariadb102-server/Makefile
@@ -25,7 +25,7 @@ LICENSE_PERMS_PerconaFT= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
SUB_FILES= pkg-message
SLAVEDIRS= databases/mariadb102-client
-USES= bison:build cmake:noninja compiler:c++11-lib cpe iconv:translit libedit ncurses shebangfix ssl
+USES= bison:build cmake:insource,noninja compiler:c++11-lib cpe iconv:translit libedit ncurses shebangfix ssl
USE_LDCONFIG= ${PREFIX}/lib/mysql
SHEBANG_FILES= scripts/*.sh storage/rocksdb/myrocks_hotbackup
SITESDIR= mariadb/mariadb-${PORTVERSION}/source
diff --git a/databases/mariadb103-server/Makefile b/databases/mariadb103-server/Makefile
index ff9c2d708a3f..c9bfbb0cfea0 100644
--- a/databases/mariadb103-server/Makefile
+++ b/databases/mariadb103-server/Makefile
@@ -27,7 +27,7 @@ SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
SLAVEDIRS= databases/mariadb102-client
-USES= bison:build cmake:noninja compiler:c++11-lib cpe iconv:translit libedit ncurses shebangfix ssl
+USES= bison:build cmake:insource,noninja compiler:c++11-lib cpe iconv:translit libedit ncurses shebangfix ssl
USE_LDCONFIG= ${PREFIX}/lib/mysql
SHEBANG_FILES= scripts/*.sh storage/rocksdb/myrocks_hotbackup
SITESDIR= mariadb/mariadb-${PORTVERSION}/source
diff --git a/databases/mariadb55-server/Makefile b/databases/mariadb55-server/Makefile
index 4040b7edf4a2..4f9a17d749b4 100644
--- a/databases/mariadb55-server/Makefile
+++ b/databases/mariadb55-server/Makefile
@@ -23,7 +23,7 @@ LICENSE= GPLv2
SUB_FILES= pkg-message
SLAVEDIRS= databases/mariadb55-client
-USES+= cmake:noninja shebangfix ssl
+USES+= cmake:insource,noninja shebangfix ssl
USE_LDCONFIG= ${PREFIX}/lib/mysql
SHEBANG_FILES= scripts/*.sh sql-bench/[a-km-z]*
diff --git a/databases/mydumper/Makefile b/databases/mydumper/Makefile
index da6d951893c7..7702bfb24323 100644
--- a/databases/mydumper/Makefile
+++ b/databases/mydumper/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= libpcre.so:devel/pcre
CMAKE_OFF= BUILD_DOCS WITH_BINLOG
USE_GNOME= glib20
-USES= cmake gnome mysql pkgconfig
+USES= cmake:insource gnome mysql pkgconfig
PLIST_FILES= sbin/mydumper sbin/myloader
diff --git a/databases/mysql-connector-c++/Makefile b/databases/mysql-connector-c++/Makefile
index be23c0179789..c35557727230 100644
--- a/databases/mysql-connector-c++/Makefile
+++ b/databases/mysql-connector-c++/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libboost_regex.so:devel/boost-libs
-USES= cmake:outsource compiler:c++11-lang mysql ssl
+USES= cmake compiler:c++11-lang mysql ssl
USE_LDCONFIG= yes
CMAKE_ARGS= -DDOC_DESTINATION="${DOCSDIR}" -DCMAKE_ENABLE_C++11=ON
diff --git a/databases/mysql-connector-c/Makefile b/databases/mysql-connector-c/Makefile
index 1ebcfa4eded7..87f41b850b39 100644
--- a/databases/mysql-connector-c/Makefile
+++ b/databases/mysql-connector-c/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_SSL= openssl111
BROKEN_SSL_REASON_openssl111= variable has incomplete type 'EVP_CIPHER_CTX' (aka 'evp_cipher_ctx_st')
-USES= cmake:outsource compiler:features mysql ssl
+USES= cmake compiler:features mysql ssl
CMAKE_ARGS+= -DOPENSSL_INCLUDE_DIR="${OPENSSLINC}"
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
diff --git a/databases/mysql55-server/Makefile b/databases/mysql55-server/Makefile
index 3c6fa424f32e..5424e4838425 100644
--- a/databases/mysql55-server/Makefile
+++ b/databases/mysql55-server/Makefile
@@ -14,7 +14,7 @@ COMMENT?= Multithreaded SQL database (server)
LICENSE= GPLv2
SLAVEDIRS= databases/mysql55-client
-USES= cmake:noninja readline shebangfix
+USES= cmake:insource,noninja readline shebangfix
CXXFLAGS+= ${CPPFLAGS}
NO_OPTIONS_SORT=yes
diff --git a/databases/mysql56-server/Makefile b/databases/mysql56-server/Makefile
index 9e17f35e6e49..6bd4189a4ad8 100644
--- a/databases/mysql56-server/Makefile
+++ b/databases/mysql56-server/Makefile
@@ -14,7 +14,7 @@ COMMENT?= Multithreaded SQL database (server)
LICENSE= GPLv2
SLAVEDIRS= databases/mysql56-client
-USES= bison:build cmake:outsource,noninja compiler:c11 compiler:c++11-lib \
+USES= bison:build cmake:noninja compiler:c11 compiler:c++11-lib \
cpe libedit localbase perl5 shebangfix ssl
USE_PERL5= run
diff --git a/databases/mysql57-server/Makefile b/databases/mysql57-server/Makefile
index e2c28806b1f5..c460abb18d81 100644
--- a/databases/mysql57-server/Makefile
+++ b/databases/mysql57-server/Makefile
@@ -17,7 +17,7 @@ LICENSE= GPLv2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
SLAVEDIRS= databases/mysql57-client
-USES= bison:build cmake:outsource,noninja compiler:c11 compiler:c++11-lib \
+USES= bison:build cmake:noninja compiler:c11 compiler:c++11-lib \
cpe libedit localbase perl5 shebangfix ssl
USE_PERL5= run
diff --git a/databases/mysql80-server/Makefile b/databases/mysql80-server/Makefile
index 35e3ea9e6cf1..de3cd36c81ef 100644
--- a/databases/mysql80-server/Makefile
+++ b/databases/mysql80-server/Makefile
@@ -17,7 +17,7 @@ LICENSE= GPLv2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}${DISTVERSIONSUFFIX}
SLAVEDIRS= databases/mysql80-client
-USES= bison:build cmake:outsource,noninja compiler:c++14-lang \
+USES= bison:build cmake:noninja compiler:c++14-lang \
compiler:c++14-lib cpe libedit localbase perl5 shebangfix ssl
USE_PERL5= run
diff --git a/databases/mysqlwsrep56-server/Makefile b/databases/mysqlwsrep56-server/Makefile
index 97178d8a1908..e9d2ccb93f48 100644
--- a/databases/mysqlwsrep56-server/Makefile
+++ b/databases/mysqlwsrep56-server/Makefile
@@ -30,7 +30,7 @@ DATADIR= ${PREFIX}/share/mysql
ETCDIR= ${PREFIX}/etc/mysql
USES= bison \
- cmake:outsource,noninja \
+ cmake:noninja \
compiler:c++11-lib \
compiler:c11 \
libedit \
diff --git a/databases/mysqlwsrep57-server/Makefile b/databases/mysqlwsrep57-server/Makefile
index e6055b0a9ea0..7217b6ab6b48 100644
--- a/databases/mysqlwsrep57-server/Makefile
+++ b/databases/mysqlwsrep57-server/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS= bash:shells/bash \
LIB_DEPENDS= libevent.so:devel/libevent liblz4.so:archivers/liblz4
USES= bison \
- cmake:outsource,noninja \
+ cmake:noninja \
compiler:c++11-lib \
compiler:c11 \
libedit \
diff --git a/databases/opendbviewer/Makefile b/databases/opendbviewer/Makefile
index ca520924ba6d..4930d610e0b0 100644
--- a/databases/opendbviewer/Makefile
+++ b/databases/opendbviewer/Makefile
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= convert:graphics/ImageMagick6
-USES= cmake:outsource compiler:c++11-lang qt:5
+USES= cmake compiler:c++11-lang qt:5
USE_GITHUB= yes
GH_ACCOUNT= Jet1oeil
USE_QT= core gui network sql sql-sqlite3 testlib widgets \
diff --git a/databases/percona55-server/Makefile b/databases/percona55-server/Makefile
index 346ae5e76222..987cf16aadf9 100644
--- a/databases/percona55-server/Makefile
+++ b/databases/percona55-server/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
SLAVEDIRS= databases/percona55-client
-USES= bison cmake:noninja readline shebangfix
+USES= bison cmake:insource,noninja readline shebangfix
USE_CXXSTD= gnu++98
CXXFLAGS+= ${CPPFLAGS}
diff --git a/databases/percona56-server/Makefile b/databases/percona56-server/Makefile
index c3b8fc82e35f..ddf254632e83 100644
--- a/databases/percona56-server/Makefile
+++ b/databases/percona56-server/Makefile
@@ -19,7 +19,7 @@ BROKEN_armv7= fails to compile: sql/mysqld.cc:198:19: error: cannot combine wit
SLAVEDIRS= databases/percona56-client \
databases/percona-pam-for-mysql
-USES= bison compiler:c++11-lang cmake:noninja perl5 shebangfix
+USES= bison compiler:c++11-lang cmake:insource,noninja perl5 shebangfix
OPTIONS_DEFINE= OPENSSL FASTMTX INNODBMEMCACHED TOKUDB
OPTIONS_DEFAULT= OPENSSL INNODBMEMCACHED
diff --git a/databases/percona57-server/Makefile b/databases/percona57-server/Makefile
index b0c2d6127c23..e7cf8d6a986b 100644
--- a/databases/percona57-server/Makefile
+++ b/databases/percona57-server/Makefile
@@ -24,7 +24,7 @@ BROKEN_powerpc64= Does not build
SLAVEDIRS= databases/percona57-client \
databases/percona57-pam-for-mysql
-USES= bison:build cmake:noninja compiler:c11 compiler:c++11-lib \
+USES= bison:build cmake:insource,noninja compiler:c11 compiler:c++11-lib \
cpe libedit localbase perl5 shebangfix
MY_DBDIR= /var/db/mysql
diff --git a/databases/pgagent/Makefile b/databases/pgagent/Makefile
index 43631161950b..e46bae106d6f 100644
--- a/databases/pgagent/Makefile
+++ b/databases/pgagent/Makefile
@@ -11,7 +11,7 @@ DISTNAME= pgAgent-${PORTVERSION}-Source
MAINTAINER= fjoe@FreeBSD.org
COMMENT= Job scheduler for PostgreSQL
-USES= cmake dos2unix pgsql
+USES= cmake:insource dos2unix pgsql
DOS2UNIX_GLOB= *.txt
CMAKE_ARGS= -DSTATIC_BUILD:BOOL=NO -DWX_CONFIG_PATH:FILEPATH="${WX_CONFIG}"
USE_WX= 2.8
diff --git a/databases/pgrouting/Makefile b/databases/pgrouting/Makefile
index e0f319c97dca..c7661568011c 100644
--- a/databases/pgrouting/Makefile
+++ b/databases/pgrouting/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libboost_system.so:devel/boost-libs\
libgmp.so:math/gmp
RUN_DEPENDS= ${LOCALBASE}/share/postgresql/contrib/postgis-2.2/postgis.sql:databases/postgis22
-USES= compiler:c++11-lib cmake:outsource localbase pgsql:9.1+ pkgconfig
+USES= compiler:c++11-lib cmake localbase pgsql:9.1+ pkgconfig
USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= pgRouting
diff --git a/databases/timescaledb/Makefile b/databases/timescaledb/Makefile
index 9d5a45328449..4ef2c5955fe3 100644
--- a/databases/timescaledb/Makefile
+++ b/databases/timescaledb/Makefile
@@ -11,7 +11,7 @@ COMMENT= Time-series database built on PostgreSQL
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE-APACHE
-USES= compiler:c11 cmake:outsource pgsql:9.6,10,11 ssl
+USES= compiler:c11 cmake pgsql:9.6,10,11 ssl
USE_GITHUB= YES
GH_ACCOUNT= timescale
diff --git a/databases/xrootd/Makefile b/databases/xrootd/Makefile
index d0e28813ee43..14b3cfab61e3 100644
--- a/databases/xrootd/Makefile
+++ b/databases/xrootd/Makefile
@@ -20,7 +20,7 @@ LICENSE_FILE_LGPL3= ${WRKSRC}/COPYING.LGPL
BUILD_DEPENDS= bash:shells/bash
LIB_DEPENDS= librados.so:net/ceph
-USES= cmake:outsource gnome localbase:ldflags pkgconfig readline shebangfix ssl
+USES= cmake gnome localbase:ldflags pkgconfig readline shebangfix ssl
SHEBANG_GLOB= *.sh
USE_GNOME= libxml2
USE_LDCONFIG= yes