aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
Diffstat (limited to 'databases')
-rw-r--r--databases/mtop/Makefile3
-rw-r--r--databases/p5-Class-DBI-Plugin-DeepAbstractSearch/Makefile9
-rw-r--r--databases/p5-DBIx-Class-EncodeColumns/Makefile9
-rw-r--r--databases/p5-DBIx-Class-InflateColumn-FS/Makefile8
-rw-r--r--databases/p5-DBIx-Sequence/Makefile3
-rw-r--r--databases/p5-DBIx-Skinny/Makefile8
-rw-r--r--databases/p5-SQL-Abstract-More/Makefile3
-rw-r--r--databases/percona-toolkit/Makefile3
-rw-r--r--databases/postgresql_autodoc/Makefile2
9 files changed, 19 insertions, 29 deletions
diff --git a/databases/mtop/Makefile b/databases/mtop/Makefile
index 5e5f71452857..6e6fce419760 100644
--- a/databases/mtop/Makefile
+++ b/databases/mtop/Makefile
@@ -14,7 +14,8 @@ RUN_DEPENDS= p5-Curses>=0:${PORTSDIR}/devel/p5-Curses \
p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql \
p5-Net>=0:${PORTSDIR}/net/p5-Net
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= mkill.1 mtop.1
diff --git a/databases/p5-Class-DBI-Plugin-DeepAbstractSearch/Makefile b/databases/p5-Class-DBI-Plugin-DeepAbstractSearch/Makefile
index 5d622f70d717..46d039d5cfa5 100644
--- a/databases/p5-Class-DBI-Plugin-DeepAbstractSearch/Makefile
+++ b/databases/p5-Class-DBI-Plugin-DeepAbstractSearch/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Class-DBI-Plugin-DeepAbstractSearch
-# Date created: 2011-02-15
-# Whom: milki <milki@rescomp.berkeley.edy>
-#
+# Created by: milki <milki@rescomp.berkeley.edy>
# $FreeBSD$
-#
PORTNAME= Class-DBI-Plugin-DeepAbstractSearch
PORTVERSION= 0.08
@@ -25,7 +21,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Class::DBI::Plugin::DeepAbstractSearch.3
.include <bsd.port.mk>
diff --git a/databases/p5-DBIx-Class-EncodeColumns/Makefile b/databases/p5-DBIx-Class-EncodeColumns/Makefile
index b513d47ea43f..d0127fffad3c 100644
--- a/databases/p5-DBIx-Class-EncodeColumns/Makefile
+++ b/databases/p5-DBIx-Class-EncodeColumns/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: DBIx-Class-EncodeColumns
-# Date created: 24 May 2008
-# Whom: Vladimir Timofeev <vovkasm@gmail.com>
-#
+# Created by: Vladimir Timofeev <vovkasm@gmail.com>
# $FreeBSD$
-#
PORTNAME= DBIx-Class-EncodeColumns
PORTVERSION= 0.02
@@ -17,7 +13,8 @@ COMMENT= Handle column encodings
RUN_DEPENDS= p5-DBIx-Class>=0.06002:${PORTSDIR}/databases/p5-DBIx-Class
BUILD_DEPENDS= p5-DBIx-Class>=0.06002:${PORTSDIR}/databases/p5-DBIx-Class
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= DBIx::Class::EncodeColumns.3
diff --git a/databases/p5-DBIx-Class-InflateColumn-FS/Makefile b/databases/p5-DBIx-Class-InflateColumn-FS/Makefile
index 3b26f82f2c78..80d1c793c9a7 100644
--- a/databases/p5-DBIx-Class-InflateColumn-FS/Makefile
+++ b/databases/p5-DBIx-Class-InflateColumn-FS/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: DBIx::Class::InflateColumn::FS
-# Date created: 18 Mar 2011
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= DBIx-Class-InflateColumn-FS
PORTVERSION= 0.01007
@@ -21,7 +16,8 @@ RUN_DEPENDS= \
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-DBICx-TestDatabase>=0:${PORTSDIR}/databases/p5-DBICx-TestDatabase
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DBIx::Class::InflateColumn::FS.3 \
DBIx::Class::InflateColumn::FS::ResultSet.3
diff --git a/databases/p5-DBIx-Sequence/Makefile b/databases/p5-DBIx-Sequence/Makefile
index a08d4f930f28..f9f7ce904e43 100644
--- a/databases/p5-DBIx-Sequence/Makefile
+++ b/databases/p5-DBIx-Sequence/Makefile
@@ -13,7 +13,8 @@ COMMENT= DBIx::Sequence - A simple SQL92 ID generator
BUILD_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DBIx::Sequence.3
diff --git a/databases/p5-DBIx-Skinny/Makefile b/databases/p5-DBIx-Skinny/Makefile
index ec419f4a4d7a..a002b2e1b64b 100644
--- a/databases/p5-DBIx-Skinny/Makefile
+++ b/databases/p5-DBIx-Skinny/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: DBIx::Skinny
-# Date created: 19 Nov 2010
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= DBIx-Skinny
PORTVERSION= 0.0742
@@ -24,7 +19,8 @@ RUN_DEPENDS= \
p5-Class-Load>0:${PORTSDIR}/devel/p5-Class-Load
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DBIx::Skinny.3 \
DBIx::Skinny::Iterator.3 \
diff --git a/databases/p5-SQL-Abstract-More/Makefile b/databases/p5-SQL-Abstract-More/Makefile
index eaf8ff210db5..66a32b1028a6 100644
--- a/databases/p5-SQL-Abstract-More/Makefile
+++ b/databases/p5-SQL-Abstract-More/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-MRO-Compat>0:${PORTSDIR}/devel/p5-MRO-Compat \
p5-SQL-Abstract>=1.73:${PORTSDIR}/databases/p5-SQL-Abstract
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= SQL::Abstract::More.3
diff --git a/databases/percona-toolkit/Makefile b/databases/percona-toolkit/Makefile
index f9ac9c3ef67a..cd539615fcbb 100644
--- a/databases/percona-toolkit/Makefile
+++ b/databases/percona-toolkit/Makefile
@@ -13,7 +13,8 @@ RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
p5-DBI>=1.46:${PORTSDIR}/databases/p5-DBI \
p5-Term-ReadKey>=2.10:${PORTSDIR}/devel/p5-Term-ReadKey
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= percona-toolkit.1 \
pt-agent.1 \
diff --git a/databases/postgresql_autodoc/Makefile b/databases/postgresql_autodoc/Makefile
index a0b01ba25fdd..dba704ce1701 100644
--- a/databases/postgresql_autodoc/Makefile
+++ b/databases/postgresql_autodoc/Makefile
@@ -14,7 +14,7 @@ BUILD_DEPENDS= p5-HTML-Template>=0:${PORTSDIR}/www/p5-HTML-Template \
p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg
USE_GMAKE= yes
-USE_PERL5= yes
+USES= perl5
CONFIGURE_ARGS+=--datadir=${DATADIR}
MAN1= postgresql_autodoc.1