aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/pgpool-II-37/Makefile46
-rw-r--r--databases/pgpool-II-37/distinfo3
-rw-r--r--databases/pgpool-II-37/files/patch-src_auth_pool__hba.c11
-rw-r--r--databases/pgpool-II-37/files/pgpool.in40
-rw-r--r--databases/pgpool-II-37/pkg-descr8
-rw-r--r--databases/pgpool-II-37/pkg-message9
-rw-r--r--databases/pgpool-II-37/pkg-plist33
8 files changed, 151 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index c42410821098..2ea33a0449ec 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -600,6 +600,7 @@
SUBDIR += pgpool-II-33
SUBDIR += pgpool-II-35
SUBDIR += pgpool-II-36
+ SUBDIR += pgpool-II-37
SUBDIR += pgreplay
SUBDIR += pgroonga
SUBDIR += pgrouting
diff --git a/databases/pgpool-II-37/Makefile b/databases/pgpool-II-37/Makefile
new file mode 100644
index 000000000000..3efa0abdb32d
--- /dev/null
+++ b/databases/pgpool-II-37/Makefile
@@ -0,0 +1,46 @@
+# $FreeBSD$
+
+PORTNAME= pgpool-II
+PORTVERSION= 3.7.3
+CATEGORIES= databases
+MASTER_SITES= http://www.pgpool.net/mediawiki/images/
+PKGNAMESUFFIX= 37
+
+MAINTAINER= tz@FreeBSD.org
+COMMENT= Connection pool server for PostgreSQL
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BROKEN_SSL= openssl-devel
+BROKEN_SSL_REASON_openssl-devel= library 'ssl' is required for OpenSSL
+
+PORTSCOUT= limit:^3.7.[0-9]*
+
+USES= gmake libtool pgsql:9.6+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+USE_RC_SUBR= pgpool
+CONFLICTS= pgpool-II-[0-9]*
+
+PORTDOCS= *
+
+OPTIONS_DEFINE= DOCS SSL
+OPTIONS_DEFAULT= SSL
+
+SSL_CONFIGURE_WITH= openssl
+SSL_USES= ssl
+
+post-install:
+ @${MKDIR} ${STAGEDIR}/var/run/pgpool
+ ${INSTALL_LIB} ${WRKSRC}/src/libs/pcp/.libs/libpcp.so.1.0.0 ${STAGEDIR}${PREFIX}/lib
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} doc ${STAGEDIR}${DOCSDIR} "-not -name Makefile.\*"
+.for f in AUTHORS ChangeLog NEWS TODO
+ ${INSTALL_DATA} ${WRKSRC}/$f ${STAGEDIR}${DOCSDIR}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/databases/pgpool-II-37/distinfo b/databases/pgpool-II-37/distinfo
new file mode 100644
index 000000000000..3a0503bd320b
--- /dev/null
+++ b/databases/pgpool-II-37/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1524047260
+SHA256 (pgpool-II-3.7.3.tar.gz) = a58fce7cb9b3198d1dc18b40e47066d30049e8059e8ce67a568d5b1e0b6b91e7
+SIZE (pgpool-II-3.7.3.tar.gz) = 3259752
diff --git a/databases/pgpool-II-37/files/patch-src_auth_pool__hba.c b/databases/pgpool-II-37/files/patch-src_auth_pool__hba.c
new file mode 100644
index 000000000000..99d35e0be35f
--- /dev/null
+++ b/databases/pgpool-II-37/files/patch-src_auth_pool__hba.c
@@ -0,0 +1,11 @@
+--- src/auth/pool_hba.c.orig 2018-04-11 05:37:54 UTC
++++ src/auth/pool_hba.c
+@@ -29,6 +29,8 @@
+ #include <string.h>
+ #include <errno.h>
+ #include <netdb.h>
++#include <arpa/inet.h>
++#include <netinet/in.h>
+
+ #include "pool.h"
+ #include "auth/pool_hba.h"
diff --git a/databases/pgpool-II-37/files/pgpool.in b/databases/pgpool-II-37/files/pgpool.in
new file mode 100644
index 000000000000..729fdaa23d9a
--- /dev/null
+++ b/databases/pgpool-II-37/files/pgpool.in
@@ -0,0 +1,40 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: pgpool
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# pgpool_enable (bool): Set to NO by default.
+# Set it to YES to enable pgpool.
+# pgpool_conf (file): Set location of your config.
+# Default is "%%PREFIX%%/etc/pgpool.conf"
+# pgpool_user (uid): User ID to run as (default nobody)
+# pgpool_stop_mode (string): Shutdown mode
+# Default is "smart"
+# Possibilities are "smart", "fast", or "immediate"
+#
+
+. /etc/rc.subr
+
+name=pgpool
+rcvar=pgpool_enable
+
+load_rc_config $name
+
+: ${pgpool_enable="NO"}
+: ${pgpool_conf="%%PREFIX%%/etc/pgpool.conf"}
+: ${pgpool_user="nobody"}
+: ${pgpool_stop_mode="smart"}
+
+command="%%PREFIX%%/bin/pgpool"
+command_args="-f ${pgpool_conf}"
+stop_cmd="${command} -m ${pgpool_stop_mode} ${command_args} stop"
+
+required_files="${pgpool_conf}"
+
+run_rc_command "$1"
diff --git a/databases/pgpool-II-37/pkg-descr b/databases/pgpool-II-37/pkg-descr
new file mode 100644
index 000000000000..6aa062adf911
--- /dev/null
+++ b/databases/pgpool-II-37/pkg-descr
@@ -0,0 +1,8 @@
+pgpool is a connection pool server for PostgreSQL. pgpool runs between
+PostgreSQL's clients(front ends) and servers(back ends). A PostgreSQL client can
+connect to pgpool as if it were a standard PostgreSQL server.
+
+pgpool caches the connection to PostgreSQL server to reduce the overhead to
+establish the connection to it.
+
+WWW: http://pgpool.net/
diff --git a/databases/pgpool-II-37/pkg-message b/databases/pgpool-II-37/pkg-message
new file mode 100644
index 000000000000..b1a7385436a6
--- /dev/null
+++ b/databases/pgpool-II-37/pkg-message
@@ -0,0 +1,9 @@
+In order to start pgpool you need some more configuration:
+
+# sysrc -f /etc/rc.conf pgpool_enable="YES"
+# sysrc -f /etc/rc.conf pgpool_user="root"
+
+Please consider the usage of another user. The user is
+required to have read/write access to /var/run/pgpool.
+
+Using the root user is - as always - an security issue.
diff --git a/databases/pgpool-II-37/pkg-plist b/databases/pgpool-II-37/pkg-plist
new file mode 100644
index 000000000000..458bffbe8b06
--- /dev/null
+++ b/databases/pgpool-II-37/pkg-plist
@@ -0,0 +1,33 @@
+bin/pcp_attach_node
+bin/pcp_detach_node
+bin/pcp_node_count
+bin/pcp_node_info
+bin/pcp_pool_status
+bin/pcp_proc_count
+bin/pcp_proc_info
+bin/pcp_promote_node
+bin/pcp_recovery_node
+bin/pcp_stop_pgpool
+bin/pcp_watchdog_info
+bin/pg_md5
+bin/pgpool
+bin/pgpool_setup
+bin/watchdog_setup
+@sample etc/pcp.conf.sample
+@sample etc/pgpool.conf.sample
+etc/pgpool.conf.sample-logical
+etc/pgpool.conf.sample-master-slave
+etc/pgpool.conf.sample-replication
+etc/pgpool.conf.sample-stream
+@sample etc/pool_hba.conf.sample
+include/libpcp_ext.h
+include/pcp.h
+include/pool_process_reporting.h
+include/pool_type.h
+lib/libpcp.a
+lib/libpcp.so
+lib/libpcp.so.1
+lib/libpcp.so.1.0.0
+%%DATADIR%%/insert_lock.sql
+%%DATADIR%%/pgpool.pam
+@dir /var/run/pgpool