aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
Diffstat (limited to 'databases')
-rw-r--r--databases/galera/Makefile1
-rw-r--r--databases/libpbl/Makefile1
-rw-r--r--databases/percona-pam-for-mysql/Makefile1
-rw-r--r--databases/percona55-client/Makefile1
-rw-r--r--databases/rocksdb/Makefile1
-rw-r--r--databases/sqliteodbc-sqlite2/Makefile1
-rw-r--r--databases/tokyocabinet/Makefile1
-rw-r--r--databases/xapian-core10/Makefile1
-rw-r--r--databases/xtrabackup/Makefile1
9 files changed, 9 insertions, 0 deletions
diff --git a/databases/galera/Makefile b/databases/galera/Makefile
index dd07c1992140..4c7ffd1c69a8 100644
--- a/databases/galera/Makefile
+++ b/databases/galera/Makefile
@@ -17,6 +17,7 @@ LIB_DEPENDS= libboost_date_time.so:devel/boost-libs
BROKEN_aarch64= fails to compile: gu_int128.h: use of undeclared identifier '__bswap64_var'
BROKEN_armv6= fails to compile: gu_int128.h: use of undeclared identifier '__bswap64_var'
+BROKEN_armv7= fails to compile: gu_int128.h: use of undeclared identifier '__bswap64_var'
NOT_FOR_ARCHS= i386
# On i386 older versions of clang produce:
# cannot compile this atomic library call yet ... __atomic_add_fetch
diff --git a/databases/libpbl/Makefile b/databases/libpbl/Makefile
index c766017ed50a..78ea6a67c35a 100644
--- a/databases/libpbl/Makefile
+++ b/databases/libpbl/Makefile
@@ -16,6 +16,7 @@ MAKEFILE= makefile
TEST_TARGET= test
BROKEN_armv6= Fails to build: cannot compile pblPerform.c
+BROKEN_armv7= Fails to build: cannot compile pblPerform.c
BROKEN_mips= Fails to build: cannot compile pblPerform.c
WRKSRC= ${WRKDIR}/${DISTNAME}/src
diff --git a/databases/percona-pam-for-mysql/Makefile b/databases/percona-pam-for-mysql/Makefile
index 091df63cc1ce..bb037dc6c139 100644
--- a/databases/percona-pam-for-mysql/Makefile
+++ b/databases/percona-pam-for-mysql/Makefile
@@ -8,6 +8,7 @@ PKGNAMESUFFIX= -pam-for-mysql
COMMENT= PAM plugin for MySQL
BROKEN_armv6= fails to compile: cannot combine with previous 'type-name' declaration specifier
+BROKEN_armv7= fails to compile: cannot combine with previous 'type-name' declaration specifier
BROKEN_mips= fails to configure: CMake Error: Generator: execution of make failed
BROKEN_mips64= fails to configure: CMake Error: Generator: execution of make failed
NOT_FOR_ARCHS= powerpc64
diff --git a/databases/percona55-client/Makefile b/databases/percona55-client/Makefile
index 10fa900f7811..6b9481ebec0b 100644
--- a/databases/percona55-client/Makefile
+++ b/databases/percona55-client/Makefile
@@ -22,6 +22,7 @@ USE_LDCONFIG= ${PREFIX}/lib/mysql
BROKEN_aarch64= Fails to build: error: passing int to parameter of incompatible type va_list
BROKEN_armv6= Fails to build: error: passing int to parameter of incompatible type va_list
+BROKEN_armv7= Fails to build: error: passing int to parameter of incompatible type va_list
MANPAGES= comp_err.1 msql2mysql.1 mysql.1 mysql_config.1 mysql_find_rows.1 \
mysql_waitpid.1 mysqlaccess.1 mysqladmin.1 mysqlbinlog.1 \
diff --git a/databases/rocksdb/Makefile b/databases/rocksdb/Makefile
index e31e061b9ba9..fa6ca1323e41 100644
--- a/databases/rocksdb/Makefile
+++ b/databases/rocksdb/Makefile
@@ -17,6 +17,7 @@ LICENSE_FILE_GPLv2= ${WRKSRC}/COPYING
BROKEN_DragonFly= does not build on DragonFly BSD using GCC with -Werror
BROKEN_aarch64= does not build: the clang compiler does not support -march=native
BROKEN_armv6= does not build: the clang compiler does not support -march=native
+BROKEN_armv7= does not build: /nxb-bin/usr/bin/ld: undefined reference to symbol `__gnu_Unwind_Find_exidx@@FBSD_1.4' (try adding -lc)
BROKEN_powerpc64= does not build: the clang compiler does not support -march=native
BROKEN_sparc64= cannot build: uses unknown compiler flags
diff --git a/databases/sqliteodbc-sqlite2/Makefile b/databases/sqliteodbc-sqlite2/Makefile
index 17b4f9ee92e1..3d575c2d22b8 100644
--- a/databases/sqliteodbc-sqlite2/Makefile
+++ b/databases/sqliteodbc-sqlite2/Makefile
@@ -11,5 +11,6 @@ MASTERDIR= ${.CURDIR}/../sqliteodbc
BROKEN_aarch64= fails to compile: error: passing char * to parameter of incompatible type va_list
BROKEN_armv6= fails to compile: error: passing char * to parameter of incompatible type va_list
+BROKEN_armv7= fails to compile: error: passing char * to parameter of incompatible type va_list
.include "${MASTERDIR}/Makefile"
diff --git a/databases/tokyocabinet/Makefile b/databases/tokyocabinet/Makefile
index 42340c38c0f6..edc5aa0b1ca0 100644
--- a/databases/tokyocabinet/Makefile
+++ b/databases/tokyocabinet/Makefile
@@ -14,6 +14,7 @@ LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_armv6= dumps core: Assertion failed: (!NodePtr->isKnownSentinel()), function operator*, file ilist_iterator.h
+BROKEN_armv7= fails to build: cc: error: unable to execute command: Abort trap (core dumped)
GNU_CONFIGURE= yes
USES= pathfix gmake
diff --git a/databases/xapian-core10/Makefile b/databases/xapian-core10/Makefile
index 2832b63abc3d..906d2af029ae 100644
--- a/databases/xapian-core10/Makefile
+++ b/databases/xapian-core10/Makefile
@@ -14,6 +14,7 @@ COMMENT= Probabilistic text search database engine
LICENSE= GPLv2
BROKEN_armv6= fails to install: quartz_log.cc:: error: call to 'om_tostring' is ambiguous
+BROKEN_armv7= fails to install: quartz_log.cc:: error: call to 'om_tostring' is ambiguous
BROKEN_mips= fails to install: quartz_log.cc:: error: call to 'om_tostring' is ambiguous
BROKEN_mips64= fails to install: quartz_log.cc:: error: call to 'om_tostring' is ambiguous
diff --git a/databases/xtrabackup/Makefile b/databases/xtrabackup/Makefile
index e74790b1fdcf..032a9ae73c7d 100644
--- a/databases/xtrabackup/Makefile
+++ b/databases/xtrabackup/Makefile
@@ -25,6 +25,7 @@ RUN_DEPENDS= p5-DBD-mysql>=0:databases/p5-DBD-mysql \
qpress:archivers/qpress
BROKEN_armv6= fails to compile: cannot combine with previous 'type-name' declaration specifier
+BROKEN_armv7= fails to compile: cannot combine with previous 'type-name' declaration specifier
BROKEN_mips64= fails to compile: 'fpsetmask' was not declared in this scope
BROKEN_powerpc64= fails to link: ld: final link failed: Bad value