aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
Diffstat (limited to 'databases')
-rw-r--r--databases/p5-AnyEvent-Redis/Makefile9
-rw-r--r--databases/p5-AsciiDB-TagFile/Makefile9
-rw-r--r--databases/p5-Cache-Memcached-Fast/Makefile3
-rw-r--r--databases/p5-DBD-PgLite/Makefile9
-rw-r--r--databases/p5-DBIx-DataSource/Makefile9
-rw-r--r--databases/p5-DBIx-Perlish/Makefile9
-rw-r--r--databases/p5-Template-DBI/Makefile9
7 files changed, 20 insertions, 37 deletions
diff --git a/databases/p5-AnyEvent-Redis/Makefile b/databases/p5-AnyEvent-Redis/Makefile
index 0e9887ce9410..67ed8079a8d9 100644
--- a/databases/p5-AnyEvent-Redis/Makefile
+++ b/databases/p5-AnyEvent-Redis/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: databases/p5-AnyEvent-Redis
-# Date created: 25 January 2011
-# Whom: Anton Berezin <tobez@FreeBSD.org>
-#
+# Created by: Anton Berezin <tobez@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= AnyEvent-Redis
PORTVERSION= 0.24
@@ -22,7 +18,8 @@ TEST_DEPENDS= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple \
p5-Test-TCP>=1.03:${PORTSDIR}/devel/p5-Test-TCP \
redis>=0:${PORTSDIR}/databases/redis
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= AnyEvent::Redis.3 \
AnyEvent::Redis::Protocol.3
diff --git a/databases/p5-AsciiDB-TagFile/Makefile b/databases/p5-AsciiDB-TagFile/Makefile
index 216fd6f1eed0..6db5465c5e75 100644
--- a/databases/p5-AsciiDB-TagFile/Makefile
+++ b/databases/p5-AsciiDB-TagFile/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: databases/p5-AsciiDB-TagFile
-# Date created: 25 April 2001
-# Whom: Anton Berezin <tobez@tobez.org>
-#
+# Created by: Anton Berezin <tobez@tobez.org>
# $FreeBSD$
-#
PORTNAME= AsciiDB-TagFile
PORTVERSION= 1.06
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Perl tie class for a simple ASCII database
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= AsciiDB::TagFile.3
diff --git a/databases/p5-Cache-Memcached-Fast/Makefile b/databases/p5-Cache-Memcached-Fast/Makefile
index f87e40294562..90bb2e7c4ffa 100644
--- a/databases/p5-Cache-Memcached-Fast/Makefile
+++ b/databases/p5-Cache-Memcached-Fast/Makefile
@@ -11,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Fast Perl client for memcached, a distributed memory cache daemon
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAKE_JOBS_UNSAFE= yes
MAN3= Cache::Memcached::Fast.3
diff --git a/databases/p5-DBD-PgLite/Makefile b/databases/p5-DBD-PgLite/Makefile
index 7871ab3c0f41..6d1cebe25496 100644
--- a/databases/p5-DBD-PgLite/Makefile
+++ b/databases/p5-DBD-PgLite/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: databases/p5-DBD-PgLite
-# Date created: 03 November 2008
-# Whom: Lars Thegler <lth@FreeBSD.org>
-#
+# Created by: Lars Thegler <lth@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= DBD-PgLite
PORTVERSION= 0.11
@@ -20,7 +16,8 @@ RUN_DEPENDS= p5-DBD-SQLite>=1.0:${PORTSDIR}/databases/p5-DBD-SQLite \
p5-DBI>=1.30:${PORTSDIR}/databases/p5-DBI
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DBD::PgLite.3 \
DBD::PgLite::MirrorPgToSQLite.3
diff --git a/databases/p5-DBIx-DataSource/Makefile b/databases/p5-DBIx-DataSource/Makefile
index da3f8323d9ee..aaeb2c982e65 100644
--- a/databases/p5-DBIx-DataSource/Makefile
+++ b/databases/p5-DBIx-DataSource/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: databases/p5-DBIx-DataSource
-# Date created: 01 June 2001
-# Whom: Anton Berezin <tobez@tobez.org>
-#
+# Created by: Anton Berezin <tobez@tobez.org>
# $FreeBSD$
-#
PORTNAME= DBIx-DataSource
PORTVERSION= 0.02
@@ -17,7 +13,8 @@ COMMENT= Database-independent create and drop functions
BUILD_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DBIx::DataSource.3 DBIx::DataSource::Driver.3 \
DBIx::DataSource::mysql.3 DBIx::DataSource::Pg.3
diff --git a/databases/p5-DBIx-Perlish/Makefile b/databases/p5-DBIx-Perlish/Makefile
index 22f33fc6de4a..6a6817ec70df 100644
--- a/databases/p5-DBIx-Perlish/Makefile
+++ b/databases/p5-DBIx-Perlish/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: databases/p5-DBIx-Perlish
-# Date created: 22 February 2007
-# Whom: Anton Berezin <tobez@FreeBSD.org>
-#
+# Created by: Anton Berezin <tobez@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= DBIx-Perlish
PORTVERSION= 0.59
@@ -18,7 +14,8 @@ BUILD_DEPENDS= p5-DBI>0:${PORTSDIR}/databases/p5-DBI \
p5-PadWalker>0:${PORTSDIR}/devel/p5-PadWalker
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DBIx::Perlish.3
diff --git a/databases/p5-Template-DBI/Makefile b/databases/p5-Template-DBI/Makefile
index a0a2dd047725..52167e097613 100644
--- a/databases/p5-Template-DBI/Makefile
+++ b/databases/p5-Template-DBI/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: databases/p5-Template-DBI
-# Date created: 04 December 2006
-# Whom: Anton Berezin <tobez@FreeBSD.org>
-#
+# Created by: Anton Berezin <tobez@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Template-DBI
PORTVERSION= 2.65
@@ -20,7 +16,8 @@ BUILD_DEPENDS= p5-Template-Toolkit>=0:${PORTSDIR}/www/p5-Template-Toolkit \
p5-MLDBM>=0:${PORTSDIR}/databases/p5-MLDBM
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Template::DBI.3 \
Template::Plugin::DBI.3