aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
Diffstat (limited to 'databases')
-rw-r--r--databases/recutils/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/databases/recutils/Makefile b/databases/recutils/Makefile
index e3418f580a3e..706bc393bf51 100644
--- a/databases/recutils/Makefile
+++ b/databases/recutils/Makefile
@@ -11,7 +11,7 @@ COMMENT= Tools and libraries to access human-editable, plain text databases
LICENSE= GPLv3
-OPTIONS_DEFINE= NLS
+OPTIONS_DEFINE= NLS DOCS
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
@@ -19,6 +19,7 @@ USE_LDCONFIG= yes
INFO= ${PORTNAME}
MAN1= csv2rec.1 rec2csv.1 recdel.1 recfix.1 recfmt.1 recinf.1 \
recins.1 recsel.1 recset.1
+PORTDOCS= ChangeLog NEWS README
.include <bsd.port.options.mk>
@@ -30,4 +31,10 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+
.include <bsd.port.mk>