aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/postgresql-plpython/Makefile25
-rw-r--r--databases/postgresql-plpython/files/patch-plpython-Makefile11
-rw-r--r--databases/postgresql-plpython/pkg-descr6
-rw-r--r--databases/postgresql-plpython/pkg-plist2
5 files changed, 45 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 638debf64ea3..a86c314eca9e 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -252,6 +252,7 @@
SUBDIR += postgresql-libpq++
SUBDIR += postgresql-libpqxx
SUBDIR += postgresql-odbc
+ SUBDIR += postgresql-plpython
SUBDIR += postgresql-plruby
SUBDIR += postgresql-pltcl
SUBDIR += postgresql-relay
diff --git a/databases/postgresql-plpython/Makefile b/databases/postgresql-plpython/Makefile
new file mode 100644
index 000000000000..63a600a7ca54
--- /dev/null
+++ b/databases/postgresql-plpython/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: PostgreSQL PL/Python
+# Date created: March 4, 2004
+# Whom: Dima Dorfman <dd@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= databases python
+PKGNAMESUFFIX= -plpython
+
+MAINTAINER= dd@FreeBSD.org
+COMMENT= A module for using Python to write SQL functions
+
+POSTGRESQL_PORT?= databases/postgresql7
+POSTGRESQL_SUBPORT=YES
+.include "../../${POSTGRESQL_PORT}/Makefile"
+
+RUN_DEPENDS= postgres:${PORTSDIR}/${POSTGRESQL_PORT}
+
+USE_PYTHON= yes
+
+MAKE_ARGS+= -C src/pl/plpython
+CONFIGURE_ARGS= --with-python
+
+.include <bsd.port.mk>
diff --git a/databases/postgresql-plpython/files/patch-plpython-Makefile b/databases/postgresql-plpython/files/patch-plpython-Makefile
new file mode 100644
index 000000000000..a1303151170a
--- /dev/null
+++ b/databases/postgresql-plpython/files/patch-plpython-Makefile
@@ -0,0 +1,11 @@
+--- src/pl/plpython/Makefile~ Thu Mar 4 08:06:19 2004
++++ src/pl/plpython/Makefile Thu Mar 4 08:06:44 2004
+@@ -8,7 +8,7 @@
+ # On some platforms we can only build PL/Python if libpython is a
+ # shared library. Since there is no official way to determine this,
+ # we see if there is a file that is named like a shared library.
+-ifneq (,$(wildcard $(python_configdir)/libpython*$(DLSUFFIX)*))
++ifneq (,$(wildcard $(python_configdir)/../../libpython*$(DLSUFFIX)*))
+ shared_libpython = yes
+ endif
+
diff --git a/databases/postgresql-plpython/pkg-descr b/databases/postgresql-plpython/pkg-descr
new file mode 100644
index 000000000000..1e121bca492d
--- /dev/null
+++ b/databases/postgresql-plpython/pkg-descr
@@ -0,0 +1,6 @@
+PL/Python allows one to write PostgeSQL stored functions and
+procedures in Python (http://www.python.org/).
+
+This software is part of the standard PostgreSQL distribution.
+
+WWW: http://www.postgresql.org/
diff --git a/databases/postgresql-plpython/pkg-plist b/databases/postgresql-plpython/pkg-plist
new file mode 100644
index 000000000000..2e953a0a80d3
--- /dev/null
+++ b/databases/postgresql-plpython/pkg-plist
@@ -0,0 +1,2 @@
+lib/postgresql/plpython.so
+@unexec rmdir %D/lib/postgresql 2>/dev/null || true