aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
Diffstat (limited to 'databases')
-rw-r--r--databases/p5-ApacheDBILogConfig/Makefile6
-rw-r--r--databases/p5-ApacheDBILogger/Makefile6
-rw-r--r--databases/p5-BerkeleyDB/Makefile1
-rw-r--r--databases/p5-DBD-CSV/Makefile5
-rw-r--r--databases/p5-DBD-Pg-13/Makefile6
-rw-r--r--databases/p5-DBD-Pg/Makefile6
-rw-r--r--databases/p5-DBD-XBase/Makefile5
-rw-r--r--databases/p5-DBD-mysql/Makefile5
-rw-r--r--databases/p5-DBI-137/Makefile6
-rw-r--r--databases/p5-DBI/Makefile6
-rw-r--r--databases/p5-DBZ_File/Makefile7
-rw-r--r--databases/p5-GDBM/Makefile6
-rw-r--r--databases/p5-MLDBM/Makefile5
-rw-r--r--databases/p5-Msql/Makefile10
-rw-r--r--databases/p5-Mysql/Makefile5
-rw-r--r--databases/p5-Pg/Makefile9
-rw-r--r--databases/p5-SQL-Statement/Makefile6
-rw-r--r--databases/p5-Text-Query-SQL/Makefile1
-rw-r--r--databases/p5-hp200lx-db/Makefile8
-rw-r--r--databases/p5-hp200lx-db/pkg-descr1
20 files changed, 23 insertions, 87 deletions
diff --git a/databases/p5-ApacheDBILogConfig/Makefile b/databases/p5-ApacheDBILogConfig/Makefile
index 4a8ecf132496..ad091096d6c6 100644
--- a/databases/p5-ApacheDBILogConfig/Makefile
+++ b/databases/p5-ApacheDBILogConfig/Makefile
@@ -18,10 +18,6 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VERSION}/Apache/DBI.pm:${
${LOCALBASE}/lib/perl5/site_perl/${PERL_VERSION}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
${LOCALBASE}/libexec/apache/libperl.so:${PORTSDIR}/www/mod_perl
-USE_PERL5= yes
-
-do-configure:
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
- PREFIX="${PREFIX}" CC="${CC}" CCFLAGS="${CFLAGS}"
+PERL_CONFIGURE= yes
.include <bsd.port.mk>
diff --git a/databases/p5-ApacheDBILogger/Makefile b/databases/p5-ApacheDBILogger/Makefile
index 779613a1679c..396f1565a4b7 100644
--- a/databases/p5-ApacheDBILogger/Makefile
+++ b/databases/p5-ApacheDBILogger/Makefile
@@ -18,13 +18,9 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VERSION}/Apache/DBI.pm:${
${LOCALBASE}/lib/perl5/site_perl/${PERL_VERSION}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
${LOCALBASE}/libexec/apache/libperl.so:${PORTSDIR}/www/mod_perl
-USE_PERL5= yes
+PERL_CONFIGURE= yes
MAN3= Apache::DBILogger.3
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-do-configure:
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
- PREFIX="${PREFIX}" CC="${CC}" CCFLAGS="${CFLAGS}"
-
.include <bsd.port.mk>
diff --git a/databases/p5-BerkeleyDB/Makefile b/databases/p5-BerkeleyDB/Makefile
index 230da27eed00..d02d868b25d8 100644
--- a/databases/p5-BerkeleyDB/Makefile
+++ b/databases/p5-BerkeleyDB/Makefile
@@ -18,7 +18,6 @@ LIB_DEPENDS= db3.1:${PORTSDIR}/databases/db3
PERL_CONFIGURE= yes
ALL_TARGET= all test
-USE_PERL5= yes
post-patch:
${PERL} -pi -e 's|^(INCLUDE\s+= )./libraries/.*$$|$$1\$(PREFIX)/include/db3|g; \
diff --git a/databases/p5-DBD-CSV/Makefile b/databases/p5-DBD-CSV/Makefile
index 1a94a16cf932..85a1e8962d54 100644
--- a/databases/p5-DBD-CSV/Makefile
+++ b/databases/p5-DBD-CSV/Makefile
@@ -19,14 +19,11 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/SQL/Statement.pm:${PORTSDIR}/databases/p5-SQL-Statement
RUN_DEPENDS= ${BUILD_DEPENDS}
-USE_PERL5= YES
+PERL_CONFIGURE= YES
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= DBD::File.3 \
DBD::CSV.3 \
Bundle::DBD::CSV.3
-do-configure:
- @cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${PERL5} Makefile.PL
-
.include <bsd.port.mk>
diff --git a/databases/p5-DBD-Pg-13/Makefile b/databases/p5-DBD-Pg-13/Makefile
index 2047e4c19e35..d89386f53bca 100644
--- a/databases/p5-DBD-Pg-13/Makefile
+++ b/databases/p5-DBD-Pg-13/Makefile
@@ -17,14 +17,10 @@ MAINTAINER= demon@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
-USE_PERL5= yes
+PERL_CONFIGURE= yes
MAKE_ENV= POSTGRES_INCLUDE=${PREFIX}/pgsql/include POSTGRES_LIB=${PREFIX}/pgsql/lib
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= DBD::Pg.3 DBD::dbd-pg.3
-do-configure:
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
- CC="${CC}" CCFLAGS="${CFLAGS}"
-
.include <bsd.port.mk>
diff --git a/databases/p5-DBD-Pg/Makefile b/databases/p5-DBD-Pg/Makefile
index 2047e4c19e35..d89386f53bca 100644
--- a/databases/p5-DBD-Pg/Makefile
+++ b/databases/p5-DBD-Pg/Makefile
@@ -17,14 +17,10 @@ MAINTAINER= demon@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
-USE_PERL5= yes
+PERL_CONFIGURE= yes
MAKE_ENV= POSTGRES_INCLUDE=${PREFIX}/pgsql/include POSTGRES_LIB=${PREFIX}/pgsql/lib
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= DBD::Pg.3 DBD::dbd-pg.3
-do-configure:
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
- CC="${CC}" CCFLAGS="${CFLAGS}"
-
.include <bsd.port.mk>
diff --git a/databases/p5-DBD-XBase/Makefile b/databases/p5-DBD-XBase/Makefile
index a91b2f3570f6..880348cc13a1 100644
--- a/databases/p5-DBD-XBase/Makefile
+++ b/databases/p5-DBD-XBase/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= ilia@cgu.chel.su
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-USE_PERL5= yes
+PERL_CONFIGURE= yes
GZIP= -9
@@ -25,9 +25,6 @@ MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= XBase::FAQ.3 XBase::Memo.3 XBase::Index.3 XBase.3 \
DBD::XBase.3 XBase::Base.3
-do-configure:
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
-
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/bin/dbfdump ${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/bin/indexdump ${PREFIX}/bin
diff --git a/databases/p5-DBD-mysql/Makefile b/databases/p5-DBD-mysql/Makefile
index 1be4a86d59fc..2769b1718f40 100644
--- a/databases/p5-DBD-mysql/Makefile
+++ b/databases/p5-DBD-mysql/Makefile
@@ -20,10 +20,10 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Data/ShowTable.pm:${
RUN_DEPENDS= ${BUILD_DEPENDS}
LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+PERL_CONFIGURE= yes
CONFIGURE_ARGS= PREFIX=${PREFIX} CC="${CC}" CCFLAGS="${CFLAGS}" \
--noprompt --mysql-install --nomsql-install
CONFIGURE_ENV= MYSQL_HOME=${PREFIX} IN_MYSQL_DISTRIBUTION=1
-USE_PERL5= yes
MAN1= dbimon.1
MAN3= Bundle::DBD::mysql.3 \
@@ -31,8 +31,7 @@ MAN3= Bundle::DBD::mysql.3 \
Mysql.3
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-do-configure:
+pre-configure:
@${PERL} -i -e 's| -lgz||' ${WRKSRC}/lib/DBD/mysql/Install.pm
- @cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${PERL5} Makefile.PL ${CONFIGURE_ARGS}
.include <bsd.port.mk>
diff --git a/databases/p5-DBI-137/Makefile b/databases/p5-DBI-137/Makefile
index 62242ca23840..aa8f111d0387 100644
--- a/databases/p5-DBI-137/Makefile
+++ b/databases/p5-DBI-137/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= vanilla@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/RPC/PlServer.pm:${PORTSDIR}/net/p5-PlRPC
-USE_PERL5= yes
+PERL_CONFIGURE= yes
MAN1= dbiproxy.1 \
dbish.1
@@ -34,8 +34,4 @@ MAN3= Bundle::DBI.3 \
Win32::DBIODBC.3
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-do-configure:
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
- PREFIX="${PREFIX}" CC="${CC}" CCFLAGS="${CFLAGS}"
-
.include <bsd.port.mk>
diff --git a/databases/p5-DBI/Makefile b/databases/p5-DBI/Makefile
index 62242ca23840..aa8f111d0387 100644
--- a/databases/p5-DBI/Makefile
+++ b/databases/p5-DBI/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= vanilla@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/RPC/PlServer.pm:${PORTSDIR}/net/p5-PlRPC
-USE_PERL5= yes
+PERL_CONFIGURE= yes
MAN1= dbiproxy.1 \
dbish.1
@@ -34,8 +34,4 @@ MAN3= Bundle::DBI.3 \
Win32::DBIODBC.3
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-do-configure:
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
- PREFIX="${PREFIX}" CC="${CC}" CCFLAGS="${CFLAGS}"
-
.include <bsd.port.mk>
diff --git a/databases/p5-DBZ_File/Makefile b/databases/p5-DBZ_File/Makefile
index d3b6160d295c..3cafee3b2aaf 100644
--- a/databases/p5-DBZ_File/Makefile
+++ b/databases/p5-DBZ_File/Makefile
@@ -15,15 +15,12 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= leeym@cae.ce.ntu.edu.tw
-USE_PERL5= yes
+PERL_CONFIGURE= yes
+CONFIGURE_ENV= -I${FILESDIR} -L${FILESDIR}
WRKSRC= ${WRKDIR}/DBZ_File
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= DBZ_File.3
-do-configure:
- @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} -I ${FILESDIR} Makefile.PL \
- LIBS= INC=-I${FILESDIR} CC="${CC}" CCFLAGS="${CFLAGS}"
-
.include <bsd.port.mk>
diff --git a/databases/p5-GDBM/Makefile b/databases/p5-GDBM/Makefile
index 228437c9346b..1204fe74c586 100644
--- a/databases/p5-GDBM/Makefile
+++ b/databases/p5-GDBM/Makefile
@@ -18,15 +18,11 @@ MAINTAINER= ports@FreeBSD.ORG
LIB_DEPENDS= gdbm.2:${PORTSDIR}/databases/gdbm
-USE_PERL5= yes
+PERL_CONFIGURE= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/ext/GDBM_File
MAN3= GDBM_File.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-do-configure:
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
- CC="${CC}" CCFLAGS="${CFLAGS}"
-
.include <bsd.port.mk>
diff --git a/databases/p5-MLDBM/Makefile b/databases/p5-MLDBM/Makefile
index 89d79f9c46c8..903a4da5e633 100644
--- a/databases/p5-MLDBM/Makefile
+++ b/databases/p5-MLDBM/Makefile
@@ -17,12 +17,9 @@ MAINTAINER= ports@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/FreezeThaw.pm:${PORTSDIR}/devel/p5-FreezeThaw \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
-USE_PERL5= yes
+PERL_CONFIGURE= yes
MAN3= MLDBM.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-do-configure:
- @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
-
.include <bsd.port.mk>
diff --git a/databases/p5-Msql/Makefile b/databases/p5-Msql/Makefile
index c75df28f5d20..463f87ca2746 100644
--- a/databases/p5-Msql/Makefile
+++ b/databases/p5-Msql/Makefile
@@ -18,17 +18,13 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libmsql.a:${PORTSDIR}/databases/msql \
${LOCALBASE}/lib/perl5/site_perl/Data/ShowTable.pm:${PORTSDIR}/devel/p5-Data-ShowTable \
${LOCALBASE}/lib/perl5/site_perl/DBI.pm:${PORTSDIR}/databases/p5-DBI
-CONFIGURE_ENV+= PREFIX=${PREFIX} MSQL_HOME=${PREFIX}
+BROKEN= DEPENDS on databases/msql which is currently BROKEN, also perl5 upgrade
-USE_PERL5= YES
+PERL_CONFIGURE= YES
+CONFIGURE_ENV+= PREFIX=${PREFIX} MSQL_HOME=${PREFIX}
MAN1= pmsql.1 dbimon.1
MAN3= Msql.3 DBD::mSQL.3
MAN3PREFIX= ${PREFIX}/lib/perl5
-BROKEN= DEPENDS on databases/msql which is currently BROKEN, also perl5 upgrade
-
-do-configure:
- @cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${PERL5} Makefile.PL
-
.include <bsd.port.mk>
diff --git a/databases/p5-Mysql/Makefile b/databases/p5-Mysql/Makefile
index 1be4a86d59fc..2769b1718f40 100644
--- a/databases/p5-Mysql/Makefile
+++ b/databases/p5-Mysql/Makefile
@@ -20,10 +20,10 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Data/ShowTable.pm:${
RUN_DEPENDS= ${BUILD_DEPENDS}
LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+PERL_CONFIGURE= yes
CONFIGURE_ARGS= PREFIX=${PREFIX} CC="${CC}" CCFLAGS="${CFLAGS}" \
--noprompt --mysql-install --nomsql-install
CONFIGURE_ENV= MYSQL_HOME=${PREFIX} IN_MYSQL_DISTRIBUTION=1
-USE_PERL5= yes
MAN1= dbimon.1
MAN3= Bundle::DBD::mysql.3 \
@@ -31,8 +31,7 @@ MAN3= Bundle::DBD::mysql.3 \
Mysql.3
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-do-configure:
+pre-configure:
@${PERL} -i -e 's| -lgz||' ${WRKSRC}/lib/DBD/mysql/Install.pm
- @cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${PERL5} Makefile.PL ${CONFIGURE_ARGS}
.include <bsd.port.mk>
diff --git a/databases/p5-Pg/Makefile b/databases/p5-Pg/Makefile
index 9615b8119e8c..cc9fd909f469 100644
--- a/databases/p5-Pg/Makefile
+++ b/databases/p5-Pg/Makefile
@@ -10,23 +10,18 @@ PORTVERSION= 1.9.0
CATEGORIES= databases perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Pg
-DISTNAME= pgsql_perl5-${PORTVERSION}
PKGNAMEPREFIX= p5-
+DISTNAME= pgsql_perl5-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
-USE_PERL5= yes
-
+PERL_CONFIGURE= yes
POSTGRES_HOME?= ${LOCALBASE}/pgsql
MAKE_ENV+= POSTGRES_HOME=${POSTGRES_HOME}
MAN3= Pg.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-do-configure:
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
- CC="${CC}" CCFLAGS="${CFLAGS}"
-
.include <bsd.port.mk>
diff --git a/databases/p5-SQL-Statement/Makefile b/databases/p5-SQL-Statement/Makefile
index 129c0f42fcae..684c8103c160 100644
--- a/databases/p5-SQL-Statement/Makefile
+++ b/databases/p5-SQL-Statement/Makefile
@@ -14,13 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= wolman@cs.washington.edu
-USE_PERL5= yes
+PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= SQL::Eval.3 SQL::Statement.3
-do-configure:
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
- CC="${CC}" CCFLAGS="${CFLAGS}"
-
.include <bsd.port.mk>
diff --git a/databases/p5-Text-Query-SQL/Makefile b/databases/p5-Text-Query-SQL/Makefile
index 1f062df3a9a4..a32eb913c131 100644
--- a/databases/p5-Text-Query-SQL/Makefile
+++ b/databases/p5-Text-Query-SQL/Makefile
@@ -17,7 +17,6 @@ MAINTAINER= tobez@tobez.org
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Text/Query.pm:${PORTSDIR}/textproc/p5-Text-Query
RUN_DEPENDS= ${BUILD_DEPENDS}
-USE_PERL5= yes
PERL_CONFIGURE= yes
MAN3= Text::Query::BuildSQLMifluz.3 Text::Query::BuildSQLMySQL.3 \
diff --git a/databases/p5-hp200lx-db/Makefile b/databases/p5-hp200lx-db/Makefile
index c2ecdc1520d5..4c58c12c377a 100644
--- a/databases/p5-hp200lx-db/Makefile
+++ b/databases/p5-hp200lx-db/Makefile
@@ -14,12 +14,6 @@ PKGNAMEPREFIX= p5-
MAINTAINER= g.gonter@ieee.org
-USE_PERL5= yes
-
-# MAN3= HP200LX::DB.3
-MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-
-do-configure:
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+PERL_CONFIGURE= yes
.include <bsd.port.mk>
diff --git a/databases/p5-hp200lx-db/pkg-descr b/databases/p5-hp200lx-db/pkg-descr
index c358cae63c8e..330c76a072bc 100644
--- a/databases/p5-hp200lx-db/pkg-descr
+++ b/databases/p5-hp200lx-db/pkg-descr
@@ -19,4 +19,3 @@ array tie implementation to access database data records
FETCH retrieve a record
STORE store a record
$db->get_last_index () return highest index
-