aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
Diffstat (limited to 'databases')
-rw-r--r--databases/mariadb-connector-c/Makefile3
-rw-r--r--databases/mysql-connector-c++/Makefile2
-rw-r--r--databases/xapian-bindings12/Makefile3
3 files changed, 8 insertions, 0 deletions
diff --git a/databases/mariadb-connector-c/Makefile b/databases/mariadb-connector-c/Makefile
index 81f5489f1b4f..0d04ba666f71 100644
--- a/databases/mariadb-connector-c/Makefile
+++ b/databases/mariadb-connector-c/Makefile
@@ -19,6 +19,9 @@ COMMENT= MariaDB database connector for C
LICENSE= LGPL21
+BROKEN_armv6= fails to configure: CMake Error: Generator: execution of make failed
+BROKEN_powerpc64= fails to compile: my_stmt_codec.c: error: invalid use of void expression
+
CONFLICTS_INSTALL= mariadb[0-9]*-client-* \
mariadb102-server-* \
mysql[0-9]*-client-* \
diff --git a/databases/mysql-connector-c++/Makefile b/databases/mysql-connector-c++/Makefile
index 144ab909ed0d..ef4abf3dcb17 100644
--- a/databases/mysql-connector-c++/Makefile
+++ b/databases/mysql-connector-c++/Makefile
@@ -14,6 +14,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libboost_regex.so:devel/boost-libs
+BROKEN_powerpc64= fails to configure: the compiler doesn't support C++11
+
USES= cmake:outsource mysql ssl
USE_LDCONFIG= yes
CMAKE_ARGS= -DDOC_DESTINATION="${DOCSDIR}"
diff --git a/databases/xapian-bindings12/Makefile b/databases/xapian-bindings12/Makefile
index 0ea509fd66f6..18966929c8f3 100644
--- a/databases/xapian-bindings12/Makefile
+++ b/databases/xapian-bindings12/Makefile
@@ -22,6 +22,9 @@ OPTIONS_DEFINE= DOCS LUA PHP PYTHON RUBY
OPTIONS_DEFAULT=PHP PYTHON RUBY
OPTIONS_SUB= yes
+# BROKEN: ruby.h: error: wrong number of arguments specified for 'deprecated' attribute
+OPTIONS_EXCLUDE_powerpc64= RUBY
+
PORTSCOUT= limitw:1,even
CONFIGURE_ARGS= --datarootdir=${DATADIR} --docdir=${DOCSDIR} \