aboutsummaryrefslogtreecommitdiff
path: root/deskutils/abacus
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/abacus')
-rw-r--r--deskutils/abacus/Makefile2
-rw-r--r--deskutils/abacus/files/patch-calc-yydefines.h15
2 files changed, 16 insertions, 1 deletions
diff --git a/deskutils/abacus/Makefile b/deskutils/abacus/Makefile
index f54aa9850b79..710adfd9f4eb 100644
--- a/deskutils/abacus/Makefile
+++ b/deskutils/abacus/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= http://www-cad.eecs.berkeley.edu/HomePages/aml/abacus/ \
PATCH_SITES= ${MASTER_SITE_LOCAL}
PATCH_SITE_SUBDIR= steve
-PATCHFILES= ${PKGNAME}.patch.gz
+PATCHFILES= ${PORTNAME}-${PORTVERSION}.patch.gz
MAINTAINER= ports@FreeBSD.org
COMMENT= Spread sheet for X Window System
diff --git a/deskutils/abacus/files/patch-calc-yydefines.h b/deskutils/abacus/files/patch-calc-yydefines.h
new file mode 100644
index 000000000000..48c23f9ff79f
--- /dev/null
+++ b/deskutils/abacus/files/patch-calc-yydefines.h
@@ -0,0 +1,15 @@
+--- calc/yydefines.h.orig Thu Aug 20 23:49:19 1998
++++ calc/yydefines.h Tue Mar 4 20:40:04 2003
+@@ -7,9 +7,10 @@
+ extern int parse_return_code;
+ double gettime(char *);
+
+-void yyrestart();
++#include <stdio.h>
++void yyrestart(FILE *);
+ int yyerror(char *);
+-int yylex();
++int yylex(void);
+ char *yysave(char *);
+
+