aboutsummaryrefslogtreecommitdiff
path: root/deskutils/alexandria/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/alexandria/Makefile')
-rw-r--r--deskutils/alexandria/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/deskutils/alexandria/Makefile b/deskutils/alexandria/Makefile
new file mode 100644
index 000000000000..f1700f2c3847
--- /dev/null
+++ b/deskutils/alexandria/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: Alexandria
+# Date created: 18 March 2005
+# Whom: Mitsuru YOSHIDA <mitsuru@riken.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= alexandria
+PORTVERSION= 0.5.0
+CATEGORIES= deskutils ruby
+MASTER_SITES= http://rubyforge.org/frs/download.php/3445/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= mitsuru@riken.jp
+COMMENT= A GNOME application to help you manage your book collection
+
+RUN_DEPENDS= ${RUBY_SITELIBDIR}/amazon.rb:${PORTSDIR}/www/ruby-amazon \
+ ${RUBY_SITEARCHLIBDIR}/gettext/_locale.so:${PORTSDIR}/devel/ruby-gettext \
+ ${RUBY_SITEARCHLIBDIR}/libglade2.so:${PORTSDIR}/devel/ruby-libglade2 \
+ ${RUBY_SITEARCHLIBDIR}/gnome2.so:${PORTSDIR}/x11/ruby-gnome2 \
+ ${RUBY_SITEARCHLIBDIR}/gdk_pixbuf2.so:${PORTSDIR}/graphics/ruby-gdk_pixbuf2 \
+ ${RUBY_SITEARCHLIBDIR}/gconf2.so:${PORTSDIR}/devel/ruby-gconf2
+
+USE_RUBY= yes
+USE_RUBY_SETUP= yes
+RUBY_SETUP= install.rb
+
+DOCS= NEWS README TODO
+
+RUBY_REQUIRE= Ruby > 180
+
+.include <bsd.port.pre.mk>
+
+.if !defined(RUBY_PROVIDED)
+IGNORE= only works with Ruby 1.8.0 or later
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODDOCDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
+.endif
+
+.include <bsd.port.post.mk>