aboutsummaryrefslogtreecommitdiff
path: root/deskutils/cdcat/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/cdcat/Makefile')
-rw-r--r--deskutils/cdcat/Makefile94
1 files changed, 39 insertions, 55 deletions
diff --git a/deskutils/cdcat/Makefile b/deskutils/cdcat/Makefile
index 9ef7b755f317..91db9d53bd62 100644
--- a/deskutils/cdcat/Makefile
+++ b/deskutils/cdcat/Makefile
@@ -6,74 +6,58 @@
#
PORTNAME= cdcat
-PORTVERSION= 1.01b # >1.01 as b doesn't stay for 'beta'
-PORTREVISION= 5
+PORTVERSION= 1.3
CATEGORIES= deskutils
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION} \
- http://cdcat.sourceforge.net/
-
-DISTNAME= CdCat-${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A QT based tool for offline CD/DVD/disk catalogs
-BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
-LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
-WRKSRC= ${WRKDIR}/CdCat-${PORTVERSION}/src
+BUILD_WRKSRC= ${WRKSRC}/src
USE_BZIP2= yes
-USE_QT_VER= 3
-QTDIR?= ${QT_PREFIX}
-USE_GMAKE= yes
-MAKE_ENV= QTDIR="${QTDIR}" MAKE="${GMAKE}" \
- QMAKESPEC="${LOCALBASE}/share/qt/mkspecs/freebsd-g++"
+USE_QT_VER= 4
+QT_COMPONENTS= corelib gui qt3support xml \
+ linguist_build moc_build qmake_build uic_build
+MAKE_JOBS_SAFE= yes
-#PLIST= ${WRKDIR}/pkg-plist
+LRELEASE= ${QT_PREFIX}/bin/lrelease-qt4
.include <bsd.port.pre.mk>
+PORTDOCS= Authors ChangeLog README TRANSLATORS_README
PLIST_FILES= bin/cdcat \
- share/cdcat/Authors \
- share/cdcat/COPYING \
- share/cdcat/ChangeLog \
- share/cdcat/README \
- share/cdcat/TRANSLATORS_README \
- share/cdcat/cdcat.png \
- share/cdcat/translations/cdcat_cz.qm \
- share/cdcat/translations/cdcat_de.qm \
- share/cdcat/translations/cdcat_el.qm \
- share/cdcat/translations/cdcat_es.qm \
- share/cdcat/translations/cdcat_fr.qm \
- share/cdcat/translations/cdcat_hu.qm \
- share/cdcat/translations/cdcat_id.qm \
- share/cdcat/translations/cdcat_it.qm \
- share/cdcat/translations/cdcat_pl.qm \
- share/cdcat/translations/cdcat_pt.qm \
- share/cdcat/translations/cdcat_sk.qm \
- share/cdcat/translations/cdcat_sr.qm
-PLIST_DIRS= share/cdcat/translations \
- share/cdcat
-
-post-patch:
- @${REINPLACE_CMD} -e 's|importGtktalogCsv\:\:importGtktalogCsv|importGtktalogCsv|' \
- ${WRKSRC}/import.h
-
-pre-configure:
- cd ${WRKSRC} && ${MAKE_ENV} qmake cdcat.pro
-.if defined(WITH_KDE)
-PLIST_DIRS+= share/apps/cdcat
-PLIST_FILES+= share/applications/kde/cdcat.desktop \
- share/apps/cdcat/cdcat.png
+ %%DATADIR%%/cdcat.png \
+ %%DATADIR%%/translations/cdcat_cz.qm \
+ %%DATADIR%%/translations/cdcat_de.qm \
+ %%DATADIR%%/translations/cdcat_el.qm \
+ %%DATADIR%%/translations/cdcat_es.qm \
+ %%DATADIR%%/translations/cdcat_hu.qm \
+ %%DATADIR%%/translations/cdcat_id.qm \
+ %%DATADIR%%/translations/cdcat_pl.qm \
+ %%DATADIR%%/translations/cdcat_pt.qm \
+ %%DATADIR%%/translations/cdcat_sk.qm
+PLIST_DIRS= %%DATADIR%%/translations \
+ %%DATADIR%%
+
+do-configure:
+ @${LRELEASE} ${BUILD_WRKSRC}/cdcat.pro
+ @cd ${BUILD_WRKSRC} && ${QMAKE} cdcat.pro ${QMAKEFLAGS}
+
+do-install:
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/cdcat ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/cdcat.png ${DATADIR}
+ @${MKDIR} ${DATADIR}/translations
+ ${INSTALL_DATA} ${BUILD_WRKSRC}/lang/*.qm ${DATADIR}/translations
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
.endif
-post-install:
-.if defined(WITH_KDE)
- ${INSTALL_DATA} ${WRKSRC}/../KDE/cdcat.desktop ${LOCALBASE}/share/applications/kde
- ${MKDIR} ${LOCALBASE}/share/apps/cdcat
- ${LN} ${LOCALBASE}/share/cdcat/cdcat.png ${LOCALBASE}/share/apps/cdcat
-.endif
-
- ${STRIP_CMD} ${LOCALBASE}/bin/cdcat
-
.include <bsd.port.post.mk>